[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 193
  • Last Modified:

die evil frames


OK, I'm not the greatest web designer in the world and this will probably be an easy question.  I have a web page for a small co. I'm starting:
http://members.home.com/liquitech

did it in frames because the title at the top and navigation on the left include a few large images, I don't want to have to reload them every page when format stays the same.  If the windows background is white, they look great but if you change the background of your windows to another color, splat!  each frame is surrounded by the color you chose.

So, my goal:
I want, when you look at the page with a background color other than white, you don't see that color.  Only white.  
Though I would like to keep it with frames, I will award more points if needed for a better way which is still efficient and doesn't effect the performance of each page.

I'm starting this at 50 points in the hopes that there's an easy answer that will make me feel stoopid.  COMMENTS ONLY PLEASE.
0
1cell
Asked:
1cell
1 Solution
 
ManoloMACommented:
Try putting the bgcolor of the body to white:


<BODY bgcolor="#FFFFFF"> <!-- I think this is the white -->


in all frames pages.
0
 
nine7sicksCommented:
bgcolor="white"

it is as simple as that..just add that to your body tag
so it looks like this

<body bgcolor="white">

I know the other person put it in hex code for you but don't worry about that most of the name colors work in the browsers now days i.e. yellow, navy, blue, black.  Anything you can think of.
0
 
DreamMasterCommented:
just a brief comment which has nothing to do with the bgcolor....i just had a look at your pages and noticed a light grey block around the images.... this is caused by the transparency you are using....to solve that...you could create a background layer that is white and i am talking about Photoshop or Paintshop here...not HTML, and flatten the image like that....no need for transparency as your background is white anyway.

The little grey block around your images is caused by the shadows you are using...when saving the image as a transparant gif it's very hard to set every grey color to transparent except for the shadows. so making the background color the same as the background of the image and NOT setting transparency solves that too....

geez...long story for something as simple as that....

Max Davidse
http://www.gamerzdelight.com/
0
 
1cellAuthor Commented:
holy________!!!!!  
It happened!!!
I feel stoopid!!! yes with two O's!!!

I can't believe I overlooked the bgcolor.  Like I said, I am not a great web author but come on!!! forget about the bgcolor????  Jeeeez.


As for the grey around the images, I was aware of that and it's actually what got me on this kick.  It was my plan to change them to regular GIF's once I had this solved.

Thanks all!!!
0
 
DreamMasterCommented:
lol....well...as long as it helps you.....*smiles*

Max Davidse
0

Featured Post

Upgrade your Question Security!

Add Premium security features to your question to ensure its privacy or anonymity. Learn more about your ability to control Question Security today.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now