need help about mounting floppies and sound card drivers!!!

i have two problems now(im using caldera openlinux version 2.2.5 i think):
1.i successfully mounted my windows partition, but when i tried to mount the floppy, it said something about driver missing (try insmod driver?) when i typed "mount -t msdos /dev/fd0 /mnt/floppy" i tried to load some driver using COAS (caldera open administration system) called ide-floppy and rebooted, but still nothing. is is because i am missing a driver? according to windows system manager, i have a MITBISHI LS-120 SLIP 40 floppy drive. and if i do get the driver, how do i install it?
2. on my laptop (same one as above) i tried to configure sound (through COAS as well) and i loaded the modules sound, uart412(its 412 i think), and sb. when i try to play wav files or cds, it seems to play them, with the time on the clock progressing as if the sound is playing. but no sound comes out. i tried cranking the volume to full and used aumix to set system vol to full too, but no sound. i have internal speakers with the sound card being Yamaha YM715 and 704B. what should i do, do i need some different drivers and how to setup?
sorry its a lot of questions but please reply.
scipi05Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

fremsleyCommented:
the /dev/fd0 device is only for standard floppy drives. your ls-120 is propably an atapi device connencted to the ide interface. depending on how your drive is connected, try:

  /dev/hda : ide 1, master. this is propably your hard disk
  /dev/hdb : ide 1, slave
  /dev/hdc : ide 2, master
  /dev/hdd : ide 2, slave
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
fremsleyCommented:
About the sound problem: I don't think there is a problem with the drivers, they would usually complain when they do not find the hardware they want. It's more likely some mixer setting; have you disabled muting for all channels and set master and channel volumes to resonable values?
0
scipi05Author Commented:
I solved the floppy issue, but I set all the mixer values to full and still no traces of sound. I'm looking for Yamaha drivers, but I don't think that's the problem, because the computer thinks its playing. Any ideas?
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

ReinierCommented:
You could try selecting the CD channel as the recording source in your mixer. For some reason I needed this in kmix to get sound from the CD.
0
Zero050300Commented:
What type of Floopy ATAPI or IDE?
0
scipi05Author Commented:
Thanks, it identified the floppy as /dev/hdd instead of /dev/floppy as I thought. For soundcard, I just found that I needed ALSA. Thanks.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.