Quick Report Problems with Delphi 4

I have a form on which I have placed a TTable component which connects to a paradox database.
Also on the form I have a quickreport and on the detail band I have placed a TQRDBTEXT component which looks at one of the fields on my database.

In Delphi 3 the report works, displating the field for all of the records in the database.

But in Delphi 4, the report only displays one record of the database.

Can anyone point me into any direction ?
LVL 1
chunky1Asked:
Who is Participating?

Improve company productivity with a Business Account.Sign Up

x
 
lgmmConnect With a Mentor Commented:
you must select the quick report form and direct it to de database that you are using , this is a common error that i had , always was the same thing

other thing is the sql that must have the datasourse directioned to your database but the mostr common is the qrform
0
 
NetoManCommented:
I assume you did recompile the form, so :

Check all the controls in the report (detailband, fields, groupbands) to see if all the properties are all right placed... maybe one is misplaced or missing.

There is no other thing I can Imagine...


NetoMan :)


0
 
pamorimCommented:
Take a look on your quickreport
dataset and check for you TTable!
0
 
chunky1Author Commented:
Cheers!

It works.

This is a setting that I didn't even notice.

0
 
lgmmCommented:
good look!!!
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.