Solved

External modem problem

Posted on 2000-05-01
7
167 Views
Last Modified: 2013-12-06
I'm running Red Hat 6.0, it successufuly
detects and initializes Rockwell External V.90 56k modem but when i try to dial any number using kppp or minicom it says "No dialtone" although that i hear the dialtone from the modem. Anyone have suggestions?
0
Comment
Question by:Peter043000
7 Comments
 
LVL 40

Expert Comment

by:jlevie
ID: 2765765
Can you run the "Modem query" in kppp successfully?
0
 

Expert Comment

by:grater120898
ID: 2769040
If not, can you run pppconfig, and use the command ppp-go -c (or ppp-on) in an X terminal? pppconfig is available from Debian at http://www.debian.org.
0
 
LVL 2

Expert Comment

by:EatEmAndSmile
ID: 2769608
Before trying to connect anywhere, you should check if the communication with the modem is ok. For that, run:

 minicom -s /dev/modem

 as root and see if you can query the modem with a few AT commands. Once this step is cool, we may proceed.

 Also make sure you're setting the speed for your modem port at startup, like putting a line in /etc/rc.d/rc.serial that would look like:

 setserial /dev/modem spd_vhi

 This sets the port to 115200bps, needed for high speed modems, 28800 and higher.

 Good luck!
0
Threat Intelligence Starter Resources

Integrating threat intelligence can be challenging, and not all companies are ready. These resources can help you build awareness and prepare for defense.

 

Author Comment

by:Peter043000
ID: 2777367
Yes i query the modem successfully with kppp i write AT and initialize the modem but when i try to dial something it says "No dialtone" although that i can hear the dialtone from the modem. I think that i should make the dial programm not to wait for dialtone and to start dialing as soon as i hear the dialtone from it.
0
 
LVL 2

Accepted Solution

by:
EatEmAndSmile earned 63 total points
ID: 2777754
To do so you just add the "X3" command to your modem string. This way it will dial out as soon as it pick up the line without waiting for the dial tone. This may cause it to fail sometimes, so you'll probably want to add some "," before the number to be dialed out. It makes the modem wait for a while before dialing, thus avoiding the fail.
0
 

Author Comment

by:Peter043000
ID: 2788330
Just what i needed to know, it now dials.
0
 
LVL 2

Expert Comment

by:EatEmAndSmile
ID: 2788472
Great! Enjoy!

 Best,

 Diogo.
0

Featured Post

Backup Your Microsoft Windows Server®

Backup all your Microsoft Windows Server – on-premises, in remote locations, in private and hybrid clouds. Your entire Windows Server will be backed up in one easy step with patented, block-level disk imaging. We achieve RTOs (recovery time objectives) as low as 15 seconds.

Join & Write a Comment

Suggested Solutions

Setting up Secure Ubuntu server on VMware 1.      Insert the Ubuntu Server distribution CD or attach the ISO of the CD which is in the “Datastore”. Note that it is important to install the x64 edition on servers, not the X86 editions. 2.      Power on th…
I. Introduction There's an interesting discussion going on now in an Experts Exchange Group — Attachments with no extension (http://www.experts-exchange.com/discussions/210281/Attachments-with-no-extension.html). This reminded me of questions tha…
Learn how to find files with the shell using the find and locate commands. Use locate to find a needle in a haystack.: With locate, check if the file still exists.: Use find to get the actual location of the file.:
Learn how to navigate the file tree with the shell. Use pwd to print the current working directory: Use ls to list a directory's contents: Use cd to change to a new directory: Use wildcards instead of typing out long directory names: Use ../ to move…

706 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

19 Experts available now in Live!

Get 1:1 Help Now