• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 471
  • Last Modified:

delphi32.exe

Everytime I run the compiler I get the
message "There is no disk in the drive A:\ " ....
How do you get rid of that?
0
Enej
Asked:
Enej
1 Solution
 
ptmcompCommented:
Look at your dpr file. Is there any unit refering to drive a: ?
0
 
EnejAuthor Commented:
This happens also when I run a blank project....
The minute I click "run" I get this msg.
I can put any dsk, in the drv. and it will work...
Looks like A:\ is default for all pr.
Idea???
0
 
ptmcompCommented:
What happens if you insert a blank disk. What's in your default *.dsk file?
0
Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
Stuart_JohnsonCommented:
Just out of curiosity, check that the "Start In" directory is not set to A: in Delphi's short-cut (under the Start button).

Stu.
0
 
EnejAuthor Commented:
When I insert a diskette (no importance whatsoever what is on it) the compiler runs!
0
 
mullet_attackCommented:
Have a look under project and environment options at the search path, debug path's etc. for a reference to A:
This happened to me once when I installed a component off a floppy, It added A: to my paths
0
 
EnejAuthor Commented:
Yes mullet,you are right....I just remembered that I installed a component from a floppy (so ofcourse in loading the components before compiling,delphi
looked for A:\...)...
Argh...I should have known...
Thank you !
0

Featured Post

VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now