Solved

ne2000 with redhat 6.1 on 486

Posted on 2000-05-02
13
478 Views
Last Modified: 2010-04-20
Hi,
I want to set up ne2000 NIC with my linx redhat 6.1.
The card as you all know is an ISA and NOT a PCI.
for some reason the installation did not recognized it.
what kernel module should I try and use?
how do I set it up or coz linux to recognize it?
the card is fine an did work on a different machine without any special configuration.
pls help
0
Comment
Question by:gschetrit
  • 6
  • 2
  • 2
  • +2
13 Comments
 

Expert Comment

by:dentener
ID: 2769471
I have a standard Ne2000 NIC too, and it works fine. You have to use the ne2000 kernel module and know the IRQ and I/O address of your NIC. The I/O address is often 0x300 and the IRQ is often 10 with standard ne2000 NIC.

Goto X and run linuxconf from a console. I used it to setup my NIC at home and afther playing with the IO and IRQ a while it worked.

I'm not an expert on Linux, so if I got it running, you'll get it running too.

Regards,

Paul
0
 

Expert Comment

by:dentener
ID: 2769482
I'm not exactly sure if the kernel module was named "ne2000" or just "ne". You'll have to try this too. By the way, linuxconf uses a dropdown list with kernel module names, so that should make it somewhat easier...
0
 
LVL 2

Expert Comment

by:EatEmAndSmile
ID: 2769509
Just try running (as root):

 modprobe ne io=0x300 irq=10

 or

 modprobe ne2000 io=0x300 irq=10

 You could try testing other IO and IRQ values, or consulting the manual or even running the DOS utility that most NE2000 compatible nics come with to check for these values or even changing them. Keeping them as 0x300 / 10 is always a good idea, by the way.

 Just a comment: I don't recommend running RedHat on 486s at all (or any other machine for performance's sake)

 Take care!
0
Master Your Team's Linux and Cloud Stack!

The average business loses $13.5M per year to ineffective training (per 1,000 employees). Keep ahead of the competition and combine in-person quality with online cost and flexibility by training with Linux Academy.

 

Expert Comment

by:dentener
ID: 2769534
Just curious, why is Redhat slower? It uses the same kernal as other distributions. And is it still slower if you stop all deamons you don't use (like sendmail, linuxconf etc. etc.)?
0
 

Author Comment

by:gschetrit
ID: 2772600
well for some reason it just doesn't wanna work. when I try to do network restart or just boot up the machine it tries to bring up eth0 and then it gives a FAIL message.
I tried to change the IO port and the IRQ as well.
what could it be???
0
 

Expert Comment

by:dentener
ID: 2772752
gschetrit,


Enter your computer BIOS and set Plug and Play OS to disabled...I couldn't get my NIC up and running too, but after setting Plug and play OS to disabled in my BIOS, it worked.


Regards,

Paul
0
 
LVL 2

Expert Comment

by:ksemat
ID: 2774345
try recompiling your kernel with support for ne2000 ethernet cards. also try setting it up as an ne card with io=0x300 irq=5 or io=0x320 irq=7
0
 
LVL 2

Expert Comment

by:EatEmAndSmile
ID: 2774460
The BIOS Setup tip is very valid. Recompiling your kernel is not necessary, though. There's no need to recompile if you've got the modules already. Try setting your BIOS to "Non-PNP OS".

 Best Regards...
0
 
LVL 2

Expert Comment

by:ksemat
ID: 2776318
I am beginning to think that either you don't have the modules or you are using the wrong modules
My box couldn't recognise my ne 2000 so I tried it on a windows machine to see what it is seen as and I realised it was actually seen as a realtek III
and when it boot it says pci ne2000 clone "realtek III"
0
 

Expert Comment

by:dentener
ID: 2776429
Realtek III is the chip used on the NIC. Most of those carts can either function in PNP modus or in ne2000 modus. Be sure it's functioning in ne2000 modus!! There came a floppy disk with the NIC with a programma called ezcfg or pnpcfg or something like that. Use it to check the configuration of the NIC. Set it in ne2000 modus and check the I/O and IRQ of the cart...
0
 

Expert Comment

by:dentener
ID: 2776437
oops, programma = program and cart = card. I'm Dutch so it isn't always easy to be 100% correct :-)
0
 
LVL 1

Accepted Solution

by:
st earned 20 total points
ID: 2776480
Some NE2000's do not work with the later 2.0.X kernels, but do following will enable them to work:

insmod 8390
insmod ne io=0x300 irq=3

(You may need to change the IO address and IRQ)

Then use ifconfig or netcfg or linuxconf to configure the card.


My Compaq 486 Redhat Print Server w/NE2000 NIC is working by above setting.
0
 

Author Comment

by:gschetrit
ID: 2807415
tnx,
btw, what is that 8390 thing???
0

Featured Post

Master Your Team's Linux and Cloud Stack

Come see why top tech companies like Mailchimp and Media Temple use Linux Academy to build their employee training programs.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Setting up Secure Ubuntu server on VMware 1.      Insert the Ubuntu Server distribution CD or attach the ISO of the CD which is in the “Datastore”. Note that it is important to install the x64 edition on servers, not the X86 editions. 2.      Power on th…
The purpose of this article is to show how we can create Linux Mint virtual machine using Oracle Virtual Box. To install Linux Mint we have to download the ISO file from its website i.e. http://www.linuxmint.com. Once you open the link you will see …
Learn several ways to interact with files and get file information from the bash shell. ls lists the contents of a directory: Using the -a flag displays hidden files: Using the -l flag formats the output in a long list: The file command gives us mor…
Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.

786 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question