• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 427
  • Last Modified:

TCP compression in Linux

How can I disable this? Is it also possible to enable a MTU (max transfer unit)setting to my connection? TCP compression loads at system startup, but my serial port modem doesn't support data compression, and that's what's slowing things down (in terms of Internet connectivity) and probably disconnecting me every few minutes (say, six or so...). How about IP header compression?
 

The modem I use for Linux works fine in Windows 98 and DOS mode, but for some reason, slows to a crawl in Linux in PPP mode. It's not a winmodem, but error control only works in 98 (I think). I have also successfully connected to terminals using Minicom in Linux.

I'm running a current distro of Peanut Linux from http://metalab.unc.edu/peanut. For more info on my PC and modem, please click on my ID.

Thanks in advance, grater
0
grater120898
Asked:
grater120898
  • 4
  • 3
1 Solution
 
modulusCommented:
I'm not sure that tcp compression really is your problem (the modem is AFAIK responsible under Linux 2.2 for compressing the data).  There are two likely candidates:
1. an IRQ/interrupt conflict
2. flow-control is not enabled.

In case 1 you would probably be seeing extreme slowness and eventually dumping out.  Check your bios/jumpers for what IRQ the modem is set to (or you could do it in windows).  Then make sure that you know which /dev/ttysX it is on and do:
/sbin/setserial -g /dev/ttysX
and it should report the I/O and IRQ and the flow rate and the UART.  Is the irq what you thought it should be?  If not then set it using /sbin/setserial /dev/ttySX irq X

In case 2 if there were a mismatch between the flow-rate from the computer to the modem and from the modem to the line then the buffer in the modem will overflow in time in both directions.  You can check in minicom to see if hardware control is enabled by:
AT&V
and look for the string "&K3".  If it's there then you have flow control enabled in the modem and then check that the device driver has flow control enabled with:
stty -a < /dev/ttySX
and look in the output.  There are strings prefixed with a minus and ones without - you want to see the non-prefixed string "crtscts"

If it's not there then you need to enable it using

stty crtscts < /dev/ttySX
(Eventually if these work you'll need to add the /sbin/setserial commands and the  stty commands to your system init scripts.  I'm betting on flow control being disabled .....)

If it's there then your problem is something else and I'm afraid the only other suggestion I would have would be to try and lower the flow rate that you send to the modem.

best wishes,
modulus
0
 
grater120898Author Commented:
Thanks...I'll try it. Found the .INF file in my c:\windows\inf dir for the modem with all the necessary commands.

back later,
grater
0
 
hewey01Commented:
Your info says you have a Rockwell 56K *PCI* MODEM. Almost all PCI modems are (cuasi)winmodems and most probably your modem has some functionality implemented in software. For what you say, your modem must include a serial UART in HW (the port is recognized) but most surely some processing in the DSP is programmed in Windows.

You will never use your modem in Linux as you do in Windows. This page:

http://www.leonardo.co.hu/hardware/modems.html

lists several modems using the Rockwell 56K HCF
Chipset as Winmodems. Too bad =(

One last hope: some programmable DSP such as the IBM MWave do work if you let Windows program it and the do a soft-reboot.

Hewey
0
The new generation of project management tools

With monday.com’s project management tool, you can see what everyone on your team is working in a single glance. Its intuitive dashboards are customizable, so you can create systems that work for you.

 
grater120898Author Commented:
You did not read my specs closely. I also mention that I have this modem:

*Global Village TelePort 56 X2 external serial port modem upgraded to v.90 (usable in Linux)*

That is the one I use in Linux.

Now that I put it here, any ideas as to how to remove the TCP compression? I know that my Rockwell only works in Windows and a DOS box in windows if necessary.
Thanks for the link too...seen it numerous times.

grater
0
 
grater120898Author Commented:
You did not read my specs closely. I also mention that I have this modem:

*Global Village TelePort 56 X2 external serial port modem upgraded to v.90 (usable in Linux)*

That is the one I use in Linux.

Now that I put it here, any ideas as to how to remove the TCP compression? I know that my Rockwell only works in Windows and a DOS box in windows if necessary.
Thanks for the link too...seen it numerous times.

grater
0
 
modulusCommented:
So what were the results of your investigations?  Do you have hardware flow control enabled and do you know what the IRQ settings are?  (ps. I note that you are looking at a C:\windows\inf directory to find out the latter.  Can't you just look at MyComputer->Settings for that?)
best wishes,
modulus
0
 
grater120898Author Commented:
It's all fine now...in the last few days, the ISP's (http://www.freewwweb.com) been upgrading their equipment. Probably the reason for the slow connections. Otherwise everything is OK. :)

HW flow, IRQ4 and I use settings from both the INF file and the PDF doc that came with the modem, which is X2, V.90, V.34 compatible

Thanks a lot,
grater

P.S. No viruses here...hope you're OK :).
0
 
modulusCommented:
Glad things are working.  I received the "virus" from colleagues and was able to enjoy looking at it but not executing it in my pine session.  Hope no one releases one of the mime extensions viruses for linux!
0

Featured Post

Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 4
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now