Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 281
  • Last Modified:

online speed (internet)

Hello, currently, I am using Redhat 6.1 with GNOME workstation, I got a problem with my internet, that is I feel that by using Linux to surfnet is much slower than Microsoft Windows, how can I configure it so that it's more faster ? (I am using Netscape 6.1, modem with 33.6 speed, Redhat Linux 6.1 GNOME workstation, Netscape 4.61 and i have configure my modem to the highest speed)
0
ahchong
Asked:
ahchong
1 Solution
 
hewey01Commented:
Are you using gnome-ppp or command line ppp??? (with ifup ppp0? or usernet?) Some options may not be activated, especially crtcts (hardware flow control)

Hewey
0
 
ahchongAuthor Commented:
I am using gnome-ppp, anyway, how to use command line ppp ?
0
 
modulusCommented:
Hi ahchong,
posting here on this unrelated question, becuase the question about xfs is locked!
Anwyay, I'm glad I could help but I don't give out my email or anything like that though as I am pretty busy adminstrating 32 machines and writing my own code and posting here.  I already get about 80 emails a day.

The directories that you ask about are where the actual descriptions of the fonts are stored by default for X.  You can find out about this by looking at the HOWTO's at the LDP www.ldp.org  I can really recommend that you download some of these (use File->SaveAs in Netscape to store them) to read at your leisure with your web-browser (You can view files locally by typing in file:/home/ahchong/filename.html  instead of http://somesite.somedomain.com/somefile.html). There is lots of inforamtion there perfect for a newby.  Also look for linuxnewbie.org.  

best wishes,
modulus
0
What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

 
modulusCommented:
Hi ahchong,
You say:
I am using gnome-ppp, anyway, how to use command line ppp ?

Well, strictly it's RHppp (the redhat ppp dialer - this is a graphical interface to the underlying ppp daemon pppd).  This daemon can be started in a text-console or on a terminal command-line using:
/sbin/ifup ppp0

The "ifup" is a script, you can do a :
more /sbin/ifup
to see what the script looks like, it just tests to see if other scripts are available and executable.  It's a relatively complex script, so don't bother too much about it until later.

One of the files that controls how the ppp daemon behaves is:

/etc/ppp/options

It may contain:
lock
crtscts
noauth
defaultroute
noipdefault
mtu
mru

It should at the least contain:
lock

These options are dependent to a large extent on the unique conditions created by your ISP.  You can read
man pppd
for an explanation of what each one does
I find it unlikely that it is "crtscts" that is your problem.  It is more likely to be that the mru and mtu need to be set to different values.

best wishes,
modulus

0
 
paulnicCommented:
you might try comparing the speeds of an FTP download of the same file under Windows and under Linux.

If they are much different, modem and dialer settings may be the issue, and chaning them may help.  If they are not very different, you may be encountering the unfortunate fact that Netscape is not equally well optimized for all platforms, that all GUIs are not created equally fast, and that Web pages may simply display slower under Netscape/Gnome/Linux.  I don't know if KDE would help, or adding RAM.

If you were were a Netscape manager deciding where to focus your best developers, which platform would you pick?

Also...if you are in fact running Netscape 6 Preview release 1 on Windows, you may need to wait for a version 6 on Linux to get a fair comparison.  The new "gecko" Web page rendering engine introduced with 6 is supposed to be faster than previous Netscape versions, including 4.x.
0
 
jaymzCommented:
I'm also using RedHat and I remember the times when speed was a problem. Now I fixed it with:
1) I downloaded and compiled the "irqtune" application. Don't worry, it doesn't need X and it does not need some extra resources. You can find it at http://www.best.com/~cae/irqtune/. This may boost your serial up to 3x its normal speed.
2) at the prompt type before connecting to the internet /bin/setserial /dev/modem spd_hi (or spd_vhi). You should replace /dev/modem with your configuration. Try spd_vhi if you have a modem that can do 115200.
0
 
ahchongAuthor Commented:
ok... no problem , after I fixed the problem, I am judge your answer :)
0
 
ahchongAuthor Commented:
Answer accepted
0

Featured Post

VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now