• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 196
  • Last Modified:

win 98 kernal locks at 100%

since UPGRADING from 95 to 98 (i hear that is probably the problem) I was having problems with my system running slow all of a sudden. I tracked it using Monitor and saw that opening a window (like netscape mail, Micro explorer or what ever) can suddenly lock my kernal processor at 100%! I can usually fix things by ctrl-alt-delete and kill the last job I added. (note that if I just close it normally it will not fix the problem).

I havea DELL CPi laptop 166 with 2 gig HD and 64meg RAM I have over 600 meg from on the HD.

I have very little running (MSWheel, explorer, systray, Rnaapp, Netscape). No virus checker is running.

I hear the solution is to install clean from a 98 disk. I'd rather not have to lose all I have right now...

Is there a better solution out there? I have the latest BIOS and used the windows 98 patch file.
0
Oshrin
Asked:
Oshrin
1 Solution
 
SysExpertCommented:

First, make sure that you run the windowsupdate from the start button and get the lates service pack and patches.
Have you updated your BIOS ?

In addition, you might try running the msconfig program and going over all the options, especially the startup tab.
There are a lot of things that can be tweaked.
Another thing is I would install the Powertoys found
If you are running Win 98 first edition,
  TweakUI is at :
  Win98 CDrom \tools\reskit\powertoy\tweakui.inf
  Right click on the Inf file and choose install.    Win98 CDrom \tools\reskit\powertoy\tweakui.inf
  You can also install the other powertoys stuff. Great for tweaking.
   After tweakUI is installed, go to the control panel and go thru the options available. There  should be a save desktop option there along with a lot of other nice options !
I hope this helps !

0
 
mr_blackCommented:
Oshrin,

I hate to tell you but Microsoft isn't great at making their operating systems friendly with each other when using an upgrade process. While noone can tell what causes the problem, and in my opinion, including Microsoft, this always happens. I have upgraded from 95 to 98 on my desktop and laptop and expierenced problems with it on both of them.

Unfourtanently, the first solution to rid yourself of this problem is to rid yourself of Windows 98 and go back to 95 for one reason: Windows 98 was designed for the newer computers and not for 166 Mhz laptops like yours. This may sound really odd, but I installed 98 on a 400Mhz desktop and it crawls. On a 166 laptop, it must be painstakingly slow. I strongly suggest you go back to Windows 95 - your missing hardly anything.

I'll say that you have a 95% chance of saying bye-bye to the problem if you re-install clean.

If you need any more help, please let me know.

mr_black
0
 
jjcontactCommented:
Did you upgrade to Windows98 or Windows98 SE? If Windows98 upgrade to IE5. If SE make sure there is a check in the "browse in a new process" box in the advanced section of the Internet options.

One thing that I think might help is to change your machine to a network server. Right click on my computer, go to properties, then click on the performace tab and choose file system. Use the drop down box in "the typical role of this computer" to change from desktop to network server.

Windows98 defrag will help move your more often progams on the HD so that they are accessed more quickly. It takes a long time I have to warn you, the first few times.

Also, you should convert to FAT32 if you haven't already.

I have a 200 and my machine is much faster with Windows98. My neighbor who has a 366 but is still running Windows95 even notices it, but I have a clean install like Mr Black suggests.

Other things like a static swap files help.  When you first start your machine, how many free resources do you have?
0
 
OshrinAuthor Commented:
to jjcontact:

I converted to FAT32 and that seemed to have fixed it!!

Submit your suggestion as a answer and I will accept it

thanks!
0
 
jjcontactCommented:
I will submit this as an answer, but I want to to observe for a couple of days before you accept. I have seen this before........
Don't want to jinx myself, but you may find that it is only having a good day and I wouldn't want you to have to come back and ask again.
0

Featured Post

[Webinar] Cloud and Mobile-First Strategy

Maybe you’ve fully adopted the cloud since the beginning. Or maybe you started with on-prem resources but are pursuing a “cloud and mobile first” strategy. Getting to that end state has its challenges. Discover how to build out a 100% cloud and mobile IT strategy in this webinar.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now