• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 167
  • Last Modified:

2 pcs network problem

i got 2 pcs connected in win98 using crossover cable rj45
everytthing seems to be fine in device manager but i cant see the other
computer in neighbourhood.

other wierd thing is that i can login to the network with every password i
give it.

what i should do in order to solve the problem and finally see the other
comp?

0
talsp
Asked:
talsp
  • 9
  • 7
  • 5
  • +4
1 Solution
 
mkepkaCommented:
Depends on what protocol your using.  If you only have 2 PCs then use Netbeui as its simpler but if you're using them to connect to the net then TCP/IP.  They should be able to find each other using broadcasts but you may also want to try making entries in the lmhosts file in the windows directory.  The file has instructions in it on how to set it up.
0
 
talspAuthor Commented:
i am using tcp/ip
i configured both computer like:
192.30.8.76
192.30.8.74

subnet 255.255.255.0

should i use dns?

what other thing i am doing wrong?

i am using same workgroup name
0
 
mkepkaCommented:
Try entering both computers into the lmhosts file.  Open a file called lmhosts.sam in the windows directory and at the end type in on the 192.30.8.76 machine:
192.30.8.74    (whatever the computer name is of 192.30.8.74)    #PRE

Save the lmhosts.sam file as just lhmosts without an extension.

In the lmhosts.sam file on the 192.30.8.74 machine type:
192.30.8.76     (whatever the computer name is of the 192.30.8.76)   #PRE

Save the lmhosts.sam file as just lmhosts without an extension.  This should fix your problem.
0
Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

 
talspAuthor Commented:
well it didnt solve the problem i still cant see the other computer.

its wierd that every password i give in the network login is ok.

0
 
mkepkaCommented:
Can you ping one workstation from the other?
0
 
RonaldBiemansCommented:
You do have file and printer sharing enabled on both computers, I assume.
0
 
RonaldBiemansCommented:
You do have file and printer sharing enabled on both computers. I assume
0
 
RonaldBiemansCommented:
Oeps, pressed the submit button twice
0
 
talspAuthor Commented:
got the print and file services and can't ping the comp
0
 
mkepkaCommented:
If you can't ping the other machine then your problem is more basic.  Check to be sure that the link status light on both NICs is on.  If it is then try adding the Netbeui protocol and see if that work.  If it does then you have TCP/IP problems and you should reinstall TCP/IP on the workstations.  If the problem persists then I would check the cable to make sure that it isn't damaged.
0
 
mikeshackletonCommented:
Both computers need to have a common protocol installed to be able to communicate, however you also have to have the same workgroup name in both computers.  If the workgroup name under network neighborhood are different the 2 pc's will not see each other.  Computer name and computer description are for your use (computer name has to be different on each machine, description doesn't matter).  I assume you already know to right click on network neighborhood and select properties.  Under configuration you will find protocols and under identification you will find computer name and workgroup name.  Try this you should find it will solve the problem.
0
 
talspAuthor Commented:
the 2 NICs green light working.
workgroup is similar on both.
NetBeui isnt working either.
checked the cable about 30 time last 7 hours :)
0
 
mkepkaCommented:
Check device manager to make sure there are no question or exclamation marks beside the NIC.  Another thing to try is to reinstall or update the NIC driver as it looks like the NIC is having problems communicating at the hardware level.
0
 
RonaldBiemansCommented:
In the netbeui properties advanced tab
see to it that the "use this protocol as your default protocol" is checked
0
 
talspAuthor Commented:
ok, i only once succeed in seeing the other computer and thats all :(

i have no exclamation in device manager.

should i use windows logon or client for MS?
i am using Client for MS
0
 
wsh2Commented:
Disable the Windows NT domain network property. To do this, follow these steps:

    a. On the Windows Start menu, point to Settings, and then click Control Panel.

    b. Double-click the Network icon.

    c. Click the Configuration tab.

    d. Choose Client for Microsoft Networks, and click Properties.

    e. Clear the Log On To Windows NT domain check box.

    f. Click OK.

0
 
talspAuthor Commented:
this box is already cleared.
0
 
mkepkaCommented:
As before, try reinstalling the network card drivers.  Have you used the cable on a different set of networked computers and gotten it to work?  I think the problem is either with the cable, the NIC driver or one of the NICs it self.  You could also try removing all the network protocols and reinstalling them but thats a long shot.
0
 
talspAuthor Commented:
i hope it aint hardware stuff.
it seems to be ok in the device manager.
i will try it out.
0
 
wsh2Commented:
talsp.. I doubt that you have a hardware problem. From the Network Icon in control panel.. click on the ADD ->  Client: Client For Microsoft Networks.. ADD -> Protocol: Microsoft: NetBUI. Click on the File And Printer sharing button Click and check "I want to share files".. Go to Windows Explorer.. Right mouse click on a drive.. select the Sharing option.. check Shared As and then hit Ok. Do this to both machines.. and the Hard Drive that you shared should appear under Network Neighborhood -> Workgroup (assuming both WorkGroup names are the same)-> on both machines. One Important Note here.. Make certain that the ComputerName is different for each machine.. or a conflict will happen.

0
 
talspAuthor Commented:
well i think its a problem with my network card coz when i change it to 10 instead of 10/100 auto mode i can see at least from 1 side to another
0
 
wsh2Commented:
talsp: you cannot run 100 with a crossover rj45 cable.. you HAVE to use a hub. See if your TCP/IP comes up under 10.. <smile>.
0
 
Zero050300Commented:
My friend had this problem well I think the problem is the other computer isnt set up correctly,And use a router contact Mutatorr@gw.total-web.com
and tellem Zero sent you for a router.
Okay first check under network in Network Neighbor hood click proerties tell me what ya see?
0
 
mkepkaCommented:
So it does look like you have a hardware issue with the NICs and not the cable.  If it is certified CAT5 cable then it will support 100Mbps whether it is crossover or straight through.  If the 2 NICs you have are different brands or are El Cheapo specials then you may have issues at 100Mbps between the NICs.  Set both cards to 10Mbps and see how well it work.  Should allow you to see both workstations.  Let us know how it turns out.
0
 
talspAuthor Commented:
its wierd when i set them to 10mbps 1 computer (pentium II 350) see the other (pentium iii 700) but the last one aint seeing the first 1.

is there another conifguration that might solve it? maybe the thershold?
0
 
Zero050300Commented:
Well lets see Contact Mutatorr@gw.total-web.com
he will help you he had the same problem
0
 
wsh2Commented:
On the Pentium 700 (the one that can't be seen).. through Windows Exlorer did you set up your Hard Drive to be shared?.. If nothing is set to be shared.. nothing is gonna show. (see my earlier comment as to how to Share a Drive).
0
 
pesty1Commented:
ADD the following

Client For Microsoft Networks leave domain details blank
Protocol: Microsoft: NetBUI.
Protocol: Microsoft: TCP/IP
TCP/IP properties
IP address of 10.0.0.1 or 10.0.0.2
Subnet 255.255.255.0
Identification: Different Computer names
SAME Workgroup name !!!!

Reboot and you should be OK.
0
 
wsh2Commented:
Pesty1:
As you are new here.. let me welcome you to EE. It is customary here to leave your observations as a comment.. unless there is absolutely no other possible solution to the question. The Answer you provided has already been commented to by other experts, and as this question was still unlocked by the time you got here, there seems to be more to this question than that which you proposed as an Answer. As such, you may want to change your Answer to a comment so that others that pass by can add their wisdom to the question.
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

  • 9
  • 7
  • 5
  • +4
Tackle projects and never again get stuck behind a technical roadblock.
Join Now