Solved

Font Server Error

Posted on 2000-05-06
5
235 Views
Last Modified: 2013-12-02
Help~, I am facing a problem:
   When I type startx in terminal (I login with root), it shows:
   failed to set default font path 'unix/-1'
   Fatal server error
   could not open default font 'fixed'
   ---
   ---
   When I reboot the system, it shows:
   Shutting down X Font Server [FAILED]

How can I fix this problem ????
0
Comment
Question by:ahchong
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
5 Comments
 

Author Comment

by:ahchong
ID: 2784160
p/s: I can't go into my X-window now
0
 
LVL 3

Expert Comment

by:jyu_88
ID: 2784216
I'll just make sure xfs (x font server) is running:
/etc/rc.d/init.d/xfs stop
/etc/rc.d/init.d/xfs start
ps -alef | grep xfs | grep -v grep
If xfs shows up as a running process, then you can proceed to do 'startx', otherwise, you may need to look into the  xfs init script in /etc/rc.d/init.d, I had experience that xfs fails to take --droppriv option well, then xfs fails to start, although appears succesful.
Fails to stop is not a problem, since you probably doesnot have it running, thus nothing to be stopped.
0
 
LVL 2

Accepted Solution

by:
modulus earned 115 total points
ID: 2784315
Your font server cannot find the list of fonts.  This is due either to you removing/moving the directories that contain the fonts, or to changing the config files that tell the server where to find the fonts.  Probably you did the last one.  A common way that people do this is to run one of the tools (XF86Setup or xf86config).

You report the error message:
failed to set default font path 'unix/-1'
If that's not just a typo in your report of the error it should be 'unix:/-1'
This is a line which tells xfs to bind a socket to the server for the fonts.  It occurs in the file /etc/X11/XF86Config in the section 'Files' for the variable 'FontPath'.  If you are using RedHat's patched version of XF86 3.3.6 (ie from 6.2 or rawhide) then this line should not be set.  Instead you should have an actual list of directories containing the fonts on your system as the value of font-path.
i.e. In /etc/X11/XF86Config replace

 Section  "Files"
      RgbPath "/usr/X11R6/lib/X11/rgb"
      FontPath "unix:/-1"
 EndSection

with

 Section "Files"
   RgbPath    "/usr/X11R6/lib/X11/rgb"
   FontPath   "/usr/X11R6/lib/X11/fonts/100dpi:unscaled,/usr/X11R6/lib/X11/fonts/misc:unscaled,/usr/X11R6/lib/X11/fonts/75dpi:unscaled,/usr/X11R6/lib/X11/fonts/Type1,/usr/X11R6/lib/X11/fonts/Speedo,/usr/X11R6/lib/X11/fonts/misc,/usr/X11R6/lib/X11/fonts/100dpi,/usr/X11R6/lib/X11/fonts/75dpi"
 EndSection

Note that in this list of font directories the _order_ of the 100 and 75dpi font directories means that you will get large fonts.  I do this because a lot of the people I admin for like it - you may not - if you don't just change the order in the list.  There is more information on this at http://metalab.unc.edu/linux/HOWTO/mini/FDU-1.html (the excellent Font De-Uglification Howto).

With regard to the error about not being able to shut down - it's likely that xfs was not started.  If you are not running the patched XF3.3.6 then before you try to shutdown

1. examine if running font server by:
 "ps -ax | grep "xfs"
      shows that there are xfs daemons running or not

2. check that the init scripts are actually staring xfs:
" ls /etc/rc.d/rc3.d"
 should reveal a S90xfs file which is a symlink to /etc/rc.d/init.d/xfs
      scripts with a "S" at the start are run with the parameter "start"
      so one gets "xfs start" at boot up.

3. search for the config files for xfs using:
strings `which xfs` | grep "^/"
(note that there are _backticks_ in the above command, `   not ' !)
to find out likely places that the config files are.  Should find one at
      /usr/X11R6/lib/X11/fs/config
4. review the syslog by
      more /var/log/messages | grep "xfs"
5. XF86Config  has a FontPath statement in it .  Removing this gets the font
      server to use its own internal defaults.  Can be useful for debug.
      That is the file I described above: /etc/X11/XF86Config
6. The file /etc/X11/fs/config contains a line "catalogue=/usr..." which can
      be used to construct the appropriate lines for FontPath in XF86Config
      by just banging in the lines from config without catalogue, with a
      preceding FontPath on each line and with the absolute address enclosed
      in quotes`. This allows one to operate without xfs.
7. Finally, can run "chkconfig --del xfs" to prevent xfs starting at boot time
      which is useful for debugging distinction between X11 and xfs.

I'm betting if you try the fix at the top of the file that things will work for you though.

best wishes,
modulus
0
 

Author Comment

by:ahchong
ID: 2784459
modulus :
   thanks a lot !!!! I have configured my linux and now I can enter my X-window. As I am the beginnner of linux (I am using Redhat Linux 6.1 with GNOME workstation), what is the use of /usr/X11R6...,/usr/X11R6... , it is the font's library ??
   Ops, forgot to ask you, can you give me your ICQ UIN or email address, as I am the beginner of linux, I need more help(s) from you, THANKS !!
0
 

Author Comment

by:ahchong
ID: 2784460
Adjusted points from 50 to 115
0

Featured Post

Enterprise Mobility and BYOD For Dummies

Like “For Dummies” books, you can read this in whatever order you choose and learn about mobility and BYOD; and how to put a competitive mobile infrastructure in place. Developed for SMBs and large enterprises alike, you will find helpful use cases, planning, and implementation.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I am a long time windows user and for me it is normal to have spaces in directory and file names. Changing to Linux I found myself frustrated when I moved my windows data over to my new Linux computer. The problem occurs when at the command line.…
SSH (Secure Shell) - Tips and Tricks As you all know SSH(Secure Shell) is a network protocol, which we use to access/transfer files securely between two networked devices. SSH was actually designed as a replacement for insecure protocols that sen…
Learn how to get help with Linux/Unix bash shell commands. Use help to read help documents for built in bash shell commands.: Use man to interface with the online reference manuals for shell commands.: Use man to search man pages for unknown command…
This demo shows you how to set up the containerized NetScaler CPX with NetScaler Management and Analytics System in a non-routable Mesos/Marathon environment for use with Micro-Services applications.

737 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question