Solved

New Edit Windows

Posted on 2000-05-07
34
234 Views
Last Modified: 2010-04-04
thank you in advance,,,

i am working on Delphi 3.0, and as you know , when you write the code rapidly, many new edit windows are opened , and in 3, or 4 seconds, i can see 15-20 new window, what i want, is to disable this.


Thank you.
0
Comment
Question by:ams4380361
  • 14
  • 6
  • 3
  • +7
34 Comments
 
LVL 2

Expert Comment

by:Roza
ID: 2785494
Is this what you need:

Tools->environment options->Code Insight-> Code completion (uncheck)
0
 

Author Comment

by:ams4380361
ID: 2785500
no it's not, to know exactly what i mean, in the code window try to press the down and left arrows respectivaly and in a fast way, then you will see that many edit window will be opend, in another way, please rigth click on the code, and you will see NEW EDIT WINDOW option, click on it and you will know what i want.

Thanks..
0
 
LVL 13

Expert Comment

by:Epsylon
ID: 2785535
Is this a joke?

If not then I suggest to reinstall Delphi...
0
 

Author Comment

by:ams4380361
ID: 2785600
No it not a joke , i mean every word i say, let me re explain what iam facing.

Iam using Delphi 3.0 on NT Platform,
while iam writing a code and using the up,down, left, right keys in a rapid way a new edit window will be displayed not one time but more than 3,4,5 windows for the selected unit.

The traditional way to open a new window for the selected unit is by clicking the right mouse and selecting the NEW EDIT WINDOW option.

So is their a way to disable such option, or is their any explanation for such behavior !!!!!

Please if you are interested in solving my issue i will be thankful to you otherwise Please dont waste my precious time.

0
 

Author Comment

by:ams4380361
ID: 2785601
No it not a joke , i mean every word i say, let me re explain what iam facing.

Iam using Delphi 3.0 on NT Platform,
while iam writing a code and using the up,down, left, right keys in a rapid way a new edit window will be displayed not one time but more than 3,4,5 windows for the selected unit.

The traditional way to open a new window for the selected unit is by clicking the right mouse and selecting the NEW EDIT WINDOW option.

So is their a way to disable such option, or is their any explanation for such behavior !!!!!

Please if you are interested in solving my issue i will be thankful to you otherwise Please dont waste my precious time.

0
 
LVL 13

Expert Comment

by:Epsylon
ID: 2785810
Weird. Did you install all updates?

I've never heard of this problem before...
0
 
LVL 14

Expert Comment

by:DragonSlayer
ID: 2786015
Neither have I... does a reinstallation of Delphi 3 help?
0
 

Author Comment

by:ams4380361
ID: 2787114
i am surprised, now, i just want to ask when you right click on the code window, is the option NEW EDIT WINDOW available? if yes , then click it, and you will see another instance of the code window...


Thank you.
0
 
LVL 20

Expert Comment

by:Madshi
ID: 2787365
The option is there, but new edit windows are NEVER opened just because you use the cursor keys!! So you should really reinstall Delphi (or even Windows).

Regards, Madshi.
0
 

Author Comment

by:ams4380361
ID: 2787407
i did not say when i am using cursors key,i said when i am using cursor keys rapidly. please try it.
0
 
LVL 20

Expert Comment

by:Madshi
ID: 2787439
Okay, I tried it, nothing happens. It simply works without any new edit windows. I *NEVER* had this effect.
0
 

Author Comment

by:ams4380361
ID: 2787512
Adjusted points from 160 to 300
0
 

Author Comment

by:ams4380361
ID: 2787513
okay, i don't know what i can say,
i want to inform you that problem is common between many programers in the company, not ONLY ME.



0
 
LVL 27

Expert Comment

by:kretzschmar
ID: 2787576
? really weird
have also done several tests,
but can't reproduce this.

are there any keyboard-macros
on your machines or are you using special keyboards?
0
 
LVL 5

Expert Comment

by:TheNeil
ID: 2787672
One word: Virus?

The Neil =:(
0
 
LVL 27

Expert Comment

by:kretzschmar
ID: 2787687
courious effect for a virus, neil ;-)
0
 
LVL 20

Expert Comment

by:Madshi
ID: 2787728
Perhaps you should try to disable/unload all 3rd party packages & experts. It may be an expert your company is using, that mixes up your keyboard settings or IDE or ...

Regards, Madshi.
0
IT, Stop Being Called Into Every Meeting

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

 
LVL 5

Expert Comment

by:TheNeil
ID: 2787733
If it simulates key strokes or has affected the registry in some way. Just a thought (paranoia overload)

The Neil =:)
0
 

Author Comment

by:ams4380361
ID: 2787905
Adjusted points from 300 to 450
0
 

Author Comment

by:ams4380361
ID: 2787906
it's not a virus, i have re-installed Delphi 3.0 many times.

thank you for all, and i wish i can meet any of you to show him what i mean.



Thanks
0
 
LVL 20

Expert Comment

by:Madshi
ID: 2787934
Well, we do believe you! It's just that noone of us have heard of this effect before. Have tried my suggestion (removing all 3rd party components/packages/experts)?

Rename the registry key:

HKEY_CURRENT_USER\Software\Borland\Delphi\3.0\Experts

to e.g. "Experts2". Then restart Delphi and uninstall all 3rd party stuff.
0
 
LVL 2

Expert Comment

by:freter
ID: 2789040
does the effect only appear in delphi? i mean, does it happen in other apps as well? eg. document windows in word? and how about bcb or any other borland ide?

if so, the problem resides somewhere outside of delphi.

</freter>
0
 

Author Comment

by:ams4380361
ID: 2791130
No, it's only in delphi, and it's common between 10 programers...
0
 
LVL 5

Expert Comment

by:TheNeil
ID: 2791481
This doesn't sound like an installation issue (unless there's something wrong with the installation CD and you're all using the same CD). I know this is probably the last thing that you want to hear (and the last thing I'd ever suggest) but I'd go and hassle Inprise over this one

The Neil =:(
0
 
LVL 4

Expert Comment

by:jeurk
ID: 2793428
Hello,
May I add a comment that will at least
comfort ams ;)
We do have a similar problem here.
Many of us are facing that problem here.
But it's only happening from time to time.
We could not find a constant...
Maybe we could find something in common ?
It's happening under D3, we are using Gexperts and DelForExp as experts...
It's happening under NT 4 (sp6a for us)
It's happening mostly when you move your
cursor but also when you type stuff..

So ?
0
 
LVL 20

Expert Comment

by:Madshi
ID: 2793487
Hi John!!  :-)

ams seems to ignore my suggestions, so perhaps you might want to test it? What if you remove the experts (and as a second step the 3rd party components)? Does the problem still occur?

Regards, Madshi.
0
 

Author Comment

by:ams4380361
ID: 2795522
No Madshi, i don't ignore your suggestions , but i don't understand you excactly.will you please explain it in details.

Thanks.
0
 
LVL 20

Expert Comment

by:Madshi
ID: 2795622
I'm thinking this way: Your and jeurk's company have this problem, most other people here in the Delphi forum NOT. So there must be something special about your and jeurk's company. The only thing I can think of is a special 3rd party component or expert you've installed on your Delphi-system on every company's computer.

Alright. Look, you can extend the Delphi IDE by so-called experts. Those experts are either stand alone DLLs (registry key see my comments above), or included in a component package. Experts can do several things like manipulating Delphi's menu or manipulating key shortcuts or popping up new edit windows or [...]. So I guess, the guilty one for your problem will most probably be an expert.

How can you disable them? First, rename that expert registry key, then restart Delphi. Now all stand alone experts are disabled. Now go to the package configuration menu and delete or disable all packages, because there could be an expert in one of those packages.

If the problem now doesn't occur anymore, you should step by step install/enable the packages & stand alone experts again to find the guilty one. If the problem still occurs, then I'm out of ideas...

Regards, Madshi.
0
 

Author Comment

by:ams4380361
ID: 2795773
i tried it, but it does not work.
0
 
LVL 4

Expert Comment

by:jeurk
ID: 2795806
Hello Madshi,
Nice and clear explanation.
The problem occurs not often enough
to have the patience to work without gexperts and delforexp. I think all of you are using those two. I thought of the problem comming from gexperts, but one of us tried without and the problem is still here. delforexp is not touching the ide without beeing asked to do it...
About the packages, I cannot work without them, they contain all our framework.
You see, the problem is that we have more or less all the same configuration here, but not all of us have the problem. That's what I call strange. I could not find a common factor for it.
Voila.
Ams, I suggest you do what Madshi is asking. If the problem happen all the time it should be easy to track down. And I'm interessed in the results ...
C Ya.
0
 

Author Comment

by:ams4380361
ID: 2795832
Hello Madshi
I tried it, i changed the Expert in the windows registry, but i did not remove packages , because if the problem comes from these packages, then none of us can work without these packages, i agree with jeurk  that there are somthing strang, because many companies work on NT platform and they are using D3, with experts and Packages, and they did not complain from this problem..
0
 
LVL 17

Accepted Solution

by:
inthe earned 450 total points
ID: 2807645
plese try this "fix" posted on borland news groups a while ago.
seems you two are not only ones affected ;-)


When you create a design time package using the following unit, the problem is gone.  Build the package using Component | Install
Component in the Delphi IDE menu.
 
--------------------------------------------------------------------------------------------------------------
{************************************************************
* Unit: FixKeys
*
* Description:
*    Fix for the 'New Edit Window' problem in the Delphi
*    IDE on some hardware.
* Created: 2000-01-14
* Author: Jan Sprengers
************************************************************}
unit FixKeys;
 
interface
 
uses
  SysUtils, Classes, Windows, Messages;
 
implementation
 
var
  MsgProcHook: HHook;
 
function HookMsgProc(Code, WParam, LParam: Integer): LResult; stdcall; var
  Msg: PMsg;
begin
  Msg := PMsg(LParam);
  if (Msg.Message = WM_KEYDOWN) and (Msg.WParam = 0) then
    Msg.Message := 0;
  if Code < 0 then
    Result := CallNextHookEx(MsgProcHook, Code, WParam, LParam) else     Result := 0;
end;
 
procedure InitFixKeys;
begin
  MsgProcHook := SetWindowsHookEx(WH_GETMESSAGE, @HookMsgProc, 0,     GetCurrentThreadID());
end;
 
procedure ExitFixKeys;
begin
  if MsgProcHook <> 0 then
    UnhookWindowsHookEx(MsgProcHook);
end;
 
initialization
  InitFixKeys;
 
finalization
  ExitFixKeys;
 
end.
--------------------------------------------------------------------------------------------------------------
 
In case you're interested in what's happening, here is the full story:
 
On some keyboards, Windows generates a WM_KEYDOWN message with a virtual key-code of 0.  Every WM_KEYDOWN message is processed by Delphi and it is checked if the pressed key happens to be a shortcut for a popup menu on the window receiving the WM_KEYDOWN message.
 
The problem is that the code to check for the shortcut is a bit
imprudent and also checks the shortcut against this 0 virtual
key-code.  The result is that the first menu option of the popup menu that has *no* shortcut (in this case 'New Edit Window') is launched because its ShortCut property has a value of 0.
 
This fix filters out all WM_KEYDOWN messages with a virtual key-code of 0 by placing a Windows hook upon installing itself in the Delphi IDE.


cheers Barry
0
 

Author Comment

by:ams4380361
ID: 2809810
Thank you Inthe
thank you for all...


Best Regards.
AMS...

0
 
LVL 4

Expert Comment

by:jeurk
ID: 2810100
I can also tell you that the problem was fone away
with windows 2000... without that fix...
CU
0

Featured Post

What Should I Do With This Threat Intelligence?

Are you wondering if you actually need threat intelligence? The answer is yes. We explain the basics for creating useful threat intelligence.

Join & Write a Comment

In this tutorial I will show you how to use the Windows Speech API in Delphi. I will only cover basic functions such as text to speech and controlling the speed of the speech. SAPI Installation First you need to install the SAPI type library, th…
Have you ever had your Delphi form/application just hanging while waiting for data to load? This is the article to read if you want to learn some things about adding threads for data loading in the background. First, I'll setup a general applica…
Internet Business Fax to Email Made Easy - With eFax Corporate (http://www.enterprise.efax.com), you'll receive a dedicated online fax number, which is used the same way as a typical analog fax number. You'll receive secure faxes in your email, fr…
Access reports are powerful and flexible. Learn how to create a query and then a grouped report using the wizard. Modify the report design after the wizard is done to make it look better. There will be another video to explain how to put the final p…

758 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

23 Experts available now in Live!

Get 1:1 Help Now