running eudora and other programs

It has become painfully obvious to me that my experience in Windows hasn't prepared me for Linux. I recently downloaded qpopper3.0, I uncompressed it, configured it, ran make and nothing! I moved the file to /usr/local/bin as it suggested but I can't execute the file. I tried running it in xterm and just clicking on the executable file but it does nothing. What am I doing wrong? This same problem occurs with about 50% of the programs that I download.
Who is Participating?
modulusConnect With a Mentor Commented:
Hi scotfitz,

I'm guessing that qpopper is actually running. After you type the full command path like you said you did and you get back to the "Root" prompt then do the following for me:

ps -aux | grep "qpop"

The "ps" command lists the processes running.  The "-aux" are options to ps that says list everything.  The "|" pipes the output of "ps -aux" which would normally come up on the screen into the next command "grep `qpop'" as its input.  "grep" searches for strings.

So this is probably going to tell us that qpopper is running on your system.  It's running quietly inthe background as a "daemon".  It's not supposed to do anything flashy in the foreground.  I don't use qpopper but I just looked at their webpage and it says it is a "server" - this means it probably sits quietly in the background scheduling tasks and dealing with requests from other sources.

In other words - you've installed it successfully already!

best wishes,
Simplest short answer:  you may have forgotten to do "make install"

More complicated answer:  you may have to change the file permissions to make it executable by the user "chmod u+x"

Another answer: try typing "/usr/local/bin/qpopper" replacing the qpopper part by whatever it's actually named.  If this works then it means that your PATH environment variable is not set.  You'll need to edit your .bash_profile to include 2 lines like:
export PATH
(the PATH is a list of locations that are searched for the executable X when you type "X" and then Enter/Return on the command line.  If /usr/local/bin wasn't there then it can't find it.

Long pedantic answer may be totally off-base as I don't really know what you are doing each time.  Hopefully it's useful in some way:
After you uncompressed the X.tar.gz or whatever file it was and it created a directory containing qpopper source files etc, it probably created files called README and INSTALL.  Also it will probably have created a Makefile.  The Makefile is a series of rules that tells the system how to build the final exectuable/binary and (optionally) where to put it and (optionally) how to tidy up. In order to see what you should do, best thing is to read README and INSTALL.  Usually they will tell you to type a command sequence like:
make install
make clean

The first of these will poke about your system checking that the correct tools and files are present to compile and link the new program.

The first make will compile and link the program in sections

The second make "make install" will put the executable/binary into a location specified in the Makefile.

check out for a whole series of useful HOWTO files that tell you lot's about this sort of thing.

best wishes,
scotfitzAuthor Commented:
I read the install text file... I also tried make install but it didn't work
So far as I can tell I did everything exactly the
way that it was supposed to be done but I still get nothing
from the executable, I can find it but I can't use it
I am lost here.
A proven path to a career in data science

At Springboard, we know how to get you a job in data science. With Springboard’s Data Science Career Track, you’ll master data science  with a curriculum built by industry experts. You’ll work on real projects, and get 1-on-1 mentorship from a data scientist.

did you try the "chmod" command that I suggested?  Also did you try typing "/usr/local/bin/qpopper"

What happens when you do these two things?  

What distro and version are you running?  
e.g. RedHat6.2 or Caldera2.4?

did you do "make install".  As you mentioned, you moved the files.  Maybe you might missed "moving" all the files to the right location.  By making "make install" you will let the "install" (in Win term) to place the right files to the right location.  Have you checked the configuration file, see there is any fine tuning that is required.


Didn't mean to steal you comment - just accidently skip reading it.

cheers :)
no worries :)
any other ideas on this?  All I can think of is that maybe he has libc5 system and is downloading libc6 executables.

best wishes,
scotfitzAuthor Commented:
I tried make install but it didn't work and the install
text file didn't mention it either. I did try typing in th command line
for the path but that didn't work either it just brought
me back to the root prompt. I am running redhat 6.2
on a 200mhz pentium mmx with a 5gb hard drive and 80mb
ram. I copied the entire folder the its current location so I don't see
how I could have missed a file. I really appreciate
everyone's help on this. BTW - what is chmod and
which flags do I need to use with it?

scotfitzAuthor Commented:
instead of using chmod I went to the directory and found the executable
then right clicked it to view the permissions. It is executable
by the user, group, and others so that isn't it unfortunately.

Thanks again,
scotfitzAuthor Commented:
Thanks Modulus I appreciate your help.
Linux isn't going to get the best of me.
I like it really well but it's just taking
some getting used to.
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.