• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 295
  • Last Modified:

Linux does not boot after adding a hard disk.

I have a PC which has Windows and linux
6.1 running on it. The first hard disk was divided into two partitions - one for DOS and the other one for Linux. Then a second disk was added purely for linux. This arrangement was working fine
with Lilo being used to choose at boot time which system starts up. Recently a third, 10Gb, disk was added. Using windows the third disk had two 2Gb partitions created on it for Windows and I have no problems under Windows to access them. However, now linux refuses to come up,. Booting process freezes after ide0 is initialized.
The suggestion was made to me that the reason for this is that perhaps originally the first disk was divided into DOS and linux partions using linux tools, but the new disk was partitioned using DOS. What can I do now? I could
repartition the third disk using linux if I could boot up linux but I do not seem to be able to do this.
Can something be done in this situation?

Andrzej
0
andrzej
Asked:
andrzej
  • 3
  • 2
  • 2
  • +1
1 Solution
 
RobsonCommented:
I don't think that partitions created by DOS are the problem. At this moment kernel doesn't care about any. It seems that ide detection code locks up.

Try to pass one of the following parameters to kernel:

      hdc=noprobe
or
      hdc=none
or
      ide1=noprobe

(I assume your hard drive is connected to second IDE interface as master).But afrer this linux won't see the third drive. You may try to pass all ide parameters to kernel and forbid it to do the detection:

      ide1=0x170,0x376,15

I took these numbers from kernel documentation (file ide.txt). Look there for other options.
0
 
bernardhCommented:
/dev/hdc is used by the cdrom drive,

boot: linux hdd=noprobe hdc=cdrom

when the system boot, you might as well include it in your /etc/lilo.conf file, but it should take the form:

append="hdd=noprobe hdc=cdrom"

0
 
jlevieCommented:
Does the 10Gb disk have any of the "disk managers" for large drives installed on it (MaxBlast, etc)? Is it does, it's likely that you'll have problems until it's removed from the system. Assuming you installed the drive youself a clue that such a thing is present is if you were instructed to use a "disk setup floppy" before installing an OS on the disk.

Oh yeah, you didn't move any of the disks around when installing the 10Gb disk did you? They are still on their original IDE controllers and in the original Prim/Slave mode, right?
0
Introducing Cloud Class® training courses

Tech changes fast. You can learn faster. That’s why we’re bringing professional training courses to Experts Exchange. With a subscription, you can access all the Cloud Class® courses to expand your education, prep for certifications, and get top-notch instructions.

 
andrzejAuthor Commented:
The problem is that when I pass to the kernel the parameter ide1=noprobe, linux boots up but I have no access to cdrom, which is on the same contoller (ide1) as the third disk. Unfortunately, neither hdd=noprobe nor hdc=noprobe helps - the booting process again freezes after printing out ide0 line.
I do not have any disk manager for large drives installed on the third disk.
Disk 1 and 2 has not been moved.
0
 
RobsonCommented:
What about ide1=0x170,0x376,15 -- have you tried it? This should prevent the kernel from detecting your hard drive itself. Then you may test your drive in normal work.
0
 
bernardhCommented:
have you tried passing this parameter combination to your kernel upon bootup?

   boot: linux hdd=noprobe hdc=cdrom

it tells the kernel not to probe the IDE addresses for the drive.

then check if symbolic link exist

   $ ls -l /dev/cdrom

   lrwxrwxrwx 1 root root 3 Oct 16 22:44 /dev/cdrom -> hdd

If it doesn't exist, type:

   $ ln -s /dev/hdd /dev/cdrom

good luck.
0
 
jlevieCommented:
What is the bios mode for the 10Gb disk(normal, LBA, etc)? Which of the two drives on EIDE1 is the master & which is the slave?
0
 
andrzejAuthor Commented:
Trying hdd=noprobe hdc=cdrom did not
help - the bootup process freezes after
ide0 line.

When I tried ide1=0x170,0x376,15, during
the bootup process a window poped up
telling me that new hardware was found, CD-ROm, do I want to configure it? I answered 'yes' and then another window
poped up asking me if I want to configure a new hard drive. I answered 'yes' again and the everything seemsed to go fine. I can now mount cdrom as hdd. Thanks a lot - this is the answer to my question.
How can I grant 500 to Robson?

0
 
RobsonCommented:
That messages were not actually caused by this kernel option, only Kudzu (hardware manaeger) noticed changes in your hardware.

I'm glad I could help you -- I have been an expert for short time and this is my second score so far. There should be the option called 'accept as answer' or 'promote to answer', but I'm not sure.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 3
  • 2
  • 2
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now