?
Solved

x server trouble ?

Posted on 2000-05-08
6
Medium Priority
?
255 Views
Last Modified: 2010-04-20
  While opening an  icon file (.xpm) that I just saved, my pc crashed & restarted until it got to where the x  server starts. It keeps trying to start but fails, over & over. How can I boot to a command line (runlevel 2) before the x server starts so I can remove the offending file.  I'am using Linux-Mandrake 6.1 with KDE.         Thanks in advance
0
Comment
Question by:Daddy101399
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 2
6 Comments
 
LVL 1

Expert Comment

by:crojas
ID: 2790987
In X press Ctrl+Alt+F1 to go to console number 1, then you'll need to edit the 'inittab' file in /etc. Change the runlevel from 5 to 3(Full network in text mode).
RunLevel 2 is without network in text mode.
0
 

Author Comment

by:Daddy101399
ID: 2797813
X never starts, it perpetually keeps trying to but fails (the monitor keeps flashing). Is there a linux equivalent to "safe mode" or some way to boot to a shell without  it trying to start x.
0
 

Expert Comment

by:antozi
ID: 2798104
Have you tried with a linux boot diskette? that boots to the command line?
0
Percona Live Europe 2017 | Sep 25 - 27, 2017

The Percona Live Open Source Database Conference Europe 2017 is the premier event for the diverse and active European open source database community, as well as businesses that develop and use open source database software.

 

Author Comment

by:Daddy101399
ID: 2798345
I Tried using the rescue Boot floppy I created during the install. Lilo started  & after it found the devices & partitions, it asked for a Root floppy. If I continue with the boot floppy I get kernel panic.  I suppose its looking for the root file system. I don't recall making a Root floppy. This is beginning to look like a format & reinstall.
0
 
LVL 1

Accepted Solution

by:
crojas earned 150 total points
ID: 2798643
After a few failed starts the system will wait for 5 min, if you press CRTL+ALT+F1 you can go to console mode, edit the file /etc/inittab, change the init level from 5 to 3 and after reboot your system won't start X. Change the settings with Xconfigurator or direct editing /etc/X11/XF86Config and use 'startx' to try X. When you get the X working OK change again the inittab file to runlevel 5.
0
 

Author Comment

by:Daddy101399
ID: 2808976
I let it keep trying for about 15 minutes without success. Fortunately I backed up my important data previously. After considering my lack of time, I decided to format & reinstall.
Thanks for your help.... Steve
0

Featured Post

Major Serverless Shift

Comparison of major players like AWS, Microsoft Azure, IBM Bluemix, and Google Cloud Platform

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

You ever wonder how to backup Linux system files just like Windows System Restore?  Well you can use Timeshift in Linux to perform those similar action.  This tutorial will show you how to backup your system files and keep regular intervals. Note…
Google Drive is extremely cheap offsite storage, and it's even possible to get extra storage for free for two years.  You can use the free account 15GB, and if you have an Android device..when you install Google Drive for the first time it will give…
Learn how to get help with Linux/Unix bash shell commands. Use help to read help documents for built in bash shell commands.: Use man to interface with the online reference manuals for shell commands.: Use man to search man pages for unknown command…
How to Install VMware Tools in Red Hat Enterprise Linux 6.4 (RHEL 6.4) Step-by-Step Tutorial
Suggested Courses
Course of the Month11 days, 5 hours left to enroll

770 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question