Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
?
Solved

PC not recognize CDROM drive

Posted on 2000-05-09
13
Medium Priority
?
233 Views
Last Modified: 2010-04-27
PC, Win 95, AMD K6-2/333
System had been working well for over a year. The hard drive was going bad so I replaced it. Got it all partitioned with no problem.
Chose the "Express" setup for the Acer CDROM driver & it said it installed OK.
Now I'm ready to install the Windows 95 operating system from CD ROM but I can't change to D: prompt in dos. During bootup it shows that it found the drive. In Setup "Integrated Peripherals" all IDE options are set to Auto. Dos prompt changes to C: with no problem but sees d: as an invalid drive.
When I put the Win 95 disk in the ROM drive the drive light comes on but it won't read the disk.
I thought perhaps something happened to the drive so I bought a new Acer CDROM RW drive & get the exact same symptoms.
0
Comment
Question by:vintel
13 Comments
 
LVL 2

Expert Comment

by:steveb_49
ID: 2792444
Basic questions-How many partitions on your hdd?.When the machines boots and loads the cdrom drivers what drive letter does it allocate to it?.Is it loading cdrom drivers?.
0
 
LVL 5

Expert Comment

by:joe_aqs
ID: 2792473
The CD Rom driver may be setting the drive to a different letter. Also, you may want to try a CD Rom support bootdisk instead. www.bootdisk.com
0
 

Author Comment

by:vintel
ID: 2792496
Steve,
One partition on the HDD, C:.

I don't know how to ascertain what drive letter is assigned to it. In DOS it does not recognize D: as a valid drive. I also tried other letters up to L:.

When I loaded the CDROM driver it said that the installation was successful.
Thanks
John
0
Who's Defending Your Organization from Threats?

Protecting against advanced threats requires an IT dream team – a well-oiled machine of people and solutions working together to defend your organization. Download our resource kit today to learn more about the tools you need to build you IT Dream Team!

 
LVL 3

Expert Comment

by:boom23
ID: 2792594
Vintel, what you need is a bootdisk with cd-rom enabled. The driver that you installed is no good for that. As joe mentioned, go get that bootdisk from the site he posted.
0
 
LVL 1

Expert Comment

by:pcservice
ID: 2792618
the only command that seem to be missing is your mscdex.exe. You may have see your CD driver install but you also need this command to assing a letter to your CD-Rom.

The command is the following

mscdex.exe /d:mscd001

the /mscd001 could be something else depending of your device command in config.sys on your boot disk

just repeat the exac same key and it will give you your letter
0
 
LVL 1

Expert Comment

by:derekcmartin
ID: 2792627
Or, go to the ACER website.  They should have the proper dos drivers for you.
0
 

Author Comment

by:vintel
ID: 2793710
Autoexec.bat contains the following-
Rem C:\cdpro\MSCDEX /D:MSCD001 /V
MSCDEX /D:MSCD001 /V

Config.sys = DEVICE=C:\CDPRO\VIDE-CDD.SYS /D:MSCD001
 
I went to www.bootdisk.com. There are so many options I'm not sure which to chose. One I went to look at was full of warnings about not using it if you don't know what you're doing. I thought I'd wait & see if there was another solution to my problem before I make it worse.

Acer web site was my first stop but I found no solution there.
0
 
LVL 5

Expert Comment

by:joe_aqs
ID: 2793887
I'm trying to figure out why would that line in your "Autoexec.bat" is REM'ed?

Rem C:\cdpro\MSCDEX /D:MSCD001 /V

You still have not installed Windows right?
0
 

Expert Comment

by:RobertDShaw
ID: 2794068
When you boot the system up from the Windows 95 boot diskette do you get any messages regarding the CD-ROM drive at all?

I believe that having the MSCDEX.EXE command rem'ed out of the Autoexec.bat file is causing the problem.

The Windows 95 boot diskette did not support a CD-ROM disk by default so the drivers for it needed to be added. The necessary changes are to place the driver command in the config.sys and then the MSCDEX.EXE command in the Autoexec.bat file.

Try running the Autoexec.bat file with the MSCDEX.EXE file un-rem'ed or simply execute the command at the DOS prompt.

If the driver did not load from the config.sys file it will give you an error message and if it did you'll then be able to change drives to the D: drive.

0
 

Author Comment

by:vintel
ID: 2794585
Windows is not installed yet.

When booting up I get
"Found CDROM: 6x4x32"

From the A: Prompt & also from the C: prompt  I ran
C:\cdpro\MSCDEX /D:MSCD001 /V
MSCDEX /D:MSCD001 /V
 and
MSCDEX /D:MSCD001 /V
I got a "Bad command or file name" response to each one. Also tried it without the spaces.



I don't know if this has any bearing on the problem or not but I can address my floppy drive as BOTH A and B. Changing directory to either one will read the floppy. It is an LS120 super drive.
0
 
LVL 5

Expert Comment

by:joe_aqs
ID: 2794607
Vintel,

Remove the "REM" from before this command line in your Autoexec.bat file.


Rem C:\cdpro\MSCDEX /D:MSCD001 /V

Save the modified Autoexec.bat file.
Restart your computer

0
 
LVL 17

Accepted Solution

by:
rayt333 earned 200 total points
ID: 2794865
Go to this site and download both of these bootdisks, one will work for sure.
http://support.micronpc.com/file_lib/boot.html

This one should work just fine: 98BOT10A.EXE

But just in case get this one too: 95BOT245.EXE
0
 

Author Comment

by:vintel
ID: 2795204
The Autoexec.bat in the suggested download had the CD-ROM drive designated as R but it activated the drive. I changed it to D & it is now ready to load Windows.
Thank you
Vintel
0

Featured Post

Meet the Family that is Made for Collaboration

The TeamConnect Family product group as part of the Sennheiser for Business Portfolio comprising high-quality, technically well-conceived meeting solutions for business communication – designed for any meeting room and any meeting situation.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

In the modern office, employees tend to move around the workplace a lot more freely. Conferences, collaborative groups, flexible seating and working from home require a new level of mobility. Technology has not only changed the behavior and the expe…
This article shows how to use a free utility called 'Parkdale' to easily test the performance and benchmark any Hard Drive(s) installed in your computer. We also look at RAM Disks and their speed comparisons.
The Relationships Diagram is a good way to get an overall view of what a database is keeping track of. It is also where relationships are defined. A relationship specifies how two tables connect to each other. As you build tables in Microsoft Ac…
How can you see what you are working on when you want to see it while you to save a copy? Add a "Save As" icon to the Quick Access Toolbar, or QAT. That way, when you save a copy of a query, form, report, or other object you are modifying, you…
Suggested Courses

564 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question