?
Solved

ls in ftp

Posted on 2000-05-09
12
Medium Priority
?
538 Views
Last Modified: 2010-04-21
(Solaris2.7)
When I ftp my server it lets me get in but when I try to put or get files it doesn't do it and I think the problem is that ls doesn't work.
It says 200 PORT command successful but then it gets stuck, and doesn't continue.
Any ideas?
0
Comment
Question by:mandybird44
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 3
  • 2
  • +4
12 Comments
 

Expert Comment

by:CASIOFL
ID: 2793537
Have you checked that the ftp login has valid permissions to the directory or folder where you are attempting to put or get files.
0
 

Author Comment

by:mandybird44
ID: 2793563
yes. I believe that what causes the problem has something to do with ls.
0
 

Expert Comment

by:CASIOFL
ID: 2793924
Are you running any type of firewall between your client station and the server. I ask this, because I have seen some Sun bug reports, about ls causing a 200 port successful message in ftp sessions with systems running through Checkpoint firewall-1, and other Sun network security tools.  Unfortunately, if this is the case, I do not have an answer for you, since I do not run any firewall tools, in my intra-network.
0
VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

 

Author Comment

by:mandybird44
ID: 2794035
Can you tell me where exactly you saw that? (I am using FW)
0
 

Expert Comment

by:CASIOFL
ID: 2794755
My customer maintains a software support contract with Sun. Sun provides us with quaterly CDs that contain all bugs, white papers, info docs, patches, fixes, etc...
We load these CDs and can perform text searches. I searched on your error and I found several bugs describing the same problems as you, and they were all pointing to some sort of conflict with having firewall-1 turned on vs off. unfortunately, Sun did not report a fix on any of these bugs.
0
 
LVL 1

Expert Comment

by:tvanlint
ID: 2799759
if you go through a firewall to get that, you might need to use a passive transfer mode.  Depending on your install, you might find another ftp in /usr/local/bin/ that uses passive transfers by default.  Or most windows GUI clients (Laplink ftp is one I use and is free) have an option in one of their advanced menus to tell it to use passive transfers.  This might help you...
0
 

Expert Comment

by:troyrock
ID: 2800480
The trouble is that ftp uses two ports for the transfer of information: 21 for control traffic (the request you type for instance - get filename.ext) and 22 or data.  Likely port 22 is blocked.  Some firewalls are stateful in that they allow the replies to outgoing traffic (your request) to come back but they don't allow new traffic to originate from the outside (the port 22 data originating from your server to your desktop)  You would have to be ftp'ing to a server outside the firewall from the inside for this to be the problem.  Some firewalls are clever enough to allow the data information in but others need to be told explicitly to allow this type of data.
0
 

Author Comment

by:mandybird44
ID: 2801715
10x for your answer troyrock, but it didn't help.
0
 
LVL 15

Expert Comment

by:samri
ID: 2804301
mandybird44,

I'm surprised that troywork suggestion doesn't work.  Have you tried to allow port 21 and 22 TCP, incoming and outgoing to go thru.

Or you could try passive transfer mode.  I think that it is PASV or PASSIVE  -- just check the HELP.

good luck
0
 

Expert Comment

by:troyrock
ID: 2808051
Do you have a sniffer or a tcpdump trace that you could share with us?
0
 

Expert Comment

by:himansusb
ID: 2811992
Did you check up your ~/.netrc file ?

Himansu
0
 
LVL 2

Accepted Solution

by:
ish earned 150 total points
ID: 2842109
I have a FW, with an anon FTP server outside, that I regularly FTP in and out of.  We don't allow too much BACK in, but allow almost full out to.

The problem you describe, is one that I've had similar problems to, the fix for us was part of hte FTP server's config.

#1: had to have an LS available for the incoming accounts.  Our FTP service has a root directory, that contains it's own ls and other such neccissary bin files.

#2: user's coming in had to be capable and have permission to execute said bin files.

The #1 caused problem similar to yours, and the #2 surfaced as a "Permission denied" error after #1 was fixed.
0

Featured Post

What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Hello fellow BSD lovers, I've created a patch process for patching openjdk6 for BSD (FreeBSD specifically), although I tried to keep all BSD versions in mind when creating my patch. Welcome to OpenJDK6 on BSD First let me start with a little …
Java performance on Solaris - Managing CPUs There are various resource controls in operating system which directly/indirectly influence the performance of application. one of the most important resource controls is "CPU".   In a multithreaded…
Learn how to get help with Linux/Unix bash shell commands. Use help to read help documents for built in bash shell commands.: Use man to interface with the online reference manuals for shell commands.: Use man to search man pages for unknown command…
In a previous video, we went over how to export a DynamoDB table into Amazon S3.  In this video, we show how to load the export from S3 into a DynamoDB table.
Suggested Courses

765 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question