Solved

backup

Posted on 2000-05-10
9
336 Views
Last Modified: 2013-12-06
what is the "could not statfile" message from fbackup ?
0
Comment
Question by:nakanoas
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 5
  • 4
9 Comments
 

Author Comment

by:nakanoas
ID: 2795912
Workstation HP-UX
HP-UX 10.20
0
 
LVL 21

Expert Comment

by:tfewster
ID: 2797157
fbackup failed to get status information about the file - possibly because it was being written to or NFS mounted from another system.

What filename is it complaining about? If it's a temporary file or a log you could exclude it from the backup.
0
 

Author Comment

by:nakanoas
ID: 2797345
it´s all project files created by Mentor Graphics.

What can i do to solve this problem???

All Workstations are in LAN, and all disks are NFS mounted.

0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
LVL 21

Expert Comment

by:tfewster
ID: 2797646
First the bad news:
> The use of fbackup for backing up NFS mounted file systems is not guaranteed to work as expected if the backup is done as a privileged user. This is due to the manner in which NFS handles privileged-user access by mapping user root and uid 0 to user nobody, usually uid -2, thus disallowing root privileges on the remote system to a root user on the local system.

So assuming the files have permissions
rwxr-x--- (Owner can do anything, other users in the group can read & execute, others [Including root from another system in this case] can't do anything.

You can test this as root by trying to copy a file from the NFS mounted filesystem.

Either change the permissions to e.g. rwxr-xr-x, or if this creates a security issue, run fbackup as a member of that group. You may have to split the backup, doing one backup without the -n option (so it doesn't read the NFS drives), then another, as a member of that group, just for the NFS drives.
0
 

Author Comment

by:nakanoas
ID: 2799752
tfewster,

  Files that get this message are created by Mentor Graphics, they are circuit diagram files.
  All Workstations are connected in LAN and are NFS mounted (all of them are HP-UX 10.20).
  what to do?
0
 

Author Comment

by:nakanoas
ID: 2800037
tfewster,

  Forget the last comment, it was the same !

  Permissions for all files created by Mentor Graphics are -rw-rw-r-- located in workstation 3.

  To run fbackup i´m using the sintax :

/etc/fbackup -n -f /dev/rmt/1m -2 -u -g /var/adm/fbackupfiles/graphs/TAPE1

  This is an script to run daily backup and TAPE1 indicates what to backup.
   
  I run fbackup from workstation 2 as root where the DAT drive is mounted

  Until this week I was not receiving the message "could not stat file" it begins on this week, since monday.
0
 
LVL 21

Expert Comment

by:tfewster
ID: 2800122
Check the permissions on those files to confirm that they do not have global read permission, and (as root) test if you can copy a file from the NFS filesystem.

Test running fbackup while logged in as a member of the group that owns the files.

If you don't mind making the files globally readable, use chmod to do that and set the users umask to 022 so any new files created are globally readable.

Otherwise, create a user "mgbackup", in the same group as the users, and have "mgbackup" run the fbackup job for the graphics files.

Hope this helps, Tim




0
 
LVL 21

Expert Comment

by:tfewster
ID: 2811182
Sorry, I missed your last post as I was typing mine & I've been tied up
since then. I've reproduced the error myself now; If a directory within the
tree being backed up has read but NOT execute permissions, it will cause
fbackup to error in this way, as it tries to check whether a file has changed.

You can check this by working your way down the directory tree on the NFS
mount & using "ls -ld" to look at the directories & their permissions. You
can either
- Change the permissions to e.g. drwxr-xr-x ;

OR Override the permissions & prevent this from happening again by changing
/etc/exports to add "-root=workstation_2_host_name" to the line that
exports the data directory. This grants root on workstation 2 superuser
rights on the NFS filesystem.
0
 
LVL 21

Accepted Solution

by:
tfewster earned 200 total points
ID: 2836598
Hi nakanoas - As you haven't responded to my last comment, I assume it fixed the problem :)

If not, please reject this answer and let me know what the results were

Cheers, Tim
0

Featured Post

Get 15 Days FREE Full-Featured Trial

Benefit from a mission critical IT monitoring with Monitis Premium or get it FREE for your entry level monitoring needs.
-Over 200,000 users
-More than 300,000 websites monitored
-Used in 197 countries
-Recommended by 98% of users

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

A metadevice consists of one or more devices (slices). It can be expanded by adding slices. Then, it can be grown to fill a larger space while the file system is in use. However, not all UNIX file systems (UFS) can be expanded this way. The conca…
Introduction Regular patching is part of a system administrator's tasks. However, many patches require that the system be in single-user mode before they can be installed. A cluster patch in particular can take quite a while to apply if the machine…
Learn several ways to interact with files and get file information from the bash shell. ls lists the contents of a directory: Using the -a flag displays hidden files: Using the -l flag formats the output in a long list: The file command gives us mor…
Learn how to navigate the file tree with the shell. Use pwd to print the current working directory: Use ls to list a directory's contents: Use cd to change to a new directory: Use wildcards instead of typing out long directory names: Use ../ to move…

705 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question