Go Premium for a chance to win a PS4. Enter to Win

x
?
Solved

Internet connection woes

Posted on 2000-05-10
6
Medium Priority
?
190 Views
Last Modified: 2010-04-20
After much struggleling, I finally managed to get Corel Linux 1.0 onto the internet. To my dismay, it seems that even after I dialed in and connected to my ISP, I cannot access anything with Netscape. It is definitley NOT a DNS problem. Even without the proper DNS, shouldn't I be able to ping a IP address? Well, that doesn't work. What could be the problem?
0
Comment
Question by:jamesshuang
  • 3
  • 2
6 Comments
 
LVL 1

Expert Comment

by:rtheriot
ID: 2798317
how did you configure your ppp conection, go back in there and make sure your set up for receiving a dhcp address.

hth

rtheriot
0
 
LVL 2

Expert Comment

by:tzanger
ID: 2798495
It sounds like you don't have a default route set up.  Try adding "defaultroute" to your /etc/ppp/options file.

if you type route -n and can't see a "0.0.0.0" entry, this is definately your problem.
0
 

Author Comment

by:jamesshuang
ID: 2802793
Adjusted points from 50 to 80
0
Visualize your virtual and backup environments

Create well-organized and polished visualizations of your virtual and backup environments when planning VMware vSphere, Microsoft Hyper-V or Veeam deployments. It helps you to gain better visibility and valuable business insights.

 

Author Comment

by:jamesshuang
ID: 2802794
Sorry, tzanger, but adding "default route to the options didn't do anything. Also, there was a 0.0.0.0 entry, however, it was binded to eth0. Shouldn't it be binded to ppp0? How would I change the eth0 to ppp0? Any more suggestions?
0
 
LVL 2

Accepted Solution

by:
tzanger earned 160 total points
ID: 2804275
remove the default route from eth0.  you can't have two default routes (well you can, but we're not dealing with equal-cost multipath or anything like that here)

when your connection is established do this

ifconfig ppp0 (take note of the ptp address)
route -n (take note of the gw address)

route del default gw (whatever your gw address was)
route add default gw (whatever the ptp address is on ppp0)

If that fixes the problem, go edit your startup files (for slackware it's /etc/rc.d/rc.inet1) and remove the GATEWAY parameter or set it to "".  for other distros the procedure is similar but I'm not familliar on all of them.

next, make sure "defaultroute" -- NO SPACES -- is in your /etc/ppp/ppp-options.  without it pppd will NOT establish a default route and you won't get anywhere.  It is likely not doing anything now becuase you have set up a default route via eth0.
0
 

Author Comment

by:jamesshuang
ID: 2806201
Thanks, tzanger, you helped me through this one. I did not completely follow your directions, but I deleted one of the eth0 entries. I had to do this because if I logged onto the internet and typed route, the console would freeze up. Still, after I deleted one of the eth0 entries, the internet worked. Thanks, anyways.
0

Featured Post

Visualize your virtual and backup environments

Create well-organized and polished visualizations of your virtual and backup environments when planning VMware vSphere, Microsoft Hyper-V or Veeam deployments. It helps you to gain better visibility and valuable business insights.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

It’s 2016. Password authentication should be dead — or at least close to dying. But, unfortunately, it has not traversed Quagga stage yet. Using password authentication is like laundering hotel guest linens with a washboard — it’s Passé.
Fine Tune your automatic Updates for Ubuntu / Debian
Learn how to find files with the shell using the find and locate commands. Use locate to find a needle in a haystack.: With locate, check if the file still exists.: Use find to get the actual location of the file.:
Connecting to an Amazon Linux EC2 Instance from Windows Using PuTTY.
Suggested Courses
Course of the Month8 days, 3 hours left to enroll

824 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question