Solved

Win2000 Routing NAT

Posted on 2000-05-11
11
383 Views
Last Modified: 2010-04-17
I am running Server2000 with 1 NIC
and 1 Modem.  
NAT services doesnt seem to "route" the network for the computers connected to
the server.
NAT will NOT allow connectd computers
to ping or surf across to the interfaced modem to see the "gateway".
NAT DIALUP, of course makes the connection fine....and my ISP gives the server an IP address and gateway.  
The SERVER sees the gateway
and surfs/pings fine on internet.

No NAT/network routing via the modem/nic card.  (meaning NO SHARED access)
How to make the "shared" modem connection run via NAT?  


0
Comment
Question by:mavv
  • 4
  • 2
  • 2
  • +2
11 Comments
 
LVL 2

Expert Comment

by:estest
ID: 2816788
mavv,

We need a couple of tests here....

Can you ping the 2000 server from the clients?
Is the default gateway on the clients set to the NIC on the 2000 server?
Also check your subnet masks, they can also effect routing...


Tim
0
 

Author Comment

by:mavv
ID: 2820964
Tim:  Yes to all your questions.
But the gateway on the server2000 is
BLANK ....AFTER demand dialup makes
the connection to ISP.
NAT demand dialup goes blank after
calling into ISP and getting gateway
on modem showing up.
NIC card has no gateway shown using
ipconfig /all.
0
 
LVL 3

Expert Comment

by:apadua
ID: 2835732
Are your clients set up for DHCP? You can't have manually configured IP addresses for them. Also, is there a DHCP server on your network (If there is one, Internet Sharing will disable its DHCP, and your machines won't get an IP).
0
PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

 
LVL 2

Expert Comment

by:estest
ID: 2835849
I configured 2 Win2K Pro machines for sharing and this is what I saw...

The "server" changed the addresses of my NIC to 192.168.0.1 when I enabled sharing on it....
I did not change the modem properties...

I configured the "client" for DHCP and it drew an address from the "server".

That's really strange that your "server" doesn't have a default GW setup even when you are dialed into the ISP. Your "client" machines shouldn't have a problem with their default GW settings since they are DHCP.

I did not use demand dialup (I just VNC to the other  machine when I need the connection...) so I can't speak about it.



Tim
0
 

Author Comment

by:mavv
ID: 2838271
I am in the process of reloading
server2000.  DHCP is set and working
correctly.  DNS is working.  Client machine is working.  Clicking SHARE modem connection works.
MANUALLY SETTING NAT and NOT CHECKING
SHARE MODEM .....IS NOT WORKING.
NAT will not allow translation across
ISP to LAN.  NAT will only allow ISP to
talk to server2000.  
WHY WHY WHY?
0
 
LVL 6

Expert Comment

by:Portang
ID: 2877732
Hi, Mavv, are you still there ?

1. DHCP is not necessary, period. Sorry, apadua.

2. Windows 2000 Server has two ways of sharing Internet:
 A. ICS - By check the "Allow Internet Connection Sharing" on the Dial-Up Networking's Sharing Property.
 B. NAT - By configuring RRAS, the Routing and Remote Access Service.

3. Your NAT probably actually means ICS, Internet Connection Sharing, in this case. In fact, it's easier to configure.

4. Your Internal network has to be 192.168.0.x  w/ mask of 255.255.255.0 .  Is this what you have with your Ethernet ??  If not, and you don't want to adapt to this private IP scheme, then you need to configure RRAS w/ NAT !

5. Based on the above:
*** On the server - Make Ethernet adapter having IP of 192.168.0.1 . Also share the Dial-Up Network Adapter for Internet.
*** On the other computers - Make sure their default gateway is 192.168.0.1 . Also make sure in "Internet Options", choose MANUAL configure, LAN connection, NO proxy ...

Please feel free to let me know if there is any questions.  If you're interested in RRAS w/ NAT, surely let me know, too.
0
 
LVL 1

Accepted Solution

by:
Moses_R earned 750 total points
ID: 2949843
You need to setup your forward lookup zones on the domain server. There are several resources that show you how to do this. Just do a search on Hotbot for network adress translation and you'll find it.
0
 
LVL 3

Expert Comment

by:apadua
ID: 2973460
Sorry dude. You're right. W2000 Professional is the one that requires DHCP. OOPS.


A.
0
 
LVL 6

Expert Comment

by:Portang
ID: 2974670
Could somebody out there to unlock that thing !
0
 

Author Comment

by:mavv
ID: 2975917
Answer accepted
0
 

Author Comment

by:mavv
ID: 2975918
U were correct....forward lookup
was not running correctly.
Thanks again..........and it works
now.  
0

Featured Post

Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

There are two basic ways to configure a static route for Cisco IOS devices. I've written this article to highlight a case study comparing the configuration of a static route using the next-hop IP and the configuration of a static route using an outg…
I recently attended Cisco Live! in Las Vegas, a conference that boasted over 28,000 techies in attendance, and a week of hands-on learning hosted by a solid partner with which Concerto goes to market.  Every year, Cisco displays cutting-edge technol…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

856 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question