Go Premium for a chance to win a PS4. Enter to Win

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 285
  • Last Modified:

Jet error, Run-time error 3447

I can run this thing fine on my system, a co worker get invalid login and password despite being no such thing in it and another gets the error in the subject line and saying this:

The Jet VBA file failed to initialize when called.  

What is going on?
0
treyjeff
Asked:
treyjeff
1 Solution
 
AzraSoundCommented:
PRB: Error "The Jet VBA File...Failed to Initialize When Called"

http://support.microsoft.com/support/kb/articles/q192/9/34.asp

0
 
mdmurphyCommented:
Hi,
I found this snipit of info on my MSDN CD--hope it helps!

Applications like Visual Basic 6.0 and Visual C++ 6.0 install new versions of the DAO and Jet files on your development computer. Any version of VBAJet32.dll 6.0.1.8132 or later is now dependent on the file Expsrv.dll. The error occurs with your original setup program because it does not include Expsrv.dll in the dependency information.

RESOLUTION
To resolve the error, do one of the following:

Manually add Expsrv.dll to your file list for your existing setup program.

Re-create a new setup program from scratch that includes this new dependency.

0
 
AzraSoundCommented:
thats exactly what the link says that i pointed to
0
What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

 
treyjeffAuthor Commented:
I tried that and get an error on install when it gets to that file.  The destination system doesnt have any development tools.  I'm using VB5 Pro but I do have Visual Interdev 6 on my system.  Now when I try to run it on his system it says the db is in use by someone else when it isn't.
0
 
treyjeffAuthor Commented:
I have no idea whats going on!  I have tried a few things and just nothing!!
0
 
treyjeffAuthor Commented:
Ok, the absolutely diverse site gave a solution which at least made the error go away :)

Unfortunately there is now run time error 3051!!

It says" It is already opened exclusively by another user, or you need permission to view it's data.

What does this one mean?  I can still view it fine!
0
 
AzraSoundCommented:
how are you connecting to and opening the database?  can you post some code?
0
 
treyjeffAuthor Commented:
Here is what goes when we press button called Build Database - I can run it no problem but this other person can't!!!!:    

Dim DB As Database
   
    'The database is built using extracts from Control:Manufacturing
   
    'Delete the current database.
    Set DB = OpenDatabase("s:\pathapps\cmcost\cmcost.mdb")
'    Set DB = OpenDatabase("z:\testsrce\cmcost\cmcost.mdb")
    DB.Execute ("delete * from Detail")
    DB.Execute ("delete * from Master")
       
    Call ReadMaster(DB)
    Call ReadLabour(DB)
    Call ReadMaterial(DB)
    Call ReadStandard(DB)
0
 
AzraSoundCommented:
try this:


Set DB = OpenDatabase("s:\pathapps\cmcost\cmcost.mdb",True)

this will open it in exclusive mode..the default is shared mode...i think thats why you may be getting that error

also ensure when you close the program to close out all the database objects you create and set them to nothing, e.g.

DB.Close
Set DB = Nothing



0
 
treyjeffAuthor Commented:
The absolutelydiverse site gave me the answer.  Still having problems but different ones now.
0

Featured Post

Free Tool: Site Down Detector

Helpful to verify reports of your own downtime, or to double check a downed website you are trying to access.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now