getting linux to reconize ttyS1 or (Com 2)

linux 6.0
i wasn't paying attention to what i was doing and i deleted ttyS1 and was wondering if anyone knew how to get linux to realixe that its there
the device is a actiontec modem
and ive tried to setserial but nothing
i really don;t believe its a PnP
but it is PCI based
i've tried many things so if any one has and info it would help me much
Who is Participating?
modulusConnect With a Mentor Commented:
Hi johnny1234,

I am assuming from your post that all was working beforehand and that there was no doubt that the modem worked before.  If so then what you need is:
cd dev; ./MAKEDEV -v ttyS0

MAKEDEV is a script to create devices.  It's located on my RH6.1 boxes at /dev/MAKEDEV and you can find more info with:

However the command above should do the trick.

Best wishes,
You'd be well advised to check to be sure that your particular modem is usable. A number of the Actiontec PCI modems are WinModems, but there are a couple that aren't.
johnny, here is an extract of what I get
when I do a "man ttys" on a linux redhat 6.something system. It's hopefully sufficient to make you capable of reinventing your lost ttyS1 node.

TTYS(4)             Linux Programmer's Manual             TTYS(4)

       ttys - serial terminal lines

ttyS[0-3] are character devices for the serial terminal lines.
They are typically created by:

mknod -m 660 /dev/ttyS0 c 4 64 # base address 0x03f8
mknod -m 660 /dev/ttyS1 c 4 65 # base address 0x02f8
mknod -m 660 /dev/ttyS2 c 4 66 # base address 0x03e8
mknod -m 660 /dev/ttyS3 c 4 67 # base address 0x02e8
chown root:tty /dev/ttyS[0-3]


       mknod(1), chown(1), getty(1), tty(4)

Concerning recognition of your modem in
linux: Do you have also windows on your system, and if so does the modem work
ok and with which values for irq etc.?

Build your data science skills into a career

Are you ready to take your data science career to the next step, or break into data science? With Springboard’s Data Science Career Track, you’ll master data science topics, have personalized career guidance, weekly calls with a data science expert, and a job guarantee.

Sorry mean that to be a comment.
johnny1234Author Commented:
thanks so much
and modulas yes i've set up a dual boot with win98 se and there is no difference in the irq or
I/O val's why do you ask????
Hi johnnny1234,

the question about the windows and irq came from "hv".  The suggestion to use MAKEDEV came from me "modulus".  I think that the reason that "hv" was asking about windows and irq was that he thought that your modem just didn't work in linux (so I guess he figured that if your modem worked in windows then at least it wasn't broken and that you could find out your irq from windows and use that to set it in linux), whereas your problem was that you had accidentally deleted /dev/ttyS0 and wanted to recreate it.

best wishes,

ps. did you use MAKEDEV?
99 times out of 100 PCI modems are WinModems and are thus unusable under Linux.  However, you may wish to check out and see if they can help you at all.  

I haven't been there in a while but they may actually have them talking now.  I know they can dial and such.  :-)
johnny1234Author Commented:
thanks tzanger, i'll check it out

I no longer understand what you are asking.  Am I correct in the following assumptions:
1. Your modem was working fine
2. You did rm -f /dev/ttyS1
3. You now want to make your modem work again?

or is it that:

1. You are installing a new modem and have not yet got it to work
2. You accidentally deleted /dev/ttyS1?

Best wishes,
johnny1234Author Commented:
thanks for all your help but i got it working again
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.