Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people, just like you, are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
Solved

Network Busy when not Connect to Internet

Posted on 2000-05-12
7
280 Views
Last Modified: 2010-03-18
I have a Samba running on my Server and if the server is not connected to the Internet no one can access their files.  I do have IP masq running, but all seems to work fine until I lose a Internet connection.  I feel that it might have something to do with the DNS server what do you suggest?
0
Comment
Question by:dfrench
  • 3
  • 2
  • 2
7 Comments
 

Expert Comment

by:unixway52
ID: 2805162
More information would be helpful. Sounds like
you're doing a dialup connection?

What are the outputs from ifconfig -a and
netstat -rn (with and without your internet
connection up)?

Are the other hosts on the same subnet as your
NIC in the samba server?

0
 

Author Comment

by:dfrench
ID: 2805309
Yes It is a dial-up Connection.  If the dial-up loses connection the server can not be accessed.
==========================
[root@uniserver xxxxxxx]# ifconfig -a |more
-------------------------
dummy     Link encap:Ethernet  HWaddr 00:00:00:00:00:00
          BROADCAST NOARP  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
-------------------------
eth0      Link encap:Ethernet  HWaddr 00:A0:C9:E7:C2:FC
          inet addr:192.168.1.199  Bcast:192.168.1.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:2378053 errors:18 dropped:0 overruns:5 frame:5
          TX packets:2506698 errors:0 dropped:0 overruns:0 carrier:0
          collisions:213819 txqueuelen:100
          Interrupt:10 Base address:0x6000
-------------------------
eth0:1    Link encap:Ethernet  HWaddr 00:A0:C9:E7:C2:FC
          inet addr:192.168.1.10  Bcast:192.168.1.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          Interrupt:10 Base address:0x6000
-------------------------
lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:3924  Metric:1
          RX packets:26039 errors:0 dropped:0 overruns:0 frame:0
          TX packets:26039 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
-------------------------
ppp0      Link encap:Point-to-Point Protocol
          inet addr:63.11.21.118  P-t-P:206.115.159.113  Mask:255.255.255.255
          UP POINTOPOINT RUNNING NOARP MULTICAST  MTU:1524  Metric:1
          RX packets:7778 errors:3 dropped:0 overruns:0 frame:3
          TX packets:7566 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:10  
=======================================
[root@uniserver xxxxxx]# netstat -rn
Kernel IP routing table
Destination     Gateway         Genmask         Flags   MSS Window  irtt Iface
192.168.1.199   0.0.0.0         255.255.255.255 UH        0 0          0 eth0
206.115.159.113 0.0.0.0         255.255.255.255 UH        0 0          0 ppp0
192.168.1.0     192.168.1.199   255.255.255.0   UG        0 0          0 eth0
192.168.1.0     0.0.0.0         255.255.255.0   U         0 0          0 eth0
127.0.0.0       0.0.0.0         255.0.0.0       U         0 0          0 lo
0.0.0.0         206.115.159.113 0.0.0.0         UG        0 0          0 ppp0
0.0.0.0         192.168.1.199   0.0.0.0         UG        0 0          0 eth0
=============================
One Server with NIC's IP 192.168.1.199
192.168.1.199 is being broadcasted to 192.168.1.10
The server host MYSQL Server / Apache / Samba
0
 

Accepted Solution

by:
unixway52 earned 100 total points
ID: 2805601
Ok, a couple of things based on a glance at the info ...

I'm not sure what you have the secondary address on eth0 for but it's irrelevant at this point.

For some reason you have 2 default gateways in
your routing table. This is a no no. There can
only ever be 1 default gateway. The network route
192.168.1.0 takes care of hosts known to the local
subnet. So in essence you will have no default
gateway in your routing table until you bring up
the dialup connection. The exception to this
would be if there were other subnets you could
get to via a router hooked up to the 192.168.1.0
subnet, which I don't believe is the casgee here.

Are you running in.routed? No need to run a
routing daemon on small networks connected to the
internet.

Did you add the default route to eth0 at some
point in time? Perhaps via an rc script?
0.0.0.0 192.168.1.199 0.0.0.0 UG 0 0 0 eth0

What is the default gateway address you have
specified on the hosts on the eth0 network?
They should point at the nic in the linux box,
192.168.1.199. And you should have ip forwarding
turned on and I reckon you must be masquerading those addresses or doing a proxy off the linux
box if they are going out to the internet (
but I guess that doesn't matter either right
now, just where do they point for a default
gateway).

This last point is most likely where your trouble
is.
0
Easy, flexible multimedia distribution & control

Coming soon!  Ideal for large-scale A/V applications, ATEN's VM3200 Modular Matrix Switch is an all-in-one solution that simplifies video wall integration. Easily customize display layouts to see what you want, how you want it in 4k.

 
LVL 40

Expert Comment

by:jlevie
ID: 2807202
Two default routes are a problem as pointed out. But there may be more things wrong. What does /etc/hosts look like?
0
 

Author Comment

by:dfrench
ID: 2807352
hosts One Line
('192.168.1.199      uniserver')

hosts.allow (Empty)

Hosts.deny (Empty)

HOSTNAME One Line
('uniserver')

host.conf Two Lines
{'order hosts, bind')
('multi on')

I will correct the Routing Table Sunday and will post the results.
0
 
LVL 40

Expert Comment

by:jlevie
ID: 2807459
If /etc/hosts only contains the one line, then indeed there is another problem, but in this case it's probably the second default route that are causing this problem.

There should be at least two lines in /etc/hosts, one for the localhost definition and one for the hostname, as follows:

127.0.0.1      localhost.localdomain localhost
192.168.1.199      uniserver.localdomain uniserver

With an IP alias (192.168.1.10) on eth0, you should also have an entry in /etc/hosts for it, perhaps like:

192.168.1.10      uniserver-alias.localdomain uniserver-alias

It's not obvious why the IP alias is there, and in fact you may not need it. But if you do have it, Samba will want to have a a hostname associated with it.
0
 

Author Comment

by:dfrench
ID: 2818777
thanks
0

Featured Post

Master Your Team's Linux and Cloud Stack

Come see why top tech companies like Mailchimp and Media Temple use Linux Academy to build their employee training programs.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
E-mail settings for Fail2ban 7 139
Setup static routes for IP address in CentOS 2 66
centos7 firewalld udp ports 33 78
Set linux box as ip router 3 35
I have seen several blogs and forum entries elsewhere state that because NTFS volumes do not support linux ownership or permissions, they cannot be used for anonymous ftp upload through the vsftpd program.   IT can be done and here's how to get i…
Note: for this to work properly you need to use a Cross-Over network cable. 1. Connect both servers S1 and S2 on the second network slots respectively. Note that you can use the 1st slots but usually these would be occupied by the Service Provide…
The Email Laundry PDF encryption service allows companies to send confidential encrypted  emails to anybody. The PDF document can also contain attachments that are embedded in the encrypted PDF. The password is randomly generated by The Email Laundr…

856 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question