Solved

PPPD and eznet for login - logs included

Posted on 2000-05-12
2
325 Views
Last Modified: 2011-10-03
I have set up pppd with eznet and the computer dials and attemps to login but fails. I have included copies of the two logs. This should be a fairly simple question but I have allocated 200 points to anyone who can solve it. The logs look normal to me but somewhere there is an error. Where?

This is a diagnostic log of the most recent login
attempt by eznet.

  ISP Name: "freewwweb.com"
  Call Initiated: Thu May 11 21:44:58 2000

The UNIX command used to initiate the connection attempt was:

/usr/sbin/pppd /dev/modem 115200 connect '/usr/bin/eznet chat 0' defaultroute lock modem asyncmap 0 crtscts -detach idle-disconnect 600 user sharka2 remotename freewwweb.com

The interaction with the modem was as follows:

44:59.550 Send:  "atz\r"
44:59.658 Skip:  "atz\r\r\n"
45:00.208 Recv:  "OK\r\n"
45:00.208 Match: "OK"
45:00.208 Send:  "at&d3\r"
45:00.318 Skip:  "at&d3\r\r\n"
45:00.868 Recv:  "OK\r\n"
45:00.868 Match: "OK"
45:00.868 Send:  "atd4163979\r"
45:01.528 Recv:  "atd4163979\r"
45:48.168 Skip:  "\r\n"
45:48.718 Recv:  "CONNECT 115200\r\n"
45:48.718 Match: "CONNECT"
45:52.018 Send:  "\r"
45:52.128 Skip:  "\r\n"
45:52.128 Skip:  "\n"
45:52.128 Skip:  "\n"
45:52.128 Skip:  "\n"
45:52.128 Skip:  "\n"
45:52.128 Skip:  "\n"
45:52.128 Skip:  "\n"
45:52.128 Skip:  "\n"
45:52.128 Skip:  "\n"
45:52.128 Skip:  "\n"
45:52.128 Skip:  "\n"
45:52.128 Skip:  "\n"
45:52.128 Skip:  "\n"
45:52.128 Skip:  "\n"
45:52.128 Skip:  "\n"
45:52.128 Skip:  "\n"
45:52.128 Skip:  "\n"
45:52.128 Skip:  "\n"
45:52.128 Skip:  "\n"
45:52.128 Skip:  "\n"
45:52.128 Skip:  "\n"
45:52.128 Skip:  "\n"
45:52.128 Skip:  "\n"
45:52.128 Skip:  "\n"
45:52.128 Skip:  "\n"
45:52.128 Skip:  "UQKT2 tnt1.palm-springs.ca.da.uu.net\r\n"
45:52.128 Skip:  "\r\n"
45:52.128 Skip:  "\r\n"
45:52.678 Recv:  "Login: "
45:52.678 Match: "ogin:"
45:52.678 Send:  "sharka2\r"
45:52.788 Skip:  "sharka2\r\n"
45:53.338 Recv:  "Password: "
45:53.338 Match: "ssword:"
45:53.338 Send:  "***********"
45:53.448 Skip:  "\r\n"
45:53.558 Skip:  "\r\n"
45:53.558 Skip:  "** Bad Password\r\n"
45:53.558 Skip:  "\r\n"
45:54.108 Recv:  "Login: "
45:54.108 Match: "ogin:"
45:54.108 Send:  "sharka2\r"
45:54.328 Skip:  "sharka2\r\n"
45:54.878 Recv:  "Password: "
45:54.878 Match: "ssword:"
45:54.878 Send:  "***********"
45:54.988 Skip:  "\r\n"
45:55.098 Skip:  "\r\n"
45:55.098 Skip:  "** Bad Password\r\n"
45:55.098 Skip:  "\r\n"
45:55.648 Recv:  "Login: "
45:55.648 Match: "ogin:"
45:55.648 Send:  "sharka2\r"
45:55.758 Skip:  "sharka2\r\n"
45:56.308 Recv:  "Password: "
45:56.308 Match: "ssword:"
45:56.308 Send:  "***********"
45:56.418 Skip:  "\r\n"
45:56.528 Skip:  "\r\n"
45:57.078 Recv:  "** Bad Password\r\n"
45:59.828 Skip:  "\r\n"
46:00.378 Recv:  "NO CARRIER\r\n"
46:00.378 Match: "NO CARRIER"
46:00.378 Fail

The following messages were written to the system log
(in /var/log/messages) by pppd as it attempted to negotiate
a PPP connection.  To see more detail, set the "debug=yes"
property and reattempt the logon.

May 11 21:44:58 darkstar pppd[218]: pppd 2.2.0 started by root, uid 0
May 11 21:46:00 darkstar pppd[218]: Exit.
This is a diagnostic log of the most recent login
attempt by eznet.

  ISP Name: "worldnet.att.net"
  Call Initiated: Thu May 11 20:23:40 2000

The UNIX command used to initiate the connection attempt was:

/usr/sbin/pppd /dev/modem 115200 connect '/usr/bin/eznet chat 1' defaultroute lock modem asyncmap 0 crtscts -detach idle-disconnect 600 user 705185625 remotename worldnet.att.net

The interaction with the modem was as follows:

23:41.878 Send:  "atz\r"
23:41.988 Skip:  "atz\r\r\n"
23:42.538 Recv:  "OK\r\n"
23:42.538 Match: "OK"
23:42.538 Send:  "at&d3\r"
23:42.648 Skip:  "at&d3\r\r\n"
23:43.198 Recv:  "OK\r\n"
23:43.198 Match: "OK"
23:43.198 Send:  "atd3209426\r"
23:43.858 Recv:  "atd3209426\r"
24:04.648 Skip:  "\r\n"
24:05.198 Recv:  "CONNECT 115200\r\n"
24:05.198 Match: "CONNECT"
24:05.638 Skip:  "\r\r\n"
24:05.638 Skip:  "STATION ID - pldca01rs08hp015,snfca12ev\r\r\n"
24:05.638 Skip:  "\r\r\n"
24:05.638 Skip:  "Welcome \r\r\n"
24:06.188 Recv:  "Please Sign-on: "
24:06.188 Match: "-on:"
24:06.188 Send:  "705185625\r"
24:06.518 Skip:  "705185625\r\n"
24:07.068 Recv:  "Password:"
24:07.068 Match: "ssword:"
24:07.068 Send:  "****************"
24:07.398 Skip:  "\r\n"
24:07.398 Skip:  "Name, password pair incorrect\r\n"
24:07.948 Recv:  "Please Sign-on: "
24:07.948 Match: "-on:"
24:07.948 Send:  "705185625\r"
24:08.168 Skip:  "705185625\r\n"
24:08.718 Recv:  "Password:"
24:08.718 Match: "ssword:"
24:08.718 Send:  "****************"
24:08.938 Skip:  "\r\n"
24:08.938 Skip:  "Name, password pair incorrect\r\n"
24:09.488 Recv:  "Please Sign-on: "
24:09.488 Match: "-on:"
24:09.488 Send:  "705185625\r"
24:09.708 Skip:  "705185625\r\n"
24:10.258 Recv:  "Password:"
24:10.258 Match: "ssword:"
24:10.258 Send:  "****************"
24:10.478 Skip:  "\r\n"
24:10.478 Skip:  "Name, password pair incorrect\r\n"
24:11.028 Recv:  "Please Sign-on: "
24:11.028 Match: "-on:"
24:11.028 Send:  "705185625\r"
24:11.248 Skip:  "705185625\r\n"
24:11.798 Recv:  "Password:"
24:11.798 Match: "ssword:"
24:11.798 Send:  "****************"
24:12.018 Skip:  "\r\n"
24:12.018 Skip:  "Login failed, reason = (-189,snfca12ev,958097558-001,pldca01rs08hp015)\r\n"
24:12.018 Skip:  "\r\n"
24:12.018 Skip:  "Connection closed by foreign host.\n"
24:12.568 Recv:  "\r"
24:16.088 Send:  "\r"
24:20.048 Send:  "\r"
24:24.008 Accept

The following messages were written to the system log
(in /var/log/messages) by pppd as it attempted to negotiate
a PPP connection.  To see more detail, set the "debug=yes"
property and reattempt the logon.

May 11 20:23:40 darkstar pppd[122]: pppd 2.2.0 started by root, uid 0
May 11 20:24:24 darkstar pppd[122]: Serial connection established.
May 11 20:24:25 darkstar pppd[122]: Using interface ppp0
May 11 20:24:25 darkstar pppd[122]: Connect: ppp0 <--> /dev/modem
May 11 20:24:33 darkstar pppd[122]: Modem hangup
May 11 20:24:33 darkstar pppd[122]: Connection terminated.
May 11 20:24:33 darkstar pppd[122]: Exit.


0
Comment
Question by:garybaker
2 Comments
 
LVL 4

Expert Comment

by:kiffney
Comment Utility
According to the logs, either your password or your login name or both is incorrect (that's what the 'bad password' messages mean).  Check with your provider and find out what your login name and password actually are, then change them in the eznet setup.  Everything else looks good so once you get that straight you should connect.
0
 
LVL 1

Accepted Solution

by:
milchew earned 200 total points
Comment Utility
So, first try ppp-setup and then try again.
0

Featured Post

What Should I Do With This Threat Intelligence?

Are you wondering if you actually need threat intelligence? The answer is yes. We explain the basics for creating useful threat intelligence.

Join & Write a Comment

If you have a server on collocation with the super-fast CPU, that doesn't mean that you get it running at full power. Here is a preamble. When doing inventory of Linux servers, that I'm administering, I've found that some of them are running on l…
Linux users are sometimes dumbfounded by the severe lack of documentation on a topic. Sometimes, the documentation is copious, but other times, you end up with some obscure "it varies depending on your distribution" over and over when searching for …
Connecting to an Amazon Linux EC2 Instance from Windows Using PuTTY.
Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.

728 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

8 Experts available now in Live!

Get 1:1 Help Now