Solved

Windows 2000 internet access through a LAN

Posted on 2000-05-15
11
150 Views
Last Modified: 2010-04-13
I've set up a small network of computers connected via ethernet and running the  TCP/IP protocol.  One machine on the network is the gateway to the internet.

IP addresses are assigned from the private block of addresses (192.168.X.X) and each machine is assigned a fixed IP address locally (no automatic/dynamic IP address assignment of any sort).

I need to add a Windows 2000 machine to the network.  I tried to configure the connection in the usual way from the network settings menu without success: I can't get the machine to talk to any other machine on the network.

This machine is configured to dual-boot Windows 2000 or SuSE Linux 6.1.  When running Linux the same machine networks perfectly so it's not a hardware or cable problem.

Can anyone help?
0
Comment
Question by:periclis
  • 5
  • 3
  • 3
11 Comments
 
LVL 63

Expert Comment

by:SysExpert
Comment Utility
First, Make sure that you have the correct NIC driver for Win2k, NE2000 clones especially have problmes. get the win2k driver from the card manufacturer, and do not rely on the MS driver !

2) Try adding netbeui to the win2k machine and one other. That will narrow the problem to hardware or a TCP/IP problem.

If NetBEUI works, then we will have to work on the TCP/IP problem.
Keep me updated for further help.
0
 
LVL 6

Expert Comment

by:Lermitte
Comment Utility
I hope that the tcp/Ip settings are good. Rightclick on My computer => properties. Do you use a workgroep for you network. Is this workgroupname the same name on the w2k machine?

Can you ping the other PC's?

Mario
0
 

Author Comment

by:periclis
Comment Utility
Card is based on the Realtek 8139 chipset.  I'll look into the driver issue and keep you posted but I have a gut feeling that's not the cause of the problem.

Problem can't be hardware-caused; the same machine networks perfectly when running Linux, remember?

Re. NetBEUI: the other machines are running Linux...NetBEUI is not an option.

TCP/IP settings: the machine knows its own IP address and its own hostname.  

TRhe machine can ping itself by IP address and hostname but can't ping any other machines.

Workgroups:  Confessions time here guys...  I'm a UNIX/Linux/TCP-IP person, I don't even know what a workgroup is.  I understand the concepts of domain, zone, subnet and gateway, but I don't know anything about workgroups.

I have a hunch that this problem may be  something to do with dynamic (automatic) IP address allocation (DHCP or
similar). Since this is a small net IP addresses don't need to be allocated dynamically.  Maybe Win2000 has DHCP enabled by default.  Anyone know how to check?
0
 
LVL 63

Expert Comment

by:SysExpert
Comment Utility
Under win2k default is probably use dhcp. Check the network properties under My Computer properties-See if a workgroup is defined. It should be the same workgroup as the other Windows machines ( If any ).
If you have just Linux, then make sure you are using the static IP addresses. This wiull be in the TCP/Ip properties under the protocol Tab of the network adapter.
What do you get when you run ipconfig /all.
Redirect it to a file, and post the results here.
0
 
LVL 6

Expert Comment

by:Lermitte
Comment Utility
W1k have dhcp enabled. So rightclick on my network place => properties => choose the local area connection => right click => properties. Highlight TCP/IP protocol and choose properties. Here you can change the tcp/ip settings.

Mario
0
What Should I Do With This Threat Intelligence?

Are you wondering if you actually need threat intelligence? The answer is yes. We explain the basics for creating useful threat intelligence.

 

Author Comment

by:periclis
Comment Utility
The ethernet card driver is Microsoft provided, I will look for a different driver.

Settings:

Settings=>Control Panel=>System=>Network Identification=>
Full Computer Name: billy.mynetwork Workgroup: MYNETWORK

Settings=>Control Panel=>Network and Dial-up Connections=>(name given to ethernet connection) Mynetwork=>Internet Protocol (TCP/IP)=>Properties:
*Use the following IP address: 192.168.1.103 (IP address of Win2000
machine)
Subnet mask: 255.255.255.0
Default gateway: 192.168.1.101
(IP address of Linux machine used as gateway).

*Use the following DNS server: (IP address of my ISP's nameserver).

ipconfig /all returns:

Windows 2000 IP configuration

Host Name..............: billy
Primary DNS suffix:....: mynetwork
Node type..............: Broadcast
IP routing enabled.....: No ***I think
this may well be our problem!!!***
WINS proxy enabled.....: No
DNS suffix search list : mynetwork

Ethernet adapter mynetwork:

Connection-specific
DNS suffix.............:
Description............: Realtek RTL 8139(A) PCI fast ethernet adapter
Physical Address.......: (ethernet address)
DHCP enabled...........: No
IP address.............: 192.168.1.103
Subnet mask............: 255.255.255.0
Default gateway........: 192.168.1.101
DNS servers............: (my ISP's
DNS server)

Any ideas?
0
 
LVL 63

Accepted Solution

by:
SysExpert earned 200 total points
Comment Utility
Everything looks good. You do not need Ip forwarding ( this is for routing - ie, 2 NICs, and using NT to route between them ).
DHCP is off, and the subnet looks OK.
Like I said, get drivers from the manufacturer for win2k, and do not use what MS supplied.
0
 

Author Comment

by:periclis
Comment Utility
The ethernet card driver is Microsoft provided, I will look for a different driver.

Settings:

Settings=>Control Panel=>System=>Network Identification=>
Full Computer Name: billy.mynetwork Workgroup: MYNETWORK

Settings=>Control Panel=>Network and Dial-up Connections=>(name given to ethernet connection) Mynetwork=>Internet Protocol (TCP/IP)=>Properties:
*Use the following IP address: 192.168.1.103 (IP address of Win2000
machine)
Subnet mask: 255.255.255.0
Default gateway: 192.168.1.101
(IP address of Linux machine used as gateway).

*Use the following DNS server: (IP address of my ISP's nameserver).

ipconfig /all returns:

Windows 2000 IP configuration

Host Name..............: billy
Primary DNS suffix:....: mynetwork
Node type..............: Broadcast
IP routing enabled.....: No ***I think
this may well be our problem!!!***
WINS proxy enabled.....: No
DNS suffix search list : mynetwork

Ethernet adapter mynetwork:

Connection-specific
DNS suffix.............:
Description............: Realtek RTL 8139(A) PCI fast ethernet adapter
Physical Address.......: (ethernet address)
DHCP enabled...........: No
IP address.............: 192.168.1.103
Subnet mask............: 255.255.255.0
Default gateway........: 192.168.1.101
DNS servers............: (my ISP's
DNS server)

Any ideas?
0
 
LVL 6

Expert Comment

by:Lermitte
Comment Utility
Try this: Remove the DNS server from the configuration.

Mario
0
 

Author Comment

by:periclis
Comment Utility
Sorry,

I managed to destroy Windows 2000 while trying to install the ethernet card driver.

I will re-install windows 2000 and get back to you as soon as I've tried the new card driver.
0
 

Author Comment

by:periclis
Comment Utility
Well done SysExpert,

Yes, the Microsoft driver was the problem, driver from RealTek (www.realtek.com.tw) solved it.

200 points to you with thanks!
0

Featured Post

IT, Stop Being Called Into Every Meeting

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

Join & Write a Comment

NTFS file system has been developed by Microsoft that is widely used by Windows NT operating system and its advanced versions. It is the mostly used over FAT file system as it provides superior features like reliability, security, storage, efficienc…
A procedure for exporting installed hotfix details of remote computers using powershell
This video discusses moving either the default database or any database to a new volume.
This video shows how to remove a single email address from the Outlook 2010 Auto Suggestion memory. NOTE: For Outlook 2016 and 2013 perform the exact same steps. Open a new email: Click the New email button in Outlook. Start typing the address: …

743 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

15 Experts available now in Live!

Get 1:1 Help Now