Go Premium for a chance to win a PS4. Enter to Win

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 206
  • Last Modified:

Routing in RH 6.1

what necesary options have to be enabled in a linux box to make it act as a router ?
i have done the following in the proc filesystem :

ip_forward=1
rp_filter=0
ip_always_defrag=1

(above may differ a little as i am mailing this at 5 in the morning with no sleep :-) )

the linux box is acting strange, it allows ping to certain hosts and does not allow to others and after sometime starts to ping the hosts it was not pinging earlier.

please help

thanks
0
sapient
Asked:
sapient
1 Solution
 
linuxwranglerCommented:
Is your routing table set up correctly? The output of ifconfig, netstat -nr, and ipchains -L would be useful (substitute fake IP if you are worried about security but keep the substitutions consistent and note what they relate to).

Also, are you running any routing protocols like routd?
0
 
raducu80Commented:
Post the outputs as linuxwrangler said. Also, are you trying to masquerade other boxes? If so, did you compile tke kernel with the specific options? More info on what is needed in the kernel, in the IP-MASQ HOWTO available at www.linuxdoc.org
0
 
sapientAuthor Commented:
thank you both of you. i did manage to solve the problem. the problem was with the host i was trying to ping.
i realized that i could ping the host from behind the linux router but not from outside the linux router.
the problem was that the gateway had not been defined properly on the host.
0

Featured Post

VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now