Solved

Shared Folder Access Problem

Posted on 2000-05-16
3
155 Views
Last Modified: 2010-04-14
I have a new Win2000 server system at my company. I am a system administrator, and have configured the Win2K machine as a domain controller.

I want to setup a shared user file area like this:
---User Area
      \
      \---share1
      \
      \---share2
..etc., with the top level shared for network access.

I want to set permissions like this:
- Top folder & entire sub-tree - admins have full control access.
- Domain users & guests have read & execute, list contents, and read access for top level and sub-tree.
- Specific users have full control access only to the sub-folder assigned to them.

I tried to do this by setting myself up a user account. I tested the security settings; when logged in to the server itself (where the share is located) as a user, the security settings work as expected - I can have my way with the folder set up for the user I logged in as, but I can only view the contents of the other sub-folders under the top level share.

When I log in from my workstation (a Windows 2000 Professional machine), I can access the share, but I can only read and list folder contents, even for the folder that the user I logged in as was assigned full control access to.

Why would it work locally but not remotely? Is this a policy issue? Is this an inherited permissions issue? Is something to do with logging in from my workstation?

Please help!
Nate
0
Comment
Question by:NateCrowell
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
3 Comments
 
LVL 95

Accepted Solution

by:
Lee W, MVP earned 100 total points
ID: 2814930
I uncheak the inherited permissions always and apply them manually, going into the advanced button to propogate to sub directories.  Also, Make sure you haven't set share level permissions which might override file level permissions when connecting remotely
0
 
LVL 6

Expert Comment

by:Lermitte
ID: 2816617
The shared permission are other permision than the NT permissions. Under the share tab you find also permission settings. These are the permissions to set.

Check also if everyone can access the computer from the network, that's a policy that you can find under control panel => Administrator tools => User and local policy..

Mario
0
 

Author Comment

by:NateCrowell
ID: 2816856
Thanks...I checked just those things, and have fixed the problem!

Nate
0

Featured Post

Free Webinar: AWS Backup & DR

Join our upcoming webinar with experts from AWS, CloudBerry Lab, and the Town of Edgartown IT to discuss best practices for simplifying online backup management and cutting costs.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

NTFS file system has been developed by Microsoft that is widely used by Windows NT operating system and its advanced versions. It is the mostly used over FAT file system as it provides superior features like reliability, security, storage, efficienc…
Recently, Microsoft released a best-practice guide for securing Active Directory. It's a whopping 300+ pages long. Those of us tasked with securing our company’s databases and systems would, ideally, have time to devote to learning the ins and outs…
Exchange organizations may use the Journaling Agent of the Transport Service to archive messages going through Exchange. However, if the Transport Service is integrated with some email content management application (such as an antispam), the admini…
Are you ready to implement Active Directory best practices without reading 300+ pages? You're in luck. In this webinar hosted by Skyport Systems, you gain insight into Microsoft's latest comprehensive guide, with tips on the best and easiest way…

733 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question