Solved

good old pnp modems lol

Posted on 2000-05-16
18
318 Views
Last Modified: 2010-04-20
Ok, I've got a USR plug and play modem. It is an ISA, but it's NOT a winmodem.
I know I had the thing working at one time with Linux, but I re-installed and I forgot. Here's something that I remember doing. I used PNPDUMP > ISAPNP.CONF, then I ran ISAPNP ISAPNP.CONF.
Now it seems that I remember doing something in windows to force some CMOS table to be updated or something. It's using COM3 and is using IRQ 11 in windows. When I run PNPDUMP I think I see something like two devices.
Anyway, if I haven't totally confused everyone, can someone give me some hints, lol?
AMD 450 CPU 64MEG Ram, Asus motherboard, Win98 on one HD, Linux on other HD. Modem is USR 56K PnP (Not winmodem).

Thanks!

Jeff
0
Comment
Question by:jeffscharpf
  • 6
  • 3
  • 3
  • +3
18 Comments
 
LVL 1

Expert Comment

by:tadams
ID: 2815686
Try going into your BIOS setup program, and disabling all of your COM ports.  Sometimes for some reason or another, PNP modems won't work properly under linux unless the appropriate COM ports have been disabled.
0
 

Expert Comment

by:raducu80
ID: 2816010
Try to disable PNP from your BIOS if you can, and after that run pnpdump and isapnp. Set your isapnp.conf file to the exact specifications that you know the modem has. IRQ, IO..etc befor doing all this.
Also check your interrupts and your irqs to see if anything's conflicting
i.e. cat /proc/interrupts
See what you come up with. If you have trouble with it, i suggest to manualy edit your isapnp.conf, and remove all the options (out of the 3 usually) that you dont need, for each pnp board.
0
 
LVL 2

Expert Comment

by:modulus
ID: 2818768
Hi Jeff,
The advice from "raducu80" to disable PNP in the BIOS is good. But if you run pnpdump after that then it should respond with
`# No boards found'
because they've all been disabled in the BIOS.

Just leave pnp disabled in the bios and set up the board using the following procedure:

1. Do a:
`more /proc/interrupts'
There should be a list of the currently used interrupts. If "11" is being used by something that is not "serial" then it's already taken and you should chose one of the other free ones.

Given that you think that the IRQ is 11 and it's on COM3 you can use the following standard mapping of com to tty to determine that it's on ttyS3:

/dev/ttys0 (COM1), port 0x3f8, irq 4
              /dev/ttys1 (COM2), port 0x2f8, irq 3
              /dev/ttys2 (COM3), port 0x3e8, irq 4
              /dev/ttys3 (COM4), port 0x2e8, irq 3

In order to tell linux where it is use:
/sbin/setserial /dev/ttyS3 irq 11 autoconfig

Make sure that /dev/modem is symlinked to /dev/ttyS3

Then things should work out.

Best wishes,
modulus

0
 

Expert Comment

by:raducu80
ID: 2819977
Modulus is right..i dunno what i was thinking last night ;-) it was pretty late.
Did it work?
0
 
LVL 2

Expert Comment

by:modulus
ID: 2823971
Yeah...except that I wasn't reading what I posted and should have said:
/sbin/setserial /dev/ttyS2 irq 11 autoconfig
instead of S3....nothing like reading the content of your own posts.

Best wishes,
modulus
0
 

Expert Comment

by:RodZilla
ID: 2824116
Another option is to disable PnP on your ISA USR modem.  Most ISA USR modems can either have Pnp turned on, or have jumpers set to tell the modem what irq/port to use...
0
 

Author Comment

by:jeffscharpf
ID: 2830458
Ok, thanks for the responses.
Here's what I get when I do what you suggested:
the pnpdump thing worked, then I modified the ISAPNP.CONF file for card 2 which was my modem (I know it is because it's ID is USR###### something.)
When I run the ISAPNP ISAPNP.CONF, no matter what address I try to set it to, I get an "I/O Error allocating 8 bytes.."
Are there any linux commands that I can use to probe the modem if I know it's address? How do I know if the address/IRQ are correct, since it's a pnp modem? Window says it's com3 (0x3E8, IRQ11), but I still can't convince linux of this, lol!

Jeff
0
 

Author Comment

by:jeffscharpf
ID: 2830511
The actual error I get is:
Fatal error recource conflict allocating 8 bytes of IO at 0x3e8

I tried going in to windows and manually setting the usr modem to 0x3e8, irq11, then rebooted. I got the message saying that the ESCD was updated.

I always thought that this forced BIOS to allocate those recources, but I can't remember now.

When I do a more ioports I see that 0x3e8 is set for a serial port (auto).
Is this why it's conflicting? If so, how do I get rid of it?

Jeff
0
 

Author Comment

by:jeffscharpf
ID: 2830515
Adjusted points from 200 to 300
0
Free Trending Threat Insights Every Day

Enhance your security with threat intelligence from the web. Get trending threat insights on hackers, exploits, and suspicious IP addresses delivered to your inbox with our free Cyber Daily.

 
LVL 1

Expert Comment

by:tadams
ID: 2830814
Did you try my suggestion of diabling all other COM ports in the BIOS?
0
 
LVL 2

Expert Comment

by:modulus
ID: 2830818
Hi jeffscharpf,
You wrote:
How do I know if the address/IRQ are correct, since it's a pnp modem?

Well, it's going to be damn hard.  The consensus on this question so far has been to _disable_ pnp using the BIOS. It's _much_ easier.  Then you can just use the "setserial" commands.

Best wishes,
modulus
0
 
LVL 1

Expert Comment

by:tadams
ID: 2831056
Disabling PNP in the BIOS should be a last resort.  I have gotten two PNP modems working under Linux just by simply disabling all COM ports in the BIOS.  Disabling PNP will prevent windows from using PNP as well.  One of the modems I got running was a USR Sportster 33.6k, and the other was a Cardinal 33.6k.
0
 
LVL 2

Expert Comment

by:tzanger
ID: 2834214
Make sure you UN-comment the "ACT" line for the modem in isapnp.conf.  pnpdump does NOT activate the PnP hardware it finds.

I have set up many PnP modems under Linux, and even multiple PnP modems under a single box for 4-line EQL (load balancing).  pnpdump does a lot of things right, but not activating the hardware seems a little boneheaded to me.

If you get errors about resources in use and you are certain that the program is incorrect, you can change the CONFLICT line to read IO WARN instead of IO FATAL and just live with the warning.  I've had a few systems erroneously report that IO space was being shared when it wasn't.
0
 

Expert Comment

by:raducu80
ID: 2834414
tzanger is right! You want to mannually uncomment the act lines. You must do this by hand because, from what i can remember there are 2 or 3 options of __act__ per pnp board in the isapnp.conf file.
0
 

Author Comment

by:jeffscharpf
ID: 2843263
Linux hates me lol
It's so weird. I've done what you all suggested. I see the config file and I'm able to edit it correctly and now when I run isapnp isapnp.conf it appears to work because it lists two devices, one which looks like my modem. But when I go to the KPPP thingy it still doesn't connect to my modem when I use ttys2. In fact, I've tried them all, and ttys1 actually says "modem ready" but I think it's talking to the comm2 device which is my palm pilot connector. I think this because it sends out the ATI commands and never gets a response, but says modem is ready and the modem should be at ttys2.
So, are there any good command lines to talk to the modem like the old terminal program in windows? :0
 i want my mommy
0
 
LVL 2

Accepted Solution

by:
tzanger earned 300 total points
ID: 2843298
run minicom -s (as root) and select ttyS2.  try asking the modem a few questions

AT  --> should respond OK
ATI1 --> should say *something*

usually if you get an OK after an AT you've got a hayes-compatible modem.

If that's not working, make sure you're running setserial with the right options...  if the modem has a 16550A say

setserial /dev/ttyS2 port 0xXXX irq Y uart 16550A

where XXX is the port and Y is the irq you specified in isapnp.conf.

Let me know the result.
0
 

Author Comment

by:jeffscharpf
ID: 2848295
Comment accepted as answer
0
 

Author Comment

by:jeffscharpf
ID: 2848296
Thanks everyone! I hope the rest of you aren't mad, but tzangers was the final thing that made it work, so I'm giving the points to him(her). I had the pnpdump thing working and figured out. It was when I commented out the error line (in the isapnp.conf file) completely that it worked. It gave me a warning, but still seemed to allocate the I/O and IRQ because after that it worked.I wish I could give points to everyone, because you were all a great help! Now I've got the modem working fine, I just have to get my browser to see the darn DNS thing, lol...I can log on but now I got to figure out how to browse the internet, lol..
Thanks again.
Jeff
0

Featured Post

How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

Join & Write a Comment

SSH (Secure Shell) - Tips and Tricks As you all know SSH(Secure Shell) is a network protocol, which we use to access/transfer files securely between two networked devices. SSH was actually designed as a replacement for insecure protocols that sen…
This article will explain how to establish a SSH connection to Ubuntu through the firewall and using a different port other then 22. I have set up a Ubuntu virtual machine in Virtualbox and I am running a Windows 7 workstation. From the Ubuntu vi…
Learn how to find files with the shell using the find and locate commands. Use locate to find a needle in a haystack.: With locate, check if the file still exists.: Use find to get the actual location of the file.:
Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.

746 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

12 Experts available now in Live!

Get 1:1 Help Now