Solved

(one for a DOS pro')   REAL MODE driver for NIC

Posted on 2001-06-04
17
902 Views
Last Modified: 2010-05-18
I'm trying to do some basic DOS / Win3.11 networking.
I'm using a Pentium 1 w/166MHz cpu & 64megs ram w/ 1gig hard drive.
The Mother Board is a P55T2P4 Asus with both PCI and ISA slots
The hardware is Okay with no issues (as far as I know)

I've TRIED going to NetGear (manufacturer) & they're NO help.
Their Knowledge Base has NOTHING on this.  Yet they tell me it's been tested & works.

The NIC is a NetGear 10/100 PCI card.

The card is in physical slot 3, but is listed as DEVICE 10 (so in config files it gets referred to as SLOT 10... )

The network WORKS when I install the driver through Win for Workgroups 3.11 and use the driver from THAT directory on the floppy.

But, when I go to the DOS (ndis2) directory and install a real mode driver FA311.DOS in config.sys I get the error

               Netgear FA311 Fast Ethernet PCI Adapter DOS NDIS 2.0.1 Driver Version:1.04
               (c) Copyright ...........**************** blah blah blah................*******
               *** Protocol Manager file could not be opened.
               initialization failure.

Now,
When I have this installed the way I need it for WFW 3.11... there is no error.
there is also no real mode driver in config.sys (just a IFSHLP.SYS driver)

I'm not too familiar with the "old" DOS way(s)....

I'm thinking/hoping that this is actually a SIMPLE problem for an old DOS virtuoso.

NetGear ASSURES me that the PCI (PnP) NIC WORKS with DOS....
......I wanna know HOW......  

I think... I'm doing this right, but, I'm not sure.
Is there ANYTHING else I should do to setup the card in dos?

I tried loading NDISHLP.SYS in config sys along with IFSHLP (not even sure what these do)...

I tried JUST NDISHLP .... then, I got rid of BOTH of them.  And the only reference to ANYTHING networking is in the CONFIG sys file and it's the reference to the DOS driver.

And I get that protocol message.

WFW = fine
DOS = No Go

I don't get it.... yet.
IF no one can help me, my next experiment is to put the nic into my NEW P3 and load dos and try it.  Maybe it's a BIOS thing and the DOS ain't werkin' quite right with the "old" PC/BIOS.

Is there something BASIC (in DOS) that I'm missing?  Or, should TRY?
0
Comment
Question by:stvrich
17 Comments
 
LVL 13

Expert Comment

by:oldgreyguy
ID: 6154826
thought.......... in your BIOS, are you set to Plug and Play?, if so change it and see if the buzzard can pull out of the dive
0
 
LVL 12

Expert Comment

by:Otta
ID: 6155094
> when I go to the DOS (ndis2) directory

What files are in that directory?
Is that a directory on a floppy or on 'C:' ?

What file(s) have you copied from the directory?
Exactly what have you added to 'CONFIG.SYS' ?

> Protocol Manager file could not be opened.

Sounds like a 'something.INI' file needs to be copied
into the same directory as the 'xxxxxxxx.SYS' file.
0
 
LVL 47

Expert Comment

by:dbrunton
ID: 6155340
Could it be looking for a file called protocol.ini?  or something like protman.dos?  (which I don't think it should be).

Hmm, Otta suggested an ini file.

Config.sys should have something like

DEVICE=C:\......\***.DOS

Protocol.ini file ""might** have something like

DriveName=****
IOBase=****

but note this was for an SMC card.
0
 
LVL 1

Accepted Solution

by:
drno007 earned 100 total points
ID: 6155425
Download and install the MS client for dos from ftp://ftp.microsoft.com/bussys/clients/msclient/

There are 2 .exe files. when asked which networkcard you have insert your floppy and it all should work.
0
 
LVL 1

Author Comment

by:stvrich
ID: 6155680
You guys are AWE-SOME!!!  good suggestions... ALL of you.
0
 
LVL 1

Author Comment

by:stvrich
ID: 6155686
Old Grey Guy...

I checked my BIOS (in the PnP/PCI section) and there is NO setting for a PnP Operating System.

As far as I could SEE anyway.
0
 
LVL 1

Author Comment

by:stvrich
ID: 6155718
Otta...

I'm at work now, so I'll provide details later.

I've BEGUN playing around with stuff that's been leading me in the direction you are suggesting.  I may need help figuring out what to do.

From what I've seen, the DOS-Booting version IS INDEED missing something like an *.ini file.  (for DOS?)

I've come to that conclusion, b/c the card initializes correctly AFTER... I've started Win3.1.

The trick is...   "what ...PRECISELY" do I tell the DOS-Booting driver?"                so, I'm werkin'-on-it.

I'll werk on it HARDER since you've also suggested it.

...............Are you speaking from EXPERIENCE???



...dbrunton
Yes, I agree, and I may need help in figuring out terminology.

The floppy DOES contain hints as to how to word what's necessary (IF NECESSARY to nitialize the NIC).  The driver IS supposed to find things like the location of the card automatically.  (if the BIOS is good, I don't see why that wouldn't work).

unfortunately I don't know if I have to TELL the card what protocols to use in the device driver statement.  (I don't think I have to but, who knows?)

That may be the job of an *.ini file

But, I've NEVER heard of an *.ini file for DOS!!!!!


drno007...
I have heard of this MS-DOS client.
And I'll TRY it.  It may help me either figure out what's wrong with THIS setup I'm working with.  Or, it may give me a workable alternative for a DOS-Bootable NETWORK system.

______________________________________________

Guys,

Once I get this "Werkin' in DOS" from the hard drive...
I'd LIKE to be able to create a dos-bootable diskette with fundamental full access to the workstation.  Like a peer to peer DOS setup.

This has GOT to be possible.

I'll keep hackin' at it, but, I'm at work now.
0
 
LVL 1

Author Comment

by:stvrich
ID: 6155777
in the WFW *.ini files there ARE references to the protocol and nic driver.  I think they are BOTH...

       drivername=fa311$.***

SOMETHING like that, but, it has dollar signs in it.
I THINK I'm gonna need a statement (*.ini?) somewhere, refering to the driver in that dollar-sign format.

In the NDIS2DOS directory on the floppy, there IS another file that I have not used.

After I get home, I'll hack around a while, then update you guys & provide answers to all questions.
0
How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

 
LVL 10

Expert Comment

by:tonnybrandt
ID: 6156011
listening...
0
 
LVL 24

Expert Comment

by:SunBow
ID: 6157173
All comments sound good from here. You might try manual for IRQ, dunno why no pNp (I'd disable, so that = good news), sometimes multiple drivers go to config.sys, as well as autoexec.bat for separate layers like MAC and LINK and DATA. Difference, you know, is in AutoExec you usually get a /u switch to pull 'em out so you can change your mind on parameters and then put 'em back in (without rebooting, bygosh).

My guess is more extensive search on the diskette is best approach currently, unless someone else runs with this card that way.
0
 
LVL 1

Author Comment

by:stvrich
ID: 6158082
There is not too much on the disk at all to help me out with DOS...
I've searched.

I've searched the Manufacturers knowledge base...
And I've WRITTEN to the Manufacturer (they claim NO SUPPORT for DOS)
They suggested that I write to "unsupported at NetGear.com)  which I've done, and gotten 1 (very poor) response.  ("It works in DOS... check w/MicroSquish...")

This means, they don't WANNA help me get it running...  

Which MAY mean, I'm just...       BEING DUMB....    and I'm just missing something basic.  (which is usually the case).

I'm home now...  So, I'll try a few "experiments" and give you guys feedback either tonight or tomorrow.

Thanx much, pls standby........
0
 
LVL 1

Author Comment

by:stvrich
ID: 6158097
There is not too much on the disk at all to help me out with DOS...
I've searched.

I've searched the Manufacturers knowledge base...
And I've WRITTEN to the Manufacturer (they claim NO SUPPORT for DOS)
They suggested that I write to "unsupported at NetGear.com)  which I've done, and gotten 1 (very poor) response.  ("It works in DOS... check w/MicroSquish...")

This means, they don't WANNA help me get it running...  

Which MAY mean, I'm just...       BEING DUMB....    and I'm just missing something basic.  (which is usually the case).

I'm home now...  So, I'll try a few "experiments" and give you guys feedback either tonight or tomorrow.

Thanx much, pls standby........
0
 
LVL 1

Author Comment

by:stvrich
ID: 6159502
OY...

Having a hard time making Methodical Progress.  It'll take me a little longer to get back to you all with good notes.  But here's a little bit more on it.

What is in the NDIS2DOS directory on the floppy???
   The FA311.dos driver
   And PROTOCOL.INI  

The sample protocol.ini has many comments in it detailing how to modify the file.  But, ultimately it has only a couple options and it comes PRE-configured with the line...        DriverName = "FA311$"    that is the ONLY default.

At one point, I modified the protocol.ini with the line:
   DriverName = "PROTMAN$"  but, it made NO difference.

I had copied the PROTMAN.DOS driver out of the windows directory and put it in the same directory with the DOS driver.  I ALSO MADE A DEVICE=C:\PROTMAN.DOS line in config.sys (And I had Protocol.ini in the directory with the FA311 driver)  None of this seemed to work.

BTW the DOS driver is the SAME driver as for WFW setup.  The only difference between the two directories on the floppy is the WFW setup has an oem-INF file instead of protocol.ini.  (however, WFW generates it's own protocol.ini of course).  So, I'm looking CLOSELY at the WFW Protocol.ini file scripting.

I need more time to look at and UNDERSTAND what I'm looking at.  I can't even formulate good statements for you guys right now.

I've downloaded the MS DOS client and begun looking at the contents.  It parallels all the stuff I'm looking at so far.  So, hopefully I'll learn something from that dos client.

I'll update later.  Right now, I'm at work again.
0
 
LVL 3

Expert Comment

by:sverre
ID: 6171077
I will check at work (after the weekend) how exactly you boot on a floppy whith NDIS2 driver. We are doing it with bootproms (the bootprom calls a floppyimage), so it is possible.
0
 
LVL 1

Author Comment

by:stvrich
ID: 6171182
UPDATE:    I had NO idea a PROTOCOL.ini file could have SO Many lines scripted for DOS!  NOR did I have any IDEA of how much gets copied to a C\NET directory!!!

I've never seen or suspected the complexity (I should have known)
Just because it's DOS... I thought it would be (very) SIMPLE.
I mean, it's SIMPLE...  but not one or 2 lines of instructions.

The Protocol.ini file can be similar to that found in Windows for Workgroups.

What I've done is ATTEMPTED using the MS-DOS client ver. 3.0.

Problem was, SETUP would NOT detect the NDIS2 driver for DOS for this network card.  (The NetGear site mentioned that ONE little problem with their cards' NDIS drivers).  In the case of Ghost, it's looking for some kind of packet driver, which this is not ... (I guess).   Ghost has difficulty making connection with this card too.

So, not only am I learning DOS-Networking, I'm using a Pain In the A-- card too!
(maybe I'll just throw a link-sys card in there).

NetGear HAS AN ISSUE that makes it difficult to create a Ghost / DOS diskette.
I'm researching it further.  IT DOES work.... you just have to KNOW how to create the initialization files.  Which, I obviously DO NOT Know how to do yet...  (but, am learning).

This is actually GOOD.  It's forcing me to learn the basics of DOS Networking.
Quite handy, I'm sure.  But, a pain to go through.

My Loved One(s) have been about to revolt.... I've had to spend time with them over the week and not work on this.   But I DID do an MS DOS setup using the MS dos client and an NE2000 compaitible driver.

That made it create some initialization files which I'm studying.

I'll try to  (re)CREATE proper initializatin files for MY DRIVER....

After I've attempted that (& if it does not work)  I'll copy / paste files into this dialogue for you guys to look at and critique...

Or, I'll just give up and buy a Link Sys Card for this machine.
But, I'm INTERESTED NOW, and would like to learn to MAKE it WORK.... (hack)

Then, get the Link Sys and throw it in.  And SEE how they compare.
0
 
LVL 3

Expert Comment

by:Fenman
ID: 6193223
You could also look for a file called net.cfg if protocol.ini does not sort it out.

Cheers
0
 
LVL 1

Author Comment

by:stvrich
ID: 6224808
I want to thank you guys for your comments & suggestions.

I'm granting the points the way I did b/c I simply did not know or understand HOW to get a DOS setup going.

Add to that, the complexity of a PnP NIC which did not behave well...

So, my problem was ill-defined.

But, from what I've seen, I actually DO have an understanding of the basics now.

I think the hint given by drno007 epitomizes the situation...

Learn to set it up in DOS.
The DOS client diskettes showed me ROUGHLY... how to get it working... purely with DOS.  And SHOWED me just how complex it could get.

It also confirmed that I'll have to play around with settings for different situations.
0

Featured Post

How to run any project with ease

Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
- Combine task lists, docs, spreadsheets, and chat in one
- View and edit from mobile/offline
- Cut down on emails

Join & Write a Comment

Introduction Often we come across situations wherein our batch files would be needing to reboot Windows for a variety of reasons. A few of them would be like: (1) Setup files have been updated whose changes can take effect only after a reboot …
In a recent article here at Experts Exchange (http://www.experts-exchange.com/articles/18880/PaperPort-14-in-Windows-10-A-First-Look.html), I discussed my nine-month sandbox testing of the Windows 10 Technical Preview, specifically with respect to r…
Internet Business Fax to Email Made Easy - With eFax Corporate (http://www.enterprise.efax.com), you'll receive a dedicated online fax number, which is used the same way as a typical analog fax number. You'll receive secure faxes in your email, fr…
Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.

758 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

19 Experts available now in Live!

Get 1:1 Help Now