Trouble Moving Mail Files

We're running 5.0.5 with a clustered hub and two spoke servers.  All four servers are NT4.0 SP6

A user that currently resides on our clustered server is moving to another one of our locations.  We would like to move his mail file with him to the corresponding mail server.

From the Admin client, I went to People & Groups | People and selected the user.  I clicked on Move Mail File and entered the name of the destination server, Server/Domain.  It says it was successfully submitted to AdminP.

AdminP checks the Mail Server's Access and has the following Action comments:  

Selective replication formulas in mail\juser have references to Joe User/Domain's old mail server (HubServer/Domain)

It tries to Create New Mail File Replica and has the following error:

File name: Server/Domain!!mail\juser; Name: Server/Domain; Error:  You are not authorized to perform that operation

I have administrative access on each of the servers.  Any ideas on how to get around this or make it work correctly?

Thanks!
jk9783Asked:
Who is Participating?

Improve company productivity with a Business Account.Sign Up

x
 
HemanthaKumarConnect With a Mentor Commented:
Could be a bug too, seems to be very recent one.
0
 
HemanthaKumarCommented:
Check the server document of the target server for Who can create new replica and see whether the server and admin groups are added to the list.

~Hemanth
0
 
jk9783Author Commented:
I am listed explicitly in Create replica databases.  Also included is our Admin group and LocalDomainServers.
0
Free Tool: Site Down Detector

Helpful to verify reports of your own downtime, or to double check a downed website you are trying to access.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
HemanthaKumarCommented:
Can you with admin access create a replica on the target server ???
0
 
jk9783Author Commented:
Yes, no problem with that.
0
 
jk9783Author Commented:
There is an existing connection document in place.  I have edited it and saved it again.

I tried to move it using the icon and Tools | People | Move.

Same error is occurring.
0
 
HemanthaKumarCommented:
Try rebuilding the index of all view in Address Book of tgt srvr by using shift+f9

0
 
jk9783Author Commented:
I opened the Admin client for the destination server.  While in the People & Groups tab | People I did shift+f9.  I also did this in names.nsf on that server.

No luck.  Same errors.

As this is becoming more troublesome, I'm upping the points.
0
 
HemanthaKumarCommented:
I believe that it is to do with mail file acl, does it have proper access control for admin or Server.

If it(server) has to create a replica it should be able to look at the database with certain access (atleast reader).

0
 
jk9783Author Commented:
The current server, destination server, myself and the user all have manager rights in the ACL.  

0
 
HemanthaKumarCommented:
So you mean to say it doesn't happen for one particular user it is for everyone, right !

THen I have to check and will get back to you .

0
 
jk9783Author Commented:
This is just the first one we've had to move.  I'll try it with another one and get back with a definite answer.  

Another one of our administrators also tried to complete the move and was given the same error messages with this file.  So in that respect, it's not just me.
0
 
merchant_scCommented:
Make sure you have allowed the other servers to create replicas in the server document.  You as a user are able to create replicas, but can the server using the AdminP process do it?  

In all my server configurations I create a group that is allowed to create new replicas, that group always contains my list of "localdomainservers" so they have access to create replicas on each other.
0
 
HemanthaKumarCommented:
jk9783

Does the target server where you are moving the mail file to have the same file as that of the source ???

check that as you mentioned it is a clustered environment !!!

~Hemanth
0
 
jk9783Author Commented:
No, the one we're moving it to is one of the spoke servers.

I'm sorry I haven't had a chance to try your other suggestions as of yet.
0
 
jk9783Author Commented:
I see that Notes.net posted 5.0.8 today.  The following is listed in the fix list:

SPR# DWIN4V7PFE - When the source server of a mail file moves via the Administration Process, user receives an error creating the mail file replica, the source server will be listed as the cause of the error.

I wonder if this may be the fix to my problem.  It may be a while as we are kind of slow on upgrading the server.
0
 
jk9783Author Commented:
Do you think an upgrade to 506a might help or another version between 505 and 508?  
0
 
jk9783Author Commented:
Finally found the answer to this last week!

It is a bug! Or at least it looks like one.  We are not able to move the db from the people & groups tab.  We have to move it from the files tab.  We are only able to move it AFTER we make the following ACL change:  Change the current server from User Type: Server to Unspecified.  Only after making this change, will it allow you to move the file.

Of course, because you're moving the file from the File tab you have to make the person doc changes manually.

Thanks so much for all of your help!
0
 
jk9783Author Commented:
It was a bug.  You were right!

Thanks for your help.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.