Solved

UTL_FILE Unix file permissions

Posted on 2001-06-05
6
2,023 Views
Last Modified: 2012-05-04
Oracle 8.1.6  Sun Solaris.
When UTL_FILE supplied packages creates a file its permissions are "rwxr-xr-x"
How can I change this default to "rwxrwxrwx" ?
0
Comment
Question by:peledc
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 2
6 Comments
 
LVL 9

Accepted Solution

by:
dbalaski earned 20 total points
ID: 6158416
Hi,

This can be changed by resetting the oracle instance owner (presumably the oracle account)  umask.   Since the unix account of the oracle instance is the owner of the server process, these will be passed on to the process.  .
Set the umask to 777  for the"rwxrwxrwx" premissions  before starting the instance and then it should work.

sincerely,
dBalaski
0
 
LVL 1

Author Comment

by:peledc
ID: 6158561
Wouldn't this have any effect on the Oracle instance in any known way?
0
 
LVL 1

Author Comment

by:peledc
ID: 6158563
Wouldn't this have any effect on the Oracle instance in any known way?
0
Windows Server 2016: All you need to know

Learn about Hyper-V features that increase functionality and usability of Microsoft Windows Server 2016. Also, throughout this eBook, you’ll find some basic PowerShell examples that will help you leverage the scripts in your environments!

 
LVL 1

Author Comment

by:peledc
ID: 6158589
Wouldn't this have any effect on the Oracle instance in any known way?
0
 
LVL 9

Expert Comment

by:dbalaski
ID: 6159586
Hi,

No,   it won't effect the way the instance runs.   remember, umask utility is only used to set the file mode creation  mask (permissions).
So, in this case, any new files created by  the oracle OS account, ie:such as trc files , dumps files,  new file generated by the UTL_FILE, etc)..     In fact, this is Oracle's recommended solution to that problem.

Sincerely
dBalaski
0
 

Expert Comment

by:harel_dayan
ID: 6190332
go to the place of UTL_FILE_DIR parameter and type
chmod 777 *
0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Working with Network Access Control Lists in Oracle 11g (part 1) Part 2: http://www.e-e.com/A_9074.html So, you upgraded to a shiny new 11g database and all of a sudden every program that used UTL_MAIL, UTL_SMTP, UTL_TCP, UTL_HTTP or any oth…
Cursors in Oracle: A cursor is used to process individual rows returned by database system for a query. In oracle every SQL statement executed by the oracle server has a private area. This area contains information about the SQL statement and the…
Via a live example show how to connect to RMAN, make basic configuration settings changes and then take a backup of a demo database
This video shows how to configure and send email from and Oracle database using both UTL_SMTP and UTL_MAIL, as well as comparing UTL_SMTP to a manual SMTP conversation with a mail server.
Suggested Courses

623 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question