Solved

Why am I getting this VxD WSOCK and this VxD VMM error message?

Posted on 2001-06-06
9
541 Views
Last Modified: 2013-12-28
Any idea what the following windows 98 error msg is telling me?

blue screen
-----------------
An exception 0E has occurred at 0028:c16f5c90 in VxD WSOCK (01) + 000006f0
This was called from 0028:c02525d5 in VxD VMM (13) + 000005d5
It may be possible to continue normally.

or this ... which seems to be related

dark screen
-----------------
out of range
(some ranges are displayed)
pc display settings correct? Y/N?

These errors are preventing one of my home pc's from functioning. They come up
frequently ... even when running win 98 in "safe mode".
0
Comment
Question by:pzxkys
  • 2
  • 2
  • 2
  • +3
9 Comments
 

Expert Comment

by:PastorDwayne
ID: 6160006
0
 
LVL 6

Expert Comment

by:kahlean
ID: 6160038
it is due to some corrupted file in your netwokr settings. TRy to reinstall all the network type that is listed in your network properties. If you have a network card, try to reinstall the driver again
0
 
LVL 15

Expert Comment

by:hewittg
ID: 6160161
Also try
Start
run
type in sfc
scan for altered files.  Also, a worm virus interferes with the winsock so rule that out.

Glenn
0
 
LVL 27

Accepted Solution

by:
Asta Cu earned 100 total points
ID: 6161247
There are so many possibilitites as to what could create Blue Screen problems and this error message.  More details as to your setup and environment from you to isolate would help.

Is WindowsUpdate current in terms of your having kept your Operating System, drivers and Browser updated with enhancements, patches and fixes?  If not, check that first. Get the updated version of Media Player as well (7.1)

Also, do you recall what changes you implemented either in terms of settings, new installs or uninstalls that may be contributing here?

Are your video and sound drivers updated and current?  Do you have Helix Hurricane installed?  Any other error messages?  Have you had problems changing your resolution settings and color depth?  Are you a Novell client? Did you recently add a new USB device?  

----

As said, these errors and OE errors can be traced to many sources:  this should help you isolate further:

---

Excerpt and link follows:

Fatal Exception 0E Errors
The Fatal Exception error's related to 0E (that's zero E) are hard to track down. I'm not pretending that I have all the answers for you here, but I will attempt to list some things that have fixed this problem for a number of users.

First, what are Fatal Exception Errors? There's a good article in the Microsoft Knowledge Base, describing these errors. See MSKB article Q150314.

Here is a list of Microsoft Knowledge Base Articles dealing with these types of errors:

16-Bit DMA May Cause Static or System Hang Q127022
A fatal exception 0E has occurred at 0028:xxxxxxxx in VxD VMM(06) + xxxxxxxx
Fatal Exception in VMM(06) Caused by Damaged Registry Q145836
An exception 0E has occurred at 00XX:XXXXXXXX in VxD VNETBIOS
Fatal Exception 0E in VNETBIOS Using NetWare Login Script Q149606
Fatal exception 0E at 0028:<xxxxxxxx> in VxD IOS(01)+<xxxxxxxx>
Fatal Exception 0E in Ios.vxd with SCSI Printer Q149563
Windows Sockets Programs Using WSIPX May Not Work Q159254
Fatal exception 0E at 0028:<address> in VXD VREDIR (04) + 00005A8D
Fatal Exception Error in VREDIR with DCOM Program Q176446 (Microsoft Windows 95)
A fatal exception 0E has occurred at 0028:C029F7A1 in VXD IFSMGR(04) + 0000D4F1
A fatal exception 0E has occurred at 0028:c0274274 in VXD IFSMGR(03) + 000CF7C
A fatal exception 0E has occurred at 028:C0282dB0 in VxD IFSMGR(03) + 0000 CF7C
Fatal Exception Error When Opening or Closing Control Panel Q175211 (HP Scanner software)
A fatal exception 0E has occurred at 0137:BFF9A3C0
A fatal exception 0E has occurred at 0137:BFF9A07C
"Fatal Exception 0E" Error Message Attempting to Open Folder Q176446 (Microsoft Internet Explorer for Win95)
A fatal exception 0E has occurred at 0028:C0003C72 in VXD VMM(01) + 00002C72
"Fatal Exception 0E" Error Message When Running McAfee VirusScan Q177672 (Video = Tseng Labs ET6000 chip set)
A fatal exception 0E has occurred in VxD Dsound(03)
Dilbert Err Msg: Fatal Exception 0E in VxD Dsound(03) Q178616 (Norton AV + Auto-Protect enabled)
Err Msg: A Fatal Exception 0E Has Occurred at 0028:C02A0201 in VXD IOS(04)+00001FC9 Q187214 (Corel CD Creator 2)
Novell Client32 Does Not Work After Upgrading to Windows 98 Q188168 (Novell Client32)
Setup Hangs in Plug and Play Detection Upgrading Over Client32 Q189185 (Novell intraNetWare Client)
A Fatal Exception 0E has occurred at 0028:C001AEEB Q189329 (Compaq FX-Series Monitors)
Err Msg: A Fatal Exception 0E Has Occurred at 0028:XXXXXXXX in VXD SYMEvent(02)+XXXXXXXX Q189655 (Norton AntiVirus or other Symantec program)
Fatal Exception 0E at 0028:c028bac6 in VXD Vwin32 05 +000281a Q190915 (Desktop Management Interface (DMI) Start utility)
A fatal exception 0E has occurred at 0028:<XXXXXXXX> in Vxd Vmwaudio (01)
MMSYSTEM257 Invalid MCI device ID. Use the ID returned when opening the MCI device.
MMSYSTEM296 The file cannot be played on the specified MCI device. The file may be corrupt, or not in the correct format.
Problems Using Media Player to Play .avi Files Q191195 (IBM Aptiva 2168-A92 or Acer computer with earlier model IBM Mwave sound card drivers)
DSS80: Fatal Exception 0E When Forcing Standby Mode Q191724 (Microsoft Digital Sound System 80)
An exception 0E has occurred at 0028:C1029F6C in VxD WSIPX(01) +00000DBC. This was called from 0028:C0043174 in VxD NDIS(01) +00000D7C
A fatal exception has occurred at 0028:C10297D1 in VxD WSIPX(01)+00000621
Fatal Exception Errors in Wsipx.vxd Q192445
An exception 0E has occurred @ 0028:C0035A67 in vxd ifsmgr (01)
Computer Hangs After Upgrade to Windows 98 with EtherFast Card Q192844 (Linksys EtherFast 10/100 network adapter)
A fatal exception 0E has occurred at 0028:FF027A60 in VXD HIDCLASS(01)+00000F40
Fatal exception in Windows. You must restart your computer
Fatal Exception When You Connect SideWinder Precision Pro Q192901
A Fatal Exception 0E has occurred at 0028:xxxxx in VXD IOS(04) Q192925 (Sb16.vxd file is located in the Windows\System\Iosubsys folder)
An exception 0E has occurred at 0028:C143EADA in VXD CDVSD(01) + 00001CFA. This was called from 0028:C18413E8 in VXD voltrack(04)+ 00000A18. It may be possible to continue normally.
Fatal Exception in CDVSD Starting Windows 98 Q197004 (SCSI DVD drive)
A Fatal Exception 0E has occurred at 015F:BFF9DBA7
General Protection Fault or Invalid Page Fault During Setup Q209321 (problem in the Dblbuff.sys file)
Error Message: Fatal Exception 0E in VxD IOS (04) Q243037 (Iomega Tools and Iomega Backup software)
Fatal Exception OE Has Occurred in VXD mrtRate (01) When Printing Q252414 (Conflict between your printer driver and Quicken)
Error Message: Fatal Exception 0E has occurred at 0028:C00082CD in VxD VMM(01) +000072CD Q253241 (incompatible or early version of a Matrox video driver)
Windows Media Player May Cause Fatal Exception 0E When Using Suspend Mode in Windows 98 Second Edition Q257845
Fatal Exception 00 has occurred in module WSIPX.VXD Q260284 (Epson Stylus Photo 870 printer)
A Fatal Exception 0E has occurred at <address> Q198811 (Okidata OL-600e)
VServer(01) + 00004d75 - Error: 0E: 0028:XXXXXX Q272991 (Windows Me Networking)
A fatal exception 0E has occurred at 0028:???????? in VXD VREDIR(??) + ????????. The current application will be terminated.
An error has occurred. To continue: Press Enter to return to Windows, or Press CTRL+ALT+DEL to restart your computer. If you do this, you will lose any unsaved information in all open applications. File Name: VREDIR(06) + 00006C54 Error: 0E : 0028:C02D2770

Exception 0E in Vredir.vxd on Remote DCOM Server Q271754 (drive mapping)

A fatal exception 0E has occurred at (address) in VXD (FSD) + (address). The current application will be terminated.
Note: The VXD in question is a File System Driver (FSD) from the list below:

CDFS (the path references a CD-ROM drive letter)
NWREDIR (the path references a network drive mapped by the Microsoft Client for NetWare Networks)
UDF (the path references a DVD-ROM drive)
VDEF (the path references an unformatted disk drive)
VFAT (the path references a floppy disk drive, a hard disk, or an FTL-formatted Linear Flash PCMCIA card (Flash File System)
VREDIR (the path references a network drive mapped by the Client for Microsoft Networks)
0028:DEDEDEDE (the path references a network drive mapped by the Novell NetWare Client for Windows 95/98 version 3.1)
Unknown (the path references drives managed by third-party, or custom file system drivers and network redirectors)
Fatal Exception 0E with Multiple MS-DOS Device Names in Path Q256015

A fatal exception 0E has occurred at (address) in VXD WDMAUD(06) + (address)
A fatal exception 0E has occurred at 0028:FF02D808
A fatal exception 0E has occurred at 0028:FF027240 in VXD USBD(01) + 00000440
Windows Driver Model Audio Update for Windows 98 Second Edition Q242937 (Audio, USB)
IFSMGR(04) + 000076A1 ERROR: 0E:0028 : C02AF8E1
X:Drive v2.0 Install Prior to WinMe Upgrade Produces ErrMsg Q266268 (X:Drive version 2.0 installed prior to upgrading to Windows Me)
NDISFILT(01) + 00000650 Error: 0E : 0028:C14796F0
Problem Installing Windows Me with Norton Internet Security 2000 Q268240
Error Message: A Fatal Exception 0E Has Occurred in VxD SCSI1HLP Q250005 (Hewlett Packard 8100i SureStor CD-Writer with the Easy CD Creator, the Easy CD Audio/Copier, or the Direct CD program)
An exception 0E has occurred at 0028:C0021E77 in VxD IOS(01) + 00001197. This was called from 0028:C00219AF in VxD IOS(01) + 00000CCF
Fatal Exception in IOS.VXD When Formatting Disk in LS-120 Drive Q214522
A Fatal Exception 0E has occurred at 0028:XXXXXXXX in VXD VSERVER(01) + XXXXXXXX.
Fatal Exception Error When Adding File and Print Sharing Q244229
Fatal exception 0E at 0028:C00BC6B0 in VXD VINESIFS(01) + 000342C
Error Message When Viewing Banyan VINES Network Properties Q206506
Windows 98 Shutdown Generates "Fatal OE" Error Messages Q200692 (Compaq)


--------------------------------------------------------------------------------

If you are running with an AMD chip, you should also note that there have been quite a number of reports on faulty L1 cache (the cache on the chip). Go in your computers BIOS (see your handbook for instructions), and disable the Level 1 cache. If this resolves your problems, consider buying a new CPU.

We noticed that this part is being quoted by several sources on the Internet as "News"; just realize that this is old information, going back around 1 year (beginning of 2000). We are no hardware experts, but we have had reports similar to the post by "HumanHunter" (Mar/07/2001 6:09 PM).



--------------------------------------------------------------------------------

Here's another short list to follow:


Check to see if you have the latest drivers installed for your motherboard.
Check to see if you have the latest drivers installed for your video card.
Turn off the external cache in BIOS.
Replace RAM chips.
Reinstall the OS. Do a clean install, by formatting the drive/partition.


--------------------------------------------------------------------------------

A common cause for these error messages is faulty physical memory (RAM) on the computer. It is possible that you have had faulty RAM in your computer, without it affecting you. But because Windows 9x uses your memory in a different way, it is possible that the fault shows up.

For a more extensive explanation, see Microsoft Knowledge Base Article Q138788

http://www.infinisource.com/windows98/troub-344.htm



asta





 
0
How to improve team productivity

Quip adds documents, spreadsheets, and tasklists to your Slack experience
- Elevate ideas to Quip docs
- Share Quip docs in Slack
- Get notified of changes to your docs
- Available on iOS/Android/Desktop/Web
- Online/Offline

 
LVL 3

Expert Comment

by:mafo
ID: 6163623
It looks like the files have been damaged.. overwritten parts.
You can find the WSock files and The VMM-files in the Win9x-cabs.. (or else, look for them in other applications)
Try to expand them and switch the files.
Also delete the existing files and copy the new files to the same dir.

An easy way to do that is using a bootdiskette..

-mafo
0
 

Author Comment

by:pzxkys
ID: 6163655
Thanks for all the suggestions! I have a problem making time to try them out today & tomorrow. Work all day & then evening commitments. It may be Saturday before I get to work on this problem again. I will accept give someone credit for this awesome assistance on Monday. Thanks again!!!!
0
 

Author Comment

by:pzxkys
ID: 6181676
It was tough deciding who to give the points to. Seems like astaec went to the most trouble to answer the question. As it turns out, I tried replacing the current vmm32.vxd & wsock.vxd files before I did anything else. This got me off the blue screen of death ... but then my wsock wouldn't work. I went looking for wsock driver info on the internet & found a very LENGTHY explanation with LOTS of steps for swapping the wsock driver ...  and since it appeared to be too complicated and since I wanted to upgrade my win98 system to winME anyway ... I upgraded to winME. My problems went away. Thanks very much for all the advice!!!!
0
 
LVL 27

Expert Comment

by:Asta Cu
ID: 6181947
Thank you as well for returning and updating us on the ultimate solution you found and implemented.  

Since you've now migrated to Windows ME, I'll share some helpful links here (FAQs about ME and Troubleshooting help):

http://support.microsoft.com/directory/content.asp?ID=FH;EN-US;winme&FR=0&SD=GN&LN=EN-US&CT=SD&SE=NONA

http://support.microsoft.com/support/tshoot/tshooterlist.asp?TPR=winme

WME Tips:
http://support.microsoft.com/support/windows/readme/winme/tips.asp#startmenuorder

Best of luck to you,
":0)  Asta
0
 
LVL 3

Expert Comment

by:mafo
ID: 6185465
No problem..
Allways fun to try to help someone..

-mafo
0

Featured Post

The problems with reply email signatures

Do you wish that you could place an email signature under a reply? Well, unfortunately, you can't. That great Exchange/Office 365 signature you've created will just appear at the bottom of an email chain. What a pain! Is there really no way to solve this? Well, there might be...

Join & Write a Comment

Suggested Solutions

Title # Comments Views Activity
Need more details 5 82
Independent domain networks for setup 6 81
how to execute all sub dir 2 24
Read-only access for auditors 5 42
Update 11/3/2014 - Although the below article will get you to relocate the WINSXS folder, Microsoft has finally released a utility to reduce the size of the WINSXS folder. For some reason, it's not that straightforward. It only works on Windows 2008…
If you get continual lockouts after changing your Active Directory password, there are several possible reasons.  Two of the most common are using other devices to access your email and stored passwords in the credential manager of windows.
Windows 8 comes with a dramatically different user interface known as Metro. Notably missing from the new interface is a Start button and Start Menu. Many users do not like it, much preferring the interface of earlier versions — Windows 7, Windows X…
This Micro Tutorial will give you a basic overview of Windows DVD Burner through its features and interface. This will be demonstrated using Windows 7 operating system.

707 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

15 Experts available now in Live!

Get 1:1 Help Now