SCSI CD Not recognised in setup...

SCSI CD Not recognised in setup... so I borrowed an IDE CD from another machine.  Mandrake 8 set itself up perfectly, even finding and mounting the SCSI CD (which neither RedHat or Mandrake could find in the setup routine).

So far so good.  I put the IDE CD back in to its machine, and run Mandrake.  No problem until I try to install a printer.  Then it says "please insert the setup device /etc/cdrom" (or something, that is from memory). I have no choice but to cancel.

Also, /mnt/cdrom is there even though the CD is no longer in the machine.

So I want to achieve two things:

1) Persuade the machine that the IDE CD-ROM is gone forever, and make the current CD /mnt/cdrom (not /mnt/cdrom2)

2) Tell the printer setup (and anything else) that the default location for the CDROM is /etc/hds2 (or whatever it is).

This is my second bash at Linux so I am not a complete newbie (but not far off).
LVL 1
thomaswpAsked:
Who is Participating?
 
psimationConnect With a Mentor Commented:
That mount command you used for the fstab file is not correct...
If you have concerns about your installation being too small, I think at this stage you would almost certainly be better off re-installing if possible, this time, select the custom install method and make sure you get X-windows, KDE, Gnome, the necessary networking tools ( dos/windows connectivity if you want samba), networked workstaion, network management, kernel development, documentaion and any services you think you'll need.

Another thing concerning the X-windows cd-rom icons, You need to change those manually after you point the /dev/cdrom device to another mount point, right click on the cd-rom icon and look at the properties and change accordingly.
0
 
psimationCommented:
1st, SCSI CD-rom support is not turned on in the kernel by default and you will need to enable it and re-compile the kernel.
You can go to my website at www.linuxhelp.co.za and follow the kernel button/link
It will show you how to compile the kernel etc.
2nd.
The /mnt/cdrom is only a mount point, not the actual device. Look at you /etc/fstab file and see what device Linux mounts to that mount point. If it only says something like /dev/cdrom /mnt/cdrom, you will need to change that AFTER the re-compile to /dev/scd0 /mnt/cdrom

(your cd-rom (scsi) will be called /dev/scd0 after the compile)
After you've done this, the printer should be able to install just fine from the /mnt/cdrom mount point...
0
 
thomaswpAuthor Commented:
psimation

Thanks for that - bearing in mind that the CDROM IS identified but as CDROM2, I am not sure that I need to recompile the kernel, but it is not identified as /dev/scd0 that is for sure.

So I would like to recompile the kernel.  Your site is pretty good, but I have no idea what the linux source rpm would be called.  Can you help with that, then I can get on with it.  I would like to recompile anyway to something minimal because I am running a P166 with 48MB RAM only.  (I am also not using X if I can help it, because it seems a bit flaky on this machine/in mandrake 8.

Thanks



0
Free Tool: SSL Checker

Scans your site and returns information about your SSL implementation and certificate. Helpful for debugging and validating your SSL configuration.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
psimationCommented:
The source rpm is usually called linux-x.x.x-source.rpm and should be on one of the two distro cd's.
To solve the cdrom2 issue, as I said before, you change that in the /etc/fstab folder.
To see as what the system installed your scsi rom as, you can either do a dmesg | more on the promt and then scroll to the section where it deals with the scsi's, or you can look in the fstab file and see what device it is mounting into the /mnt/cdrom2 folder, if it says /dev/cdrom(1), then go to your /dev/folder and do a ls -l and see where the /dev/cdrom(1) device links to...
Then you can just change the mount line in fstab to mount that device to /mnt/cdrom instead of /mnt/cdrom2
0
 
thomaswpAuthor Commented:
I have made changes to the fstab, commenting out the old line with # and changing the line below:

/mnt/cdrom /mnt/cdrom supermount fs=iso9660,dev=/dev/cdrom2 0

This means nothing to me by the way.

This works in that I can see the SCSI CD at /mnt/cdrom, but I am having problems installing RPMs under X, and now cannot get near setting up a printer - not even an error message, it just hangs.

I would like to try recompiling the kernel, but cannot find the linux.x.x.x-source file anywhere.

I had to install make and telnet-server manually using

rpm -i package-name.rpm

Is that the corrrect syntax?  I am beginning to think that I did a pretty minimal installation.  

I am pretty much ready to give you the points, but still very confused!

Thanks

Thomas

0
 
thomaswpAuthor Commented:
Hmmm, the command is exactly as it was set up by Mandrake when it found the drive - I just removed the 2s.  Here is the original line from fstab file before I made changes.

/mnt/cdrom2 /mnt/cdrom2 supermount fs=iso9660,dev=/dev/cdrom2 0 0

I am loath to reinstall.  It seems a bit drastic.

Thomas


0
 
thomaswpAuthor Commented:
I Am still stuck on this despite much trying and research on the web.  Anyone else out there able to help?
0
 
thomaswpAuthor Commented:
I gave up and reinstalled a year later using FTP...
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.