Go Premium for a chance to win a PS4. Enter to Win

x
?
Solved

Mwave modem error (mwme0001) on Thinkpad 755cx under Win95

Posted on 2001-06-07
16
Medium Priority
?
2,931 Views
Last Modified: 2013-12-16
Mwave modem internal error (mwme0001) on Thinkpad 755cx under Win95

Had some problems recently with mwave modem under Win95 on IBM Thinkpad 755cx.  I've go the 33.6k VOD update for this soft-modem.  Had some spurious dll errors that couldn't fix with gpf's from mmsystem.dll and winmm.dll.  Tried re-extracting these from win95 .cab files with no effect.  Next tried adding "drivers=mmsystem.dll" line to system.ini (?) under [boot].  This appears to have fixed the problems with the dlls throwing gpfs but now I have this error on startup:

MWME0001: Mwave modem internal error
Priomary Code: 2 (0x0002)
Secondary Code: 22 (0x0016)
File: mwmspcfc.c
Line: 3516

Have checked it's got the correct port assignment (com2) and that theres no interrupt conflicts (in device manager).  Also have tested ports within bios tester.  have tried deleting modem and letting pnp detect, and tried reloading driver files manually.  Modem diagnostic test won't work, attempt to "echo ata>com2" in dos fails.

Please help.

Many thanks,

pbhj
0
Comment
Question by:pbhj
  • 5
  • 4
  • 2
  • +4
16 Comments
 
LVL 17

Expert Comment

by:rayt333
ID: 6166048
Possibe modem has gone bad?

Was it working just fine before you tried updating the drivers?
Or was it giving you troubles which is why you tried an updated driver?
0
 
LVL 5

Author Comment

by:pbhj
ID: 6176576
The modem just stopped working, I switched on and the DLL errors started:  I can't recall doing anything in particular that may have caused it.  It's possible that out of range errors whilst using Borland C++ Builder may have been the cause (?) but I don't see how.
0
 
LVL 17

Expert Comment

by:rayt333
ID: 6178978
Try removing it from device manager then boot up into safe mode and check device manager and see if there is any double entries listed, if so then delete them all and reboot and let Windoze find and reinstall the modem. Then test and see if it works, if not then probably good bet the thing has died on you.
Too bad it is an internal modem or we could take it to another machine and test it there.
0
VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

 
LVL 2

Expert Comment

by:cooler012598
ID: 6267251
You will have to check www.ibm.com. There is a patch available to fix your problem.  If you can not find anything then you have to look up your laptop model number and install the latest patches and drivers for that modem.
0
 
LVL 5

Author Comment

by:pbhj
ID: 6295832
No, tried ibm.com first, nice try at getting easy points though - I'm sure there's an answer on there to most things!

Paul
0
 
LVL 2

Expert Comment

by:cooler012598
ID: 6295845
Ok. The proper thing to say here would have been I have not found the solution there. Now I will not bother to look. I am sorry I wasted this much time on this allready.
0
 

Accepted Solution

by:
GlockDawg earned 300 total points
ID: 6979615
THIS SHOULD WORK. a THINKPAD MODEM HAS TO HAVE A EXACT REG KEY. IF IT HAS CHANGED, YOU GET THAT ERROR. DOWNLOAD THE FOLLOWING PATCH.
ftp://ftp.pc.ibm.com/pub/pccbbs/bp_thinkpad/mwregfix.exe

AFTER YOU DOWNLOAD THE PATCH, PLACE IT ON A FLOPPY, OR CDRW. RUN THE PATCH ON THE THINKPAD FROM THE DISK. IT WILL CORRECT THE REG. SO YOUR MODEM WILL WORK. AFTER RUNNING THE PATCH, RE-BOOT AND THATS IT. REMEMBER THE PATCH WILL RUN LESS THEN A SECOND, YOU WONT EVEN SEE IT GOOD. HAHA IT WONT TELL YOU TO RE-BOOT, BUT YOU MUST.

LET ME KNOW
GLOCK
0
 
LVL 5

Author Comment

by:pbhj
ID: 6981730
GlockDawg,

Thanks for the suggestion, I no longer own this piece of hardware but I'll pass the fix on to the friend who now owns it and see what happens.  Be right back with you ...

Paul
0
 

Expert Comment

by:GlockDawg
ID: 6993176
Paul, just checking to see if it worked for you, if not let me know and I will dig deeper for you.

Glock
0
 

Expert Comment

by:LunXscape
ID: 7118987
GlockDawg,

The patch you posted to fix the registry key for the ThinkPad internal modem worked beautifully for me. I had the same error message with my ThinkPad 600E laptop after installing Windows XP. Now modem works fine.
0
 

Expert Comment

by:GlockDawg
ID: 7119136
Great! Cya's laterrrr.
0
 
LVL 3

Expert Comment

by:ITsheresomewhere
ID: 7119716
Hello pbhj,

It appears that you have forgotten this question. I will ask Community Support to close it unless you finalize it within 7 days. If there is no objection or further activity, I will suggest to:

    Accept GlockDawg's comment(s) as an answer.

pbhj, if you think your question was not answered at all, you can post a request in Community Support and ask them to delete this question and refund your points (please include a link to this
Question: http:Q.20131335.html in any posts to Community Support).
If you want to post to Community Support, click here:
      http://www.experts-exchange.com/jsp/qAskQuestion.jsp?ta=commspt

Please do not accept this comment as an answer!

EXPERTS: Your input for closing recommendations is appreciated.
==========
ITsheresomewhere
EE Database Cleanup Volunteer
0
 
LVL 5

Author Comment

by:pbhj
ID: 7152094
Well it looks like it's been taken out of my hands - the 'answer' that Glock provided is best but instead of the above mentioned error I now get an "Error 630: The computer is not receiving a response from the modem."  However the diagnostic (from the modem applet of control panel) runs fine ... any other ideas?
0
 

Expert Comment

by:GlockDawg
ID: 7152141
Can I have my 75 points ? :-)

your new question should be a new question, as in differnt from this one :)
0
 
LVL 5

Expert Comment

by:Netminder
ID: 7153343
Per recommendation, force-accepted.

Netminder
CS Moderator
0
 
LVL 5

Author Comment

by:pbhj
ID: 7160496
I feel a bit put out on this - Glock looks on Google and finds a fix for a totally different system which simply reroutes my error and I have to say he answered the question?  I was expecting something like - this is whats happened and heres how to fix it - instead a shot in the dark gets the points.  Nevermind.

pbhj
0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Ever visit a website where you spotted a really cool looking Font, yet couldn't figure out which font family it belonged to, or how to get a copy of it for your own use? This article explains the process of doing exactly that, as well as showing how…
This article provides a convenient collection of links to Microsoft provided Security Patches for operating systems that have reached their End of Life support cycle. Included operating systems covered by this article are Windows XP,  Windows Server…
This is used to tweak the memory usage for your computer, it is used for servers more so than workstations but just be careful editing registry settings as it may cause irreversible results. I hold no responsibility for anything you do to the regist…
If you’ve ever visited a web page and noticed a cool font that you really liked the look of, but couldn’t figure out which font it was so that you could use it for your own work, then this video is for you! In this Micro Tutorial, you'll learn yo…

916 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question