Solved

Windows 98 - Windows Explorer attribute question

Posted on 2001-06-07
8
216 Views
Last Modified: 2013-12-28
I recently backed up all my data files onto a CD.  I burned ALL my data onto a CD using HP CDWriter. When I copied all the files from my CD BACK ONTO THE hard drive it gave all my files and folders an attribute of READ ONLY. My question is: How can I quickly remove the READ ONLY attribute on all of these files and folders, without having to go into the properites of each file and removing the check mark next to READ ONLY?????
0
Comment
Question by:sgarcia3
8 Comments
 
LVL 13

Expert Comment

by:oldgreyguy
ID: 6165053
I wonder if the ATTRIB command (done from the COMMAND PROMPT would do it

example

ATTRIB -s C:\*.* /s

here is a page to peruse for the command syntax

http://www.computerhope.com/attribhl.htm
0
 
LVL 10

Accepted Solution

by:
tonnybrandt earned 100 total points
ID: 6165533
Above comment looks good, but it is the wrong attribute beeing unset. I belive the correct syntax is:

ATTRIB -r C:\*.* /s /d

Here is the help for attrib:

E:\>attrib /?
Displays or changes file attributes.

ATTRIB [+R | -R] [+A | -A ] [+S | -S] [+H | -H] [[drive:] [path] filename]
       [/S [/D]]

  +   Sets an attribute.
  -   Clears an attribute.
  R   Read-only file attribute.
  A   Archive file attribute.
  S   System file attribute.
  H   Hidden file attribute.
  /S  Processes matching files in the current folder
      and all subfolders.
  /D  Processes folders as well.


There might be another way (at least it works in win 2000) open an explorer and navigate to the folder, where you copied the data. Rightclick that folder, choose properties and check the read only checkbox. Click apply and it will ask you if you want to set it on subfolders and files. Click yes. Next you uncheck the read only and click apply and answer yes to set it on subfolders and files.

This works in win 2000, but i haven't tested it on a win98.
0
 
LVL 13

Expert Comment

by:oldgreyguy
ID: 6165588
tonnybrandt, thanks for the catch, i had just done a series of -s (system attributes) and I was still in that mode.

bill
0
Easy, flexible multimedia distribution & control

Coming soon!  Ideal for large-scale A/V applications, ATEN's VM3200 Modular Matrix Switch is an all-in-one solution that simplifies video wall integration. Easily customize display layouts to see what you want, how you want it in 4k.

 
LVL 2

Expert Comment

by:RickHalle
ID: 6165597
You can also select more than one file at a time from windows explorer as well. Open the Folder, Then Edit/Select All from the menu, Then File/Properties from the menu, Then Uncheck the read only box and hit ok. The Dos attrib command will work also but explorer may be easier if you are uncomfortable working from dos.

Rick
0
 
LVL 7

Expert Comment

by:pbessman
ID: 6165834
If you are using ME, remember thatyou cannot reboot into DOS.  You must do it from within a DOS prompt from the DOS Window.  Depending on what it is you are editing, ME may prevent you from doing so.  I have tried some of these DOS commands myself and received messages like "the command is no longer supported".
0
 
LVL 7

Expert Comment

by:pbessman
ID: 6165844
It would be easier to simply uncheck the read only box in the file attributes for the files you wish to use.
0
 

Expert Comment

by:goyalmayank
ID: 6166348
open FIND in the start Menu and give a *.* in find and the location of the files which have been copied from the CDROM, (Supposing all files have been copied to a same folder) and let it find all the files.

Clisk on any of the files just to select it and press CTRL + A, to select all files. Right click on any file and select its property. In the property sheet uncheck the Read _only check box.

(Ensure that all the reauired files are selected while selected properties from the popup menu obtained on right click)
0
 

Author Comment

by:sgarcia3
ID: 6167974
When I posed this question on "Experts-exchange.com", I was in a very desperate situation.  I didn't feel like trying to figure out the problem myself.  But, I swear to you (folks), RIGHT AFTER I POSED THE QUESTION; I turned around and used my knowledge of DOS COMMANDS and figured it out for myself! I used the following DOS COMMAND: Attrib -r C:\work\*.* /s

But it's only fair to give the points to whom I felt gave me the most specific & detailed answer! And that was tonnybrandt. Thanks. I am very pleased with the quick responses to the possible solutions for my problem.
0

Featured Post

Create the perfect environment for any meeting

You might have a modern environment with all sorts of high-tech equipment, but what makes it worthwhile is how you seamlessly bring together the presentation with audio, video and lighting. The ATEN Control System provides integrated control and system automation.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Join Greg Farro and Ethan Banks from Packet Pushers (http://packetpushers.net/podcast/podcasts/pq-show-93-smart-network-monitoring-paessler-sponsored/) and Greg Ross from Paessler (https://www.paessler.com/prtg) for a discussion about smart network …
While rebooting windows server 2003 server , it's showing "active directory rebuilding indices please wait" at startup. It took a little while for this process to complete and once we logged on not all the services were started so another reboot is …
With the advent of Windows 10, Microsoft is pushing a Get Windows 10 icon into the notification area (system tray) of qualifying computers. There are many reasons for wanting to remove this icon. This two-part Experts Exchange video Micro Tutorial s…
The Task Scheduler is a powerful tool that is built into Windows. It allows you to schedule tasks (actions) on a recurring basis, such as hourly, daily, weekly, monthly, at log on, at startup, on idle, etc. This video Micro Tutorial is a brief intro…

821 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question