CD ROM Drives arent showing up anymore, HELP!!

Hi,
I have 3 CD drives, a plextor CD-R on a adaptec aha 2940
and a yamaha CDRW and a Toshiba DVD drive on a promise ultra100 controller card
It has all been working just fine until today, I turned on my computer and neither of the three of my CD drives appeared anymore.
I can see them in the device manager and when I go to manage my computer, the three drives have a red X on them. when I click on the drives subfolder for each one, it says that "Not present, Empty"
It was all working perfectly and I didnt do anything weird with the settings or nothing, but they just dont show up at all, not even my Direct CD wizard can find them.
I have tried removing them from the device manager and restarting, but when I restarted they still didnt show up in my computer or any program, but were in the device manager

Thanx for the help in advanced
I will try and add more points as I get them
damn_computerAsked:
Who is Participating?
 
SysExpertCommented:
Have it do a system file repair for a start.

I would do a backup of all critical data in advance and also of your present registry.

I hope this helps !
0
 
tobykCommented:
have you tried using them in another machine. You might have a flaky power supply because you might have sucked out too much power. Can you access the cdrom in dos?
0
 
damn_computerAuthor Commented:
I can access them using Windows ME which I also have installed on my computer. The power supply is brand new and 300W so I dont think that is the problem.
It is something with windows 2000 configuration i think
0
Keep up with what's happening at Experts Exchange!

Sign up to receive Decoded, a new monthly digest with product updates, feature release info, continuing education opportunities, and more.

 
SysExpertCommented:
1) Check for viruses with 2 updated programs.

2) Get the SP2 update and check www.windowsupdate.com.


3) Are you logged in as administrator.

4) have you tried restoring the registry  or repairing it with either regclean or from you Boot CD of win2k ?

5) What new drivers or programs have you installed recently ??

I hope this helps !!
0
 
damn_computerAuthor Commented:
So should I try and tell windows 2000 setup to repair the current installation?
If so, what option of repair do I chose?

I am logged in as Administrator, and I have already made the SP2 update.
I havent intalled any new drivers,
the latest program that I installed was Nero Burning ROM 5, could this have caused the problem?

I currently have systemworks, but it isnt installed and I think that it is for windows 9x and ME only.
Is there an online service that I could use free of charge that would scan for viruses or problems?
0
 
damn_computerAuthor Commented:
ok, I have tried uninstalling Nero, but it still doesnt work.
I am also having another problem, since I was experimenting with deleting the CD drives from the computer managment area. They didnt come back up now. They are all detected in the device manager, but not there.
I am considering maybe having win2k setup repair the installation, I just need to know what procedure to follow
0
 
damn_computerAuthor Commented:
I ended up formatting my computer since I got a new HD, so it is fixed now, thanx for the help anyway
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.