sendmail not answering except for 'localhost'

We are setting up a replacement server for out current one who will be retiring very soon (and thus we decided why not start from scratch). At the same time we setup a firewall which the enw server will be behind. The firewall is set up to do NAT and successfully routes pop3, imap, httpd and ssh through to the new server and smtp is set up in the exact way. In reality this firewall should have nothing to do with the problem, but i mention it just in case.

The server is RedHat 7.1, the IP of the machine is for the LAN 10.1.1.198. When I am on the local machine and i do a:

 telnet localhost 25

i will get connected...same goes for telnetting to 127.0.0.1, however if I attempt to telnet to 10.1.1.198 on port 25 it will say:

  Trying 10.1.1.198...
  telnet: Unable to connect to remote host: Connection refused

the machine had ipchains set up on it as secondary backup from the main firewall but i completely removed that just in case that was the problem. The same error happens when I try to telnet to it with it's real internet ip, with the domain name etc, and this is tested from remote boxen and the local box itself, the only thing it likes is localhost and 127.0.0.1

if you have any clue what this problem is, let me know.
LVL 1
delleteAsked:
Who is Participating?
 
jlevieCommented:
Nope that firewall rules aren't the problem. By default RH 7.1 has inbound access to sendmail blocked. Look at the Release notes on the 1st CD and you'll see what needs to be done to enable inbound connections to sendmail.
0
 
markt9Commented:
Redhat 7.1 defaults to high security firewall rules.

Log on as root and type      setup

choose firewall configuration and run tool. You are probably at security level high.

You can choose custom level and allow mail, or to play with set it to low till you know sendmail works.

Your telnet to port 25 is an excellent test.
0
 
delleteAuthor Commented:
thanks for the reply, but that isn't it (plus 7.1 defaults with medium security level), but i have completely disabled ipchains for the time being while trying to figure this out, so there is no firewall active.
0
 
delleteAuthor Commented:
thanks, i guess that will teach me for not reading those things....

(i am so used to installing everything manually, i hate this automatic setup stuff)

thanks for the answer.
0
 
jlevieCommented:
Yeah, sometimes it is trully amazing what you can find in the Release Notes... Don't feel bad, I got bit by that for an hour or so on my first RedHat 7.1 install.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.