Solved

timeout

Posted on 2001-06-07
4
334 Views
Last Modified: 2010-04-20
i'm using redhat 7, and ipchains for the firewall,
i open all connection to outside
and allow all connection from other network(202.???.???.???) to inside (192.168.12.0/24)

INPUT         - ACCEPT
OUTPUT        - ACCEPT
FORWARD       - MASQ
From inside(192.168.12.0/24) to outside allow all
From other public 202.???.???.0/24 to inside allow all

all the connection is ok, but i always got problem with
mapping,
if i map a drive to other network (202.???.???.???) from the inside network (192.168.12.0/24) after sometime it will give a timeout, but then if you click again on the drive... it will be ok again...

i don't why this happen (the timeout)... can i set no timeout.. so the mapped drive will always connected?

thanks
0
Comment
Question by:ichen
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
4 Comments
 
LVL 12

Accepted Solution

by:
j2 earned 100 total points
ID: 6166869
Your default policy for forwarding is MASQ. You cannot masquerade SMB traffic without getting the error you mention. You must create rules which opens (atleast) port 135-139 between the two nets WITHOUT masquerading (which most likely will break something else) But that is the breaks :)
0
 
LVL 1

Author Comment

by:ichen
ID: 6167079
create rules which opens port 135-139 without masquerading??
what do you mean by that?
ipchains -A forward -s 192?????? -d 203?????? 135:139 (without -j MASQ? is it??)
0
 
LVL 12

Expert Comment

by:j2
ID: 6167240
-A forward -s 192.168??? -d 203??? -p TCP --destination-port 135:139 -j ACCEPT and that has to come before the masquerade for the same network. And since you are using "dark" IP's (the 192.168 net) this probably will not wor, but it is the only way to get a reliable SMB connection. You also of cource need bidirectional routing between the networks.
0
 
LVL 12

Expert Comment

by:j2
ID: 6167243
oh, you need to add -b (bidirectional) to that rule aswell.
0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
000webhost.com default error log 1 61
How to use IFS to get output of range in comma separator in bash? 2 47
sed/awk/tail: how to read 3'de last line 4 44
Linux 3 37
SSH (Secure Shell) - Tips and Tricks As you all know SSH(Secure Shell) is a network protocol, which we use to access/transfer files securely between two networked devices. SSH was actually designed as a replacement for insecure protocols that sen…
I. Introduction There's an interesting discussion going on now in an Experts Exchange Group — Attachments with no extension (http://www.experts-exchange.com/discussions/210281/Attachments-with-no-extension.html). This reminded me of questions tha…
Learn several ways to interact with files and get file information from the bash shell. ls lists the contents of a directory: Using the -a flag displays hidden files: Using the -l flag formats the output in a long list: The file command gives us mor…
Learn how to get help with Linux/Unix bash shell commands. Use help to read help documents for built in bash shell commands.: Use man to interface with the online reference manuals for shell commands.: Use man to search man pages for unknown command…

726 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question