Vmm32.vxd missing...

Hi all,
This is a problem I've been encountering a lot lately...
People boot their PCs with Win98 and their machine powers down at the windows splash screen - when trying to access safe mode it hangs at the splash screen indefinetly with the hard drive continually grating. With step by step confirmation it says that the file
c:\windows\system\vmm32.vxd is missing

I've read the Microsoft support article on this problem here - http://support.microsoft.com/support/kb/articles/Q191/8/74.ASP

This article seems to indicate that a scanner causes the problem but in not one of these cases is a scanner involved. We do not have a solution to this problem and it seems to happen at random and for no apparent reason. Eg - it happened recently after someone just cleared the CMOS!
In every situation we have had to recover the PCs involved...

Does anyone have any information on how to fix this problem - or even better - what causes it and how to prevent it?

Who is Participating?
hewittgConnect With a Mentor Commented:
CokaneAuthor Commented:
Oh and by the way -

This article also fails to help with this problem...
I know you said a scanner is not involved but look in your system.ini file for any reference to "Umaxis11.386 "  if so, rem it out.

Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

Asta CuCommented:
Windows 95/98 Boots Directly to "Shut Down" Screen

The information in this article applies to:

Microsoft Windows 95
Microsoft Windows 98
Microsoft Windows 98 Second Edition


When you start your computer, you may see the following message:

It's now safe to turn off your computer
This behavior can occur in any mode.

This behavior can occur if the Vmm32.vxd or Wininit.exe file is missing or damaged.

Asta CuCommented:
Is Power Management disabled in the BIOS as well as virus-related options?


Computer Stops Responding After You Press CTRL+ALT+DELETE

The information in this article applies to:

Microsoft Windows 98
Microsoft Windows 95

When you press CTRL+ALT+DELETE to open the Close Program dialog box in Windows, your computer may stop responding (hang).
This issue can occur if the Reboot.vxd file is located in the Vmm32 folder and is damaged or is the wrong version.
To resolve this issue, rename the Reboot.vxd file in the Vmm32 folder and then restart your computer. For information about how to rename a file, click Start, click Help, click the Index tab, type "renaming" (without quotation marks), and then double-click the "Renaming files" topic.
The Reboot.vxd file is normally integrated into the Vmm32.vxd file, and should not appear in other locations.



<< with the hard drive continually grating.

To me it sounds like your hard drives are flakey.

I would recommend that you download a diagnostic disk from your harddrive manufacturer's url. This will tell you right off where you are at and if
   you can recover from it. It may be under waranty, the harddrives are usually covered for three years and you can make out the RMA on their site
                     also. Depending on the manufacturer of the hard drive, you can download diagnostic utilities from their sites to check the drives.

I hope this helps !
CokaneAuthor Commented:
Thanks all so far...
SysExpert - the hard drives are OK - Its not really a grating noise (bad description on my part) but rather the noise the hard drive makes when its trying to do something but unable to ...

Thanks for all suggestions - I'll have a look at the links and stuff and get back to you.
Asta CuCommented:
Churning from searching and not finding, perhaps also churning because of a badly fragmented swapfile and hard disk that scandisk/defrag may help.
well have you tried replacing the file from other pc
CokaneAuthor Commented:
Thanks hewittg,
That's what I was looking for - well I was hoping for a miracle cure but wasn't really expecting one...
Thanks all for your contributions.

and kahlean - yes we have tried it but it never works...
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.