Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

need to make a layer 2 network over Frame relay with Cisco

Posted on 2001-06-11
11
Medium Priority
?
270 Views
Last Modified: 2011-09-20
Here is the situation. I have a customer with a bunch of connections. Some of the connections are ethernet over fiber. They all bridge together and we provide a layer 2 network between the customer's various sites.

We are now adding an additional few sites. But the new sites are going to connect with Frame relay.

I have 1 frame connection at my central site ( from which the fiber goes out) and 2 other sites that connect to the cloud. In addition, one of the 2 sites has a P2P T-1 going to a third site. Ideally I would like to continue to provide a layer 2 solution. I would have to guess I can use IP un-numbered on all my routers. But then how can I manage them? ideas?

I already have 3 2511s I can use and a 1600, so I think I am set on the hardware.



picture:

POP     ------ Cloud ------ site 1
                  |
                  |
                site 2 ---T1-- site 3
             
0
Comment
Question by:jjeff1
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
11 Comments
 
LVL 11

Expert Comment

by:geoffryn
ID: 6178096
Layer 2? So you want to bridge all of the sites togather?  Why is a layer 2 solution the best?  You will be wasting valuable WAN bandwidth on broadcast traffic.  
0
 
LVL 7

Author Comment

by:jjeff1
ID: 6178371
I am well aware of the waste of bandwidth. The point is that as an ISP I don't want to get involved in trying to deal with the customers IP addressing scheme.
0
 
LVL 1

Expert Comment

by:asarluhi
ID: 6179178
You can run the frame-relay interface as part of a bridge group.  Broadcasts are supported on multipoint interfaces with the frame-relay map bridge command.  See the following URL for more information:

http://www.cisco.com/univercd/cc/td/doc/product/software/ios120/12cgcr/ibm_c/bcprt1/bctb.htm#xtocid1230316

This is technically an example for IBM transparent bridging, but it basically holds for any L2 protocol.  Remember to *not* configure IP addresses on the transit interfaces...

Let me know if you need more detail.

Good luck-
0
Plug and play, no additional software required!

The ATEN UE3310 USB3.1 Gen1 Extender Cable allows users to extend the distance between the computer and USB devices up to 10 m (33 ft). The UE3310 is a high-quality, cost-effective solution for professional environments such as hospitals, factories and business facilities.

 
LVL 7

Author Comment

by:jjeff1
ID: 6179350
Yes, I was looking also for some basic config.

Also, would I by able to access these devices in any way? You said I can't assign an IP to the transit ( umm, you mean the serial interfaces )so I assume not.

0
 
LVL 79

Expert Comment

by:lrmoore
ID: 6179406
You have a couple of options:
at Site one, you can setup one interface with frame-relay encapsulation and run multiple sub-interfaces to the other sites. Each sub-interface can have it's own IP address. If you use IP unnumbered, then you can still manage the devices by connecting to whatever address you identify in the ip unnumbered statement.

Example:

Site 1 main:
  Interface Serial 0/0
   encap frame-relay
  Int serial 0/0.1
   description connected to site 2
   ip add 192.168.255.1 255.255.255.252
   frame-relay interface-dlci 200 {DLCI is assigned by the telco}
!
ip route <ip network of site 3> mask 192.168.255.2

Site 2
 
  Interface Serial 0
   encap frame-relay
  Int serial 0.1
   description connected to site 1
   ip add 192.168.255.2 255.255.255.252
   frame-relay interface-dlci 100 {DLCI is assigned by the telco}
!
  Interface serial 1
  description point-to-point to site 3
   ip address 192.168.255.5 255.255.255.252
!
ip route <ip network of site 1> mask 192.168.255.1
ip route <ip network of site 3> mask 192.168.255.6

Site 3:
 Interface Serial 0
 description point-to-point to site 2
 ip address 192.168.255.6 255.255.255.252
!
ip route 0.0.0.0 0.0.0.0 192.168.255.5

Hope this helps!
0
 
LVL 1

Accepted Solution

by:
asarluhi earned 300 total points
ID: 6179415
OK - here's an example, including only the really salient parts of the configuration.  To address your question of how to manage the router, we'll use integrated routing and bridging (IRB) - which allows for the router to route packets that are specifically routable and bridges the rest.  In this instance, the address on the remote router (192.168.1.150) can be used to manage the device - but can be completely independent of any IP addressing used by your customer.  Check out Cisco's reference on IRB for more details:

http://www.cisco.com/univercd/cc/td/doc/product/software/ios121/121cgcr/ibm_c/bcprt1/bcdtb.htm#xtocid1869460

central WAN router

(it is assumed that fe0 connects to your existing bridged backbone and that dlci 50 links you to your remote site - it is also assumed that this core router is also already managed out of band)

interface fastethernet0
no ip address
bridge-group 1

interface serial0
encapsulation frame-relay
interface serial0.1 point-to-point
bridge-group 1
frame-relay interface-dlci 50

bridge 1 protocol ieee

remote client router

(ethernet0 goes to local clients, dlci 40 links back to the central site and bvi 1 is used for in-band management)

interface ethernet0
no ip address
bridge-group 1

interface bvi 1
ip address 192.168.1.150 255.255.255.0

interface serial0
encapsulation frame-relay
interface serial0.1 point-to-point
bridge-group 1
frame-relay interface-dlci 40

bridge irb
bridge 1 route ip
bridge 1 protocol ieee


Now - with this in mind, I do agree with geoffryn's comments.  This isn't the optimal approach.  The performance isn't going to be great, and I'd pay close attention to the stability question.  If you need to support arbitrary IP addressing across a common backbone, check out MPLS-VPN.  I'd be happy to provide pointers if needed.

Good luck-
0
 
LVL 7

Author Comment

by:jjeff1
ID: 6179462
Please don't lock the question. I want to get feedback from everyone.
0
 
LVL 7

Author Comment

by:jjeff1
ID: 6288050
I am doing basically what asarluhi wrote. I made by serial interfaces and threw them, along with my ethernet interface into a bridge group.

Unfortunatly, the telco messed up the DLCIs, so I was unable to get anything to work.
0
 
LVL 7

Author Comment

by:jjeff1
ID: 6489003
Unfortunatly, I can't make this work at all.

I have been trying to use IRB with no luck.

As soon as I put the serial sub interface into a bridge group, all the PVC info dissappears from a show frame-relay pvc

0
 
LVL 7

Author Comment

by:jjeff1
ID: 6489053
Here is what I have on my core router:
!
interface ATM1/0.26 multipoint
 atm pvc 36 0 128 aal5snap
 bridge-group 26                    
!
interface Serial4/6
 no ip address
 encapsulation frame-relay IETF
 frame-relay lmi-type ansi
!
interface Serial4/6.1 point-to-point
 frame-relay interface-dlci 30
 bridge-group 26
!
interface Serial4/6.2 point-to-point
 frame-relay interface-dlci 31
 bridge-group 26
!
interface BVI26
 description gbar
 no ip address
!                  
bridge 26 protocol ieee
 bridge 26 route ip      


And on the edge :

Interface serial0
  no ip address
  encap frame-relay ietf
  frame-relay lmi-type ansi

interface serial0.1 point-to-point
  frame-relay interface dlci 16
  bridge group 1

bridge crb
bridge 1 protocol ieee

int ethernet0
no ip address
bridge-group 1

The edge router is running IOS 10.0 and does not have enough flash or RAM to upgrade.

I will see how this goes. I have had problems in the past, but this looks like it should all work.

Jeff
0
 
LVL 7

Author Comment

by:jjeff1
ID: 6715717
This is more or less what I ended up doing. I found that one of my problems was with the old code on one of my edge routers. The BVI simply did not work on the router, once I upgraded from 10 to 11 code, all was well.
0

Featured Post

On Demand Webinar - Networking for the Cloud Era

This webinar discusses:
-Common barriers companies experience when moving to the cloud
-How SD-WAN changes the way we look at networks
-Best practices customers should employ moving forward with cloud migration
-What happens behind the scenes of SteelConnect’s one-click button

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Tired of waiting for your show or movie to load?  Are buffering issues a constant problem with your internet connection?  Check this article out to see if these simple adjustments are the solution for you.
In the world of WAN, QoS is a pretty important topic for most, if not all, networks. Some WAN technologies have QoS mechanisms built in, but others, such as some L2 WAN's, don't have QoS control in the provider cloud.
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

715 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question