• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 212
  • Last Modified:

.htaccess not working

I have a .htaccess file in the members area of my site.  It points to my /etc/http/mysite/users file for authentication.  It has always worked in the past.  Last week I installed RHLinux7.1 and for some reason, when going to the members area, the .htaccess file is being totally ignored.  It never prompts for a username/password.  Anyone know any reason this is happening?  Has anything changed in Apache for RHLinux7.1?
0
GorGor2
Asked:
GorGor2
1 Solution
 
RareCommented:
Check your /etc/httpd/conf/httpd.conf and make sure that you have

AccessFileName .htaccess

and if the dir that needs for authentication is /home/user1/public_html, make sure this is in httpd.conf also.

<Directory "/home/user1/public_html">
    AllowOverride AuthConfig
    (other options you might have here)
</Directory>
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Cloud Class® Course: Microsoft Office 2010

This course will introduce you to the interfaces and features of Microsoft Office 2010 Word, Excel, PowerPoint, Outlook, and Access. You will learn about the features that are shared between all products in the Office suite, as well as the new features that are product specific.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now