driver for midi

Hi

Can't install external midi driver on i-machine,
crystal fusion sound card.
(I know :)
Original seting works fine, but when I try to
install mpu-401 driver (for contolling midi in/out)
device manager saying:
"driver miss component or not installed properly"

Thank you,

Val.
vaalsh2000Asked:
Who is Participating?
 
NavidCommented:
Hello Asta and Vaalsh!
Let me give you a description which can give errors of any kinds using MPU-401 driver:
The MPU-401 driver has been designed to allow co-exist with other audio drivers. However, when using the
MPU-401 driver in this way, you will effictively have two device drivers that do not communicate with each other sharing the same hardware. This combination can cause odd, unpredicable behavior that can vary from driver to driver and even from version to version.
The other audio device driver, hereby known as the main driver, typically controls an entire adapter, and the
MPU-401 driver only talks to the MPU-401 hardware on that adapter. In some cases, the main driver also talks to the MPU-401 hardware.
In particular, there are two problems that occur most frequently:
 1.The main driver controls the audio mixer, and can mute the wavetable synthesizer on the adapter. The
audio mixer controls the volume levels of each of the devices, such as the wavetable synthesizer, on the
audio adapter. The MPU-401 device on an audio adapter typically controls the wavetable synthesizer. The
MPU-401 driver can only control the MPU-401 device on the adapter, and the audio mixer cannot be
controlled by the MPU-401 device.
2.The main driver can reset the MPU-401 device for an unrelated reason (such as when initializing the wave
audio device), and thus preventing simultaneous use of the wave audio device and the MPU-401 device
(i.e. you will not be able to get digital audio and MIDI at the same time).
The default options for the MPU-401 driver will usually prevent the MPU-401 driver from co-existing with other
drivers. This is because the MPU-401 driver registers its resource with Resource Manager in "exclusive" mode, and this usually conflicts with the main driver. If this is the case, three things must be done:
1.Determine whether the conflict is with the I/O ports, the IRQ, or both.
2.Determine how the main driver registers the resource with RM: shared, multiplexed, or exclusive.
3.Use the chart below to determine how to set the MPU-401 driver
 Main driver is set to:
Shared
Shared
Multiplexed
Set MPU-401 driver to:
Multiplexed
Exclusive
None
For example, if the main driver registers its I/O ports in exclusive mode and its IRQs in multiplexed mode (a
common configuration), the MPU-401 driver should set Resource Manager I/O Usage(http://www.thetaband.com/mmpack/56.htm) to "None" and Resource
Manager IRQ Usage(Set MPU-401 driver to:) to "Multiplexed".
I hope it helps
Navid
0
 
Asta CuTechnical consultant & graphic designCommented:
Have you updated your system using WindowsUpdate?  Do you have Media Player installed with proper codecs and drivers?  What about updated sound card drivers?

start-run-msinfo32-tools-directX diagnostics.  I'd run these, all tests, and see what results.  The current version of DirectX diagnostics, I believe, is version 8.0a, either available from windowsUpdate or here:

http://www.microsoft.com/downloads/release.asp?ReleaseID=27741

Listening when I can.

Asta
0
 
Asta CuTechnical consultant & graphic designCommented:
0
Cloud Class® Course: MCSA MCSE Windows Server 2012

This course teaches how to install and configure Windows Server 2012 R2.  It is the first step on your path to becoming a Microsoft Certified Solutions Expert (MCSE).

 
GUEENCommented:
Boot up in safe mode (press F8 key after memory run and before windows splash screen.)
Go to Control Panel  | system properties  | device manager and click down on the + for sound and remove all duplicates - just remove all then reboot and when you come back into windows - it should be detected and reinstall drivers.
Then check device manager for MPU-401 settings (resources should be 0330-0331 and an IRQ of 5 would be good.  Check the driver files also while there.
0
 
NavidCommented:
What can I do not prevent texts jumping up and down on EE. When I type comments, they look alright on themessage box...hmm...
0
 
NavidCommented:
Correction:(typed too fast) Sorry
What can I do to prevent texts jumping up and down on EE. When I type comments, they look alright on
the message box...hmm...
0
 
gonzal13RetiredCommented:
Interestingly I ran across a problem with internet explorer today. I imagine my 18 year old son had something to do with it's corruption. Now there is a little known fix which I have not seen mentioned on this site that corrected my problem and may fix a corruption in your Internet Explorer itthere is one:  Go to CONTROL PANEL, ADD/REMOVE SOFTWARE.Now go down to MICROSOFT INTERNET EXPLORER, double click on it, a FIX window will appear!. Click on fix, let it run it's course and restart your PC. It worked for me, when there was no way I could communicate with the ISP after I logged on. I know it is a comment, but it surprised me!
0
 
gonzal13RetiredCommented:
Interestingly I ran across a problem with internet explorer today. I imagine my 18 year old son had something to do with it's corruption. Now there is a little known fix which I have not seen mentioned on this site that corrected my problem and may fix a corruption in your Internet Explorer itthere is one:  Go to CONTROL PANEL, ADD/REMOVE SOFTWARE.Now go down to MICROSOFT INTERNET EXPLORER, double click on it, a FIX window will appear!. Click on fix, let it run it's course and restart your PC. It worked for me, when there was no way I could communicate with the ISP after I logged on. I know it is a comment, but it surprised me!
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.