Solved

slow network connection.

Posted on 2001-06-13
5
191 Views
Last Modified: 2013-12-16
My problem is that all network services are slow connecting to my RH7 Linux box.  (Telnet, ftp, email, etc.)  For example, when I try to telnet to the box, it takes anywhere from 30 - 90 seconds to get the login prompt.  Once I am logged in, the session proceeds normally.  The box is also running qmail, and all attempts to send/receive email through it are slow.  I have read some other posts, and get the general feeling that it might be a DNS problem.  I do not run my own DNS server, I use my isp's.  I have an always-on connection to the internet.  Any suggestions would be greatly appreciated.

M.B.
0
Comment
Question by:mattbrice
  • 2
  • 2
5 Comments
 
LVL 40

Accepted Solution

by:
jlevie earned 100 total points
ID: 6189489
That is most likely a DNS lookup issue. The various servers are attempting to do a reverse lookup on the client's IP and the DNS request has to time out before the server can proceed. For nodes on your local LAN you can fix most of the problems by creating hosts file records for each of the nodes. Obviously you could set up a local DNS that contains data for you local LAN and forwards all other requests to your ISP, but that would be overkill if you only have a few nodes.
0
 

Author Comment

by:mattbrice
ID: 6196518
jlevie,

Thanks for the comment!  Although I had tried adding client records in my hosts file previously, it did not seem to help.  But after your comment, I tinkered with the file and discovered that I was not putting the records in the file correctly.  This has definitely made a speed increase in my connection times.  

But I have a few other clarifying questions that maybe someone can answer.  I run mainly Win NT 4/Win 2000 clients ( approx 10 nodes )with the linux box being the file/email server.  My questions are: are there some settings in the windows machines that I can adjust that will decrease the wait-to-connect time?  

For some reason, the Win 2000 machines seem to connect much faster than the Win NT 4.0 boxes; is there a known reason for this? Or is it just my imagination?

I run qmail as the email server, and the time it takes to check email is now less, but still not as fast as I think it should be.  Are there any other settings in Linux that may speed this up? Or am I just an impatient person?

Again, thanks for the prompt response.

MB
0
 
LVL 40

Expert Comment

by:jlevie
ID: 6197019
What kind of time delay on the NT4 boxes are we talking about? And is the delay seen on all protocols (TELNET, FTP, SMTP, POP/IMAP)?

One sure-fire way to find out where the delay is is to run a "tcpdump -n" on the Linux system and then attempt one of the things that is slow from an NT system. You need to do this when there is no other activity on the network, i.e., no one logged in on any of the systems in your local LAN. If you even a little about network protocols the answer is usually immediately evident from the tcpdump output. If you don't understand what you are seeing I'll be glad to look at the trace and tell you what's happening. You can either post the part containing the delay here or email it to jim@entrophy-free.net.
0
 
LVL 1

Expert Comment

by:auther_bin
ID: 6199379
 Jlevie is right, that problem is just come from DNS. When you telnet to the box, the telnet daemon process first want to get your IP's daemon name, usually, it send PTR querry to dns server. The time you wait just because the DNS need more time to trans data. What ever the box get your IP's daemon name or not, it will logdown all the telnet connect message in logfile with your daemon name.
  but it's really a easy way to settle it:

1. Make sure that your box have correct setup with DNS server daemon program: named(bind 9.0)
2. Add your host name and IP address in file:" /etc/hosts" like:
       192.168.1.1         Myname
3. If you need to run DNS server on your machine, then you'd better add an item to the PTR file. About details, you can look for DNS configrations on net.
4. If you need not to run the DNS server then just kill DNS daemon service: "killall named", and the change the resolve file: "/etc/resolv.conf" delete all the nameserver lines.

I think it must work more fast, if not tell me :)

Good Luck
0
 

Author Comment

by:mattbrice
ID: 6225200
Thanks for all the input.  I have the system working at a much more acceptable pace now.  Unfortunately, I have been re-assigned to another few tasks and will be unable to delve into these annoyances until later. Since the problem is mostly solved, I don't know when I will be able to get back to this.

Thanks again,

MB
0

Featured Post

Maximize Your Threat Intelligence Reporting

Reporting is one of the most important and least talked about aspects of a world-class threat intelligence program. Here’s how to do it right.

Join & Write a Comment

This is the error message I got (CODE) Error caused by incompatible libmp3lame 3.98-2 with ffmpeg I've googled this error message and found out sometimes it attaches this note "can be treated with downgrade libmp3lame to version 3.97 or 3.98" …
I. Introduction There's an interesting discussion going on now in an Experts Exchange Group — Attachments with no extension (http://www.experts-exchange.com/discussions/210281/Attachments-with-no-extension.html). This reminded me of questions tha…
Learn several ways to interact with files and get file information from the bash shell. ls lists the contents of a directory: Using the -a flag displays hidden files: Using the -l flag formats the output in a long list: The file command gives us mor…
This demo shows you how to set up the containerized NetScaler CPX with NetScaler Management and Analytics System in a non-routable Mesos/Marathon environment for use with Micro-Services applications.

762 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

24 Experts available now in Live!

Get 1:1 Help Now