• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 174
  • Last Modified:

Win 2k not installing printer port

Hi Guys,

Have just installed win 2k, everything seems to be ok, with the exception of my printer, I have installed the correct printer drivers, however, nothing will print.
On further investigation,  there was an exclamation mark beside  LPT 1 in device manager, under properties there was the following message.... This device is disabled because the firmware of the device did not give it the required resources. (Code 29)...

The port and printer were fine under win 98, so I don't think it's failed hardware...

Any suggestions please???


1 Solution
have you tried deleting the port and running a new hardware scan?
GHOSTRIDERAuthor Commented:
Yup, couple of times, still comes up with the same message in properties.... Currently looking at a bios update for mainboard...
The BIOS upgrade should fix the problem. If not, start looking for a PNP printer card to add in.

I hope this helps !
Train for your Pen Testing Engineer Certification

Enroll today in this bundle of courses to gain experience in the logistics of pen testing, Linux fundamentals, vulnerability assessments, detecting live systems, and more! This series, valued at $3,000, is free for Premium members, Team Accounts, and Qualified Experts.

Doesn't sound like the printer...
Is your computer on the W2K hardware compatibility list (HCL)?  See <http://www.microsoft.com/hcl>
It's possible for a machine to work fine under W98 and not be 100 % compatible with W2K.
Good luck.
what type of computer? what make and model of printer?, try
changing the parallel port in your bios to ecp, or epp & ecp.
if you dont have that option in your bios, a bios upgrade is needed. also, if your printer is on the windows 2000 software and hardware compatibility list try installing service pack 1 for win2k.
in your bios i would suggest that you set it to SPP which is the standard parallel port mode.
Normally in EPP or ECP mode DMA 3 is used.
Try to find out if another device is using the same DMA. Or check the bios which address/irq and dma settings are currently assigned. Then in the lpt1 settings in the Device manager fill in the same settings by overriding the automatic settings.
Also SPP is an option because this mode don't use a DMA address, but you lose some speed.
GHOSTRIDERAuthor Commented:
ok, kinda got it sorted out, it seems to have been a resource allocation problem. Played around with manually allocating resources to prinbter port, managed to get the printer working but abracadabra my com1 port (with attached modem) vanished....modem still showes but trying to use it caused port not opened error.... grrrr....

so played around a bit more, managed to get com 1 com2 and printer to work at the same time. Bizzarely enough there are still exclamation marks beside the com ports.
What is particularly confusing is that at no time did 2k report a hardware conflict, but that is obviously what has been happening...



ps, the bios update didn't seem to make a damn bit of difference....
I would use winmsd to keep a safe copy of the settings. mark down the BIOS settings and consider updating your BIOS and/ or clearing the CMOS settings totally.

I'm glad at least something is working !!

GHOSTRIDERAuthor Commented:
Yah, got three copies of the current config scattered about, just in case...
 cheers guys...
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Hire Technology Freelancers with Gigs

Work with freelancers specializing in everything from database administration to programming, who have proven themselves as experts in their field. Hire the best, collaborate easily, pay securely, and get projects done right.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now