Red Hat 7.1 Telnet Question

Hello all you Linux gurus out there.

I've installed Red Hat 7.1 on serveral machines now.  I am not able to telnet into any of them.  Is that the way RH 7.1 ships?  If so, how do I enable it so that I can telnet into it?  
My RH 7.0 machines have no such problems.

Thanks.
LVL 1
MichaelcAsked:
Who is Participating?
 
vsamtaniCommented:
Check the /etc/xinetd.d/telnet file. Specifically look for the line "disable = yes" and if it's there, change it to disable = no and restart xinetd.



0
 
crouchetCommented:
Yes, that is the way RH 7.1 ships. Why? Because a lot of customers were asking them to tighten up security. They did a number of things, getting rid of or disabling some older, less secure programs and telnet was one of those.

Understand that telnet is probably the most wretchedly insecure protocol on the planet. All of it's communications are sent in plain text and all that is needed to view your work is a simple packet sniffer/assembler -- a common tool. When you telnet to a system and log on, that logon and password are available to anyone on your network who cares to look. It's kinda the cyber equivalent of walking around naked.

So what to do if you want to replace telnet? Use SSH. SSH uses strong encryption and secures your entire session starting with the logon itself. A lot of programs can use SSH for their communications protocol. Yes, you do have to learn how to set it up and master a few simple commands, but if you care about security at all SSH is the way to go.

BTW, my suggestion to RH was that they may security a selectable option in 7.1. I suggested profiles such as:

Secure -- Best security, but many protocols and functions are disabled for security reasons.

Normal -- A reasonably secure profile with more protocols and functions available. (basically what we got in 7.1)

Traditional -- Significantly less secure, but leaves many traditional protocols and functions such as telnet available. (like in 6.2)

None -- Passwords and other security features are disabled. WARNING: This creates a VERY insecure machine that is easily attacked from any outside connection. (Windoze users might not notice the difference.)

Custom -- Choose which protocols and functions to enable or disable. (starts from the "Normal" profile)

Maybe we can convince them to do this in their next release.

JC
0
 
MichaelcAuthor Commented:
Thanks for the info vsamtani.  That worked for me.

Thanks to crouchet also for the additional info.  Security doesn't mean all that much to me at this point but I will definately look into SSH.
0
 
MichaelcAuthor Commented:
Thanks for the info vsamtani.  That worked for me.

Thanks to crouchet also for the additional info.  Security doesn't mean all that much to me at this point but I will definately look into SSH.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.