Solved

Time, HELP got to have TIME!!!!!!!!!

Posted on 2001-06-16
4
179 Views
Last Modified: 2010-07-27
I'm out of ideas with this xinetd sh@t.
I need to get the time servers running.
daytime and time.
The ports are open and beinging listened to so
Xinetd knows about this much that's fine. Now here's the
problem. It doesn't return squat!!

I run telnet 192.168.1.1 daytime
and get
trying 192.168.1.1
Connected to 192.168.1.1
Escape character is '^]' .
Connection closed by foregin host.

Where the HELL IS MY DATE!!!!
I've updated and reinstalled xinetd and checked and
double checked the config file. Here's the message from startup:

xinetd[1412]: linuxconf disabled, removing
xinetd[1412]: ntalk disabled, removing
xinetd[1412]: exec disabled, removing
xinetd[1412]: talk disabled, removing
xinetd[1412]: tftp disabled, removing
xinetd[1412]: xinetd Version 2.1.8.9pre9 started with
xinetd[1412]: libwrap
xinetd[1412]: options compiled in.
xinetd[1412]: Started working: 9 available services
xinetd: xinetd startup succeeded

looks ok right?
so somebody tell me why I can't get my TIME?!?!?!
0
Comment
Question by:jscart
  • 2
  • 2
4 Comments
 
LVL 1

Author Comment

by:jscart
ID: 6198472
Oh yeah
RH 7.0
0
 
LVL 40

Accepted Solution

by:
jlevie earned 200 total points
ID: 6198933
They aren't working because the xinetd on the RH 7.0 CD is, well, slightly broken. You need to get and install the updated xinetd rpm from RedHat. Also you should know that the glibc from the CD is even more seriously broken and that needs to be updated also, as does the compiler, kernel... Well, shucky darn, there's just a whole bunch of updates that you should apply. I've got a script that I wrote to automate the process of applying the updates, which I'd be glad to share. If you'd like a copy, send an email to jim@entrophy-free.net.
0
 
LVL 1

Author Comment

by:jscart
ID: 6199673
I found the update an hour after posting this.
It's always in the last place you look after giving up.

Does anyone have an opinion on upgrade Vs. fresh install with Linux?
Have any problems? Need to reconfig everything? Did it wreck any systems?

I'm thinking of doing it but the box I have is production running lost of different services. I would prefer not to reconfig all of them.
0
 
LVL 40

Expert Comment

by:jlevie
ID: 6199781
Hmmm, my first thought would be, since you have the 7.1 kit, to just do the upgrade to 7.1. My experience so far is that this upgrade has worked every time, provided that you haven't futzed with things "out of band". By that I mean that you are either using only things installed from the RedHat 7.0 distribution, or that you removed any RedHat packages that needed to be replaced by a built from source or non-RedHat rpm. If you've "followed the rules" the upgrader can correctly identify the 7.0 packages that need to be upgraded and everything works properly. However, if you've futzed with things "out of band" there'll be trouble. Now to be fair about it, there'll also be trouble in applying the updates to 7.0 in that case.

I think that the 7.1 upgrade will preserve your existing configuation for those services (it certainly should). The only "gottcha's" that I've encountered so far with a 7.1 upgrade are with sendmail and bind. The sendmail issue is covered in the Release notes on the 7.1 CD and there can be issues with the named.conf file when moving from Bind 8 to Bind 9. Oh yeah, I've heard some folks complaining that the 2.4 kernel is slower than a 2.2 kernel. I've not experienced that myself so I don't know if there is any validity to that statement.

0

Featured Post

Is Your Active Directory as Secure as You Think?

More than 75% of all records are compromised because of the loss or theft of a privileged credential. Experts have been exploring Active Directory infrastructure to identify key threats and establish best practices for keeping data safe. Attend this month’s webinar to learn more.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I have seen several blogs and forum entries elsewhere state that because NTFS volumes do not support linux ownership or permissions, they cannot be used for anonymous ftp upload through the vsftpd program.   IT can be done and here's how to get i…
Note: for this to work properly you need to use a Cross-Over network cable. 1. Connect both servers S1 and S2 on the second network slots respectively. Note that you can use the 1st slots but usually these would be occupied by the Service Provide…
Here's a very brief overview of the methods PRTG Network Monitor (https://www.paessler.com/prtg) offers for monitoring bandwidth, to help you decide which methods you´d like to investigate in more detail.  The methods are covered in more detail in o…
You have products, that come in variants and want to set different prices for them? Watch this micro tutorial that describes how to configure prices for Magento super attributes. Assigning simple products to configurable: We assigned simple products…

930 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

14 Experts available now in Live!

Get 1:1 Help Now