• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 310
  • Last Modified:

Linux boot prob with Athlon 900

I've just upgraded my m/board and CPU from PII-266 to Athlon-900, and afterwards Linux will no longer boot. It crashes out right at the start, with a General Protection Fault when trying to disable the CPU serial no. (didn't know that Athlons have them?)

Tried re-installing the /boot and / partitions, and the RH installer boots a kernel ok to re-install, but then when rebooting off the HDD the same error again.

Any suggestions?
0
nat2000
Asked:
nat2000
1 Solution
 
superschlonzCommented:
I know that SuSE also had a problem with Athlon.

I'm not sure but I believe it was a problem in the startup code of the kernel,
and I can't remember which kernel it was, one of the older 2.2.X I think.

If you have another linux PC you could try to make a bootdisk with a newer
kernel. If not I think you have to build the new kernel with the old board.
0
 
superschlonzCommented:
Oh, I forgot, you could also download a floppy disk linux distribution and try with that.
0
 
psimationCommented:
Was the old kernel compiled specifically for P-II processor?
0
NEW Veeam Backup for Microsoft Office 365 1.5

With Office 365, it’s your data and your responsibility to protect it. NEW Veeam Backup for Microsoft Office 365 eliminates the risk of losing access to your Office 365 data.

 
nat2000Author Commented:
no - the wierd thing is that the kernel on the RH install cd-rom boots (but i couldn't see which one it was), but then the one it installs in /boot does not boot. I guess it may have picked a PII (or non-AMD compliant) kernel, but I have done a new install with the new board, and its done the same thing.

I have another Linux box (running with a PII board), on which I could compile a 2.4 kernel of some type - but how I would install it I don't know. I guess I could use the RH rescue thing, and mount the HDD?

0
 
superschlonzCommented:
Do you have the option to boot an installed system when using the
RedHat rescue disk ?
If yes you can boot your system this way (perhaps it gets some problems
with loading kernel modules, I think it's safer to first edit /etc/inittab and
set the default runlevel to S), and then install the new kernel and reboot.
0
 
nat2000Author Commented:
unfortunately, you can't boot an installed system using the rescue disk. It boots a kernel + shell from the cd then I guess you could mount the HDD from that to make changes.

I thought i might see if theres any boot options for the kernel to solve recognised problems with Atholon processors. can't find any docs on it though.

0
 
superschlonzCommented:
Is this rescue thing a cd ?

If yes you can build a new kernel on the other machine and put in on a floppy.

Assuming you have hda1 as /boot, hda2 as / and hda3 as swap you can mount
them this way:

mount /dev/hda2 /mnt
mount /dev/hda1 /
mount /dev/fd0 /mnt/mnt

copy the kernel and the modules and run lilo:

chroot /mnt /sbin/lilo
0
 
jlevieCommented:
Hmm, I know that RedHat 6.2, 7.0, & 7.1 will install and run properly on an Athlon 900... cause I've done it. Since you can boot and run the installer but can't boot the resultant system, I'd say that you have a motherboard problem. The installer's kernel is pretty severely stripped down and doesn't have a lot of the services and drivers that the installed kernel does.

First go back and double check the jumper config of the MB and make darn sure that it is properly set up for an Athlon. If you don't find a problem there see if you can arrainge with your supplier to try a different MB. Also make sure that you have the current BIOS in flash. I've seen a number of MB's come in with old and slightly broken verions of the BIOS installed. Another check would be to see if NT or Windows 2000 Pro will install. My bet is that they are likely to fail also.
0
 
m931a2Commented:
Have you checked the BIOS to see if you have setting for disableling the PII ID?

Just a thought.

Mark
0
 
Scott SilvaNetwork AdministratorCommented:
Here is your answer from the following page;
http://www.redhat.com/support/alex/163.html

Topic: Athlon Problems

Canned Answer Number: 163

Issue:

I get the following when booting my Red Hat Linux 6.2 system on my Athlon computer:
Disabling CPUID Serial Number : general protection fault:0000 CUP: 0 VIP:
0010:[] EFLAGSFLAGS0282 exa:
0ex0020 ebx: 0exc500 ecx:..


Resolution:

This is easy to fix for the stock Red Hat Linux 6.2 release. You can do it one of two ways: the easy way and the hard way.
The Easy Way At the LILO: prompt type: linux x86_serial_nr=1 Then after booting, log in as root and edit /etc/lilo.conf, adding this line to the first or "global" section of the file: append="x86_serial_nr=1" Next, run LILO by issuing this command: /sbin/lilo -v -v This will write the changes to the disk.
The Hard and Unsupported Way Recompile your kernel and turn off the "Disable P-III CPUID" feature. This issue was fixed in the 2.2.16-3 kernel upgrade errata available at this URL: http://www.redhat.com/support/errata/RHSA-2000-037-05.html 
0
 
CleanupPingCommented:
nat2000:
This old question needs to be finalized -- accept an answer, split points, or get a refund.  For information on your options, please click here-> http:/help/closing.jsp#1 
EXPERTS:
Post your closing recommendations!  No comment means you don't care.
0
 
fciiiCommented:
No comment has been added lately, so it's time to clean up this TA.
I will leave a recommendation in the Cleanup topic area that this question is:

PAQd and points to scott_silva

Please leave any comments here within the next seven days.

PLEASE DO NOT ACCEPT THIS COMMENT AS AN ANSWER!

fciii
EE Cleanup Volunteer
0

Featured Post

Free Tool: Subnet Calculator

The subnet calculator helps you design networks by taking an IP address and network mask and returning information such as network, broadcast address, and host range.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now