Solved

Update RH

Posted on 2001-06-17
9
293 Views
Last Modified: 2013-12-06
I have a lot of updates to apply to my RH6.0 installation.  I first have to update RPM.  I downloaded the files from the RH FTP site fine.  When I issue
rpm -Uvh rpm*rpm
I get ERROR:failed dependencies and the indication that it needs libdb-3.1.so and libpopt.so.0.  I have been unable to find these files on my system (no surprise) and on the FTP site.  What are the indications here and how can I fix the problems it is causing.  Any better suggestion for updating the system files/kernel?
0
Comment
Question by:slink9
  • 6
  • 2
9 Comments
 
LVL 17

Expert Comment

by:dorward
ID: 6200572
Search for the files on http://www.rpmfind.net/ that should list RPMs which contain those files.

Then you can install multiple RPMs are once like so:

rpm -Uvh rpm1.rpm another.rpm more.rpm

and so on.

However as you have such an old version of Red Hat you might want to consider upgrading to 7.1, I can't say how good the upgrade system on it is as I have never used it, but it is supposed to work for version 6.
0
 
LVL 5

Expert Comment

by:vsamtani
ID: 6201652
I'd agree with dorward - it's probably much less work in the long run to simply get a 7.1 cd and install from fresh. From your other question it appears that you're using this system to learn Linux, and it would be much better to learn the newest kernel and utilities than an old version.

By the way, cheap Linux cds are available from www.cheapbytes.com (RH 7.1 for <$10) or www.linuxemporium.co.uk in the UK.

Vijay

0
 
LVL 23

Author Comment

by:slink9
ID: 6201675
I am trying to updtae it to 7.1 and have all of the update rpms on a CD.  It is just a matter of being able to install them.  Whenever I can get RPM to recognize those files I will be off and rolling.  I have d/l db3-3.1.17-7 and -5 and -4.  The first two gave an error message that only packages with major numbers <= 3 are supported by this version of rpm.  I am d/l the -4 now and will see how it goes.
0
 
LVL 23

Author Comment

by:slink9
ID: 6202018
I had time to play with this before coming to work.  The -4 seemed to be the fix for that.  Now I have to install the RPM files in the order specified and I should be up and running.  I will have to do that tonight after work.  I will check in after 5 (EDT) and hopefully close this one.  Thanks for the help.
0
Maximize Your Threat Intelligence Reporting

Reporting is one of the most important and least talked about aspects of a world-class threat intelligence program. Here’s how to do it right.

 
LVL 23

Author Comment

by:slink9
ID: 6210483
I gave up on that, installed TurboLinux, got frustrated with it, and reinstalled RH with the decision to use the version I currently have.  After learning more about this kernel release I may update later.  Give me some pointers on getting my network card running and the points are yours!!
I have the NIC installed and on it's own IRQ.  I have run through the installation routine in the book I have but still get Failed when booting and trying to start eth0.  Any suggestions?
0
 
LVL 23

Author Comment

by:slink9
ID: 6215956
The problem with the NIC is that it is jumperless and I don't believe I have the proper address for it.  How can I run the configure program within Linux for the Etherlink XL?  Is there a Linux program for configuring this NIC or should I go through the DOS emulation to run it?  Will Cardfind work for this?
0
 
LVL 23

Author Comment

by:slink9
ID: 6221549
Okay, I found the fix for the NIC.  Now I have Gnome in a video mode that is not readable and no knowledge of how to boot without it.  dorward, you answered the previous (but now moot) question promptly and accurately.  Is there an equivalent to SAFE MODE in Linux where I can either boot Gnome with a standard video setup or boot without loading Gnome?
0
 
LVL 17

Accepted Solution

by:
dorward earned 100 total points
ID: 6221748
Once you get to the GUI log in (boy to I hate GUI logins!) do this:

Alt+Ctrl+F2

That should take you to a console

Now log in as root

Run the following command:

init 3

This will tell the system to turn off the GUI log on (but doesn't set it as the deafult)

Then you can run your config tool to change the X settings.
0
 
LVL 23

Author Comment

by:slink9
ID: 6222163
Good job.  It worked fine.  I will log in as root and run Xconfigurator to get around this.  Have some more points for the trouble.
0

Featured Post

How to improve team productivity

Quip adds documents, spreadsheets, and tasklists to your Slack experience
- Elevate ideas to Quip docs
- Share Quip docs in Slack
- Get notified of changes to your docs
- Available on iOS/Android/Desktop/Web
- Online/Offline

Join & Write a Comment

I. Introduction There's an interesting discussion going on now in an Experts Exchange Group — Attachments with no extension (http://www.experts-exchange.com/discussions/210281/Attachments-with-no-extension.html). This reminded me of questions tha…
The purpose of this article is to demonstrate how we can use conditional statements using Python.
Learn how to navigate the file tree with the shell. Use pwd to print the current working directory: Use ls to list a directory's contents: Use cd to change to a new directory: Use wildcards instead of typing out long directory names: Use ../ to move…
Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.

708 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

12 Experts available now in Live!

Get 1:1 Help Now