• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 207
  • Last Modified:

Replication error?

Hi,

I have a database which is replicated to several servers. It has a search facility using FTSearch which I develop on server A an it works perfectly. It is replicated to server B which also works perfectly. But server C doesn't work as it should - Searching for the same criteria returns 2 documents on servers A & B, but none on C, although the documents *do* exist in the database on C.

Any suggestions as to what might cause this strange behaviour? Server C is the administration server...

Thanks
Andrew.
0
ANDREAG
Asked:
ANDREAG
  • 2
1 Solution
 
mfay72Commented:
Are you sure that the full text index was updated correctly on Server C?
0
 
ANDREAGAuthor Commented:
I was sure the index was updating (it's set to Daily), but when I checked, it's size was 149mb on server C, but only 27mb on the others. The "Create Index" settings are the same on all servers, so I don't understand why they should be different.
0
 
mfay72Commented:
One thing I found sometimes helps is clearing the replication history, and remove any date that might be listed. Then re-replicate. Then update the full-text index again. This might solve the problem.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now