installing java on linux

everytime I start linux , I need to type

export PATH=/usr/java/jdk1.3.1/bin:$PATH

inorder for me to run java command
Is there way to eliminating that step, If there is, how do you do it?
kuichan2Asked:
Who is Participating?
 
superschlonzConnect With a Mentor Commented:
If you are using bash you can add this line at the end of the file
/etc/profile (that's not in your home directory, the first slash means
absolute path) You can also add it to your .profile in your home
directory but then the PATH is set only for you, not for other users
on the system.

If you are using csh then the files are /etc/csh.cshrc and .cshrc
int the home directory.

It's long time ago since I last used csh but I belive to remember
that you would have to write it this way for csh:
setenv PATH "$PATH:/usr/java/jdk1.3.1/bin"
0
 
superschlonzCommented:
Add this line to /etc/profile
0
 
kuichan2Author Commented:
where am i adding this line? .cshrc? What is that do?
0
 
CleanupPingCommented:
kuichan2:
This old question needs to be finalized -- accept an answer, split points, or get a refund.  For information on your options, please click here-> http:/help/closing.jsp#1 
EXPERTS:
Post your closing recommendations!  No comment means you don't care.
0
 
paullamhkgCommented:
No comment has been added lately, so it's time to clean up this TA.
I will leave a recommendation in the Cleanup topic area that this question is to:

Accept superschlonz's Comments as answer

Please leave any comments here within the next seven days.

PLEASE DO NOT ACCEPT THIS COMMENT AS AN ANSWER!

Paul
EE Cleanup Volunteer
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.